Modify

Opened 7 years ago

Closed 6 years ago

#1074 closed bug (fixed)

Slow internet with IPV6 and Wifi bridge mode

Reported by: alecrovel@… Owned by:
Priority: normal Milestone: Firmware 2.3.7.0
Component: fon-wifi Version: 2.3.7.0 beta1
Severity: unknown
Cc: Hardware: 2.0n (FON2300)

Description

Hello, I have issues with wifi bridge mode, i think it’s related of the ipv6 connection. Dmesg give me this ( a lot of times ) : IPv6MacTableLookUp(): dstMac=00:21:85:XX:XX:XX for mapped dstIPv6(5840:9882:b4c9:XXXX:XXXX:XXXX:XXXX:XXXX) This slow down considerably the fonera and internet is very bad. For now, i fixed this thing with disabling ipv6 on my computers but sound not too good. Any good fixes ? Thanks,

Attachments (1)

dmesg.txt (15.5 KB) - added by alecrovel@… 7 years ago.
Dmesg for debugging

Download all attachments as: .zip

Change History (6)

Changed 7 years ago by alecrovel@…

Dmesg for debugging

comment:1 Changed 7 years ago by alecrovel@…

For now,i tested a lot the wifi bridge mode
and sometimes some paquets (but very very little) are lost when i ping ( on local network ).
I think i'm close to my internet wifi router and i didn't have any issues with other bridge.Even the svn firmware fonera 2.0n found work better.
I don't know if it's related with this bug
For the ipv6 problem,my provider is Free (Also nammed proxad) and give us ipv6 native connectivy.
Also this bug happend after a long time (like 1 day) not immediatly,it's look like the fonera is overheating and seems to crash. If someone had an idea,please tell me.

comment:2 Changed 7 years ago by matthijs

  • Milestone set to Firmware 2.3.7.0
  • Status changed from new to investigate

comment:3 Changed 6 years ago by matthijs

  • Status changed from investigate to infoneeded

Is this problem still occuring for you with beta3?

This message is originating from the wifi driver. When in wifi-bridge mode, the wifi driver performs a kind of MAC-address NAT, and this message originates from that code. If I read the code correctly, the driver is outputting this message for every package coming through, which is of course not a very good idea.

However, in the beta3 version of the (compiled) driver, grep doesn't find the message anymore. Looking more closely, it seems that this is because CONFIG_RT2860V2_AP_MEMORY_OPTIMIZATION is turned on in the beta3 version of the driver, which disables debug messages from the wifi driver.

I hope that your problem was in fact that the debug prints were taking so much time, the system was becoming slow. If so, the problem should be fixed in beta3. If not, there might be a different problem, possibly even unrelated to the debug messages you were seeing that we need to investigate separately.

comment:4 Changed 6 years ago by alecrovel@…

It seems that the problem is solved,

I'm using the latest svn version (r2165) and there is not messages about " IPv6MacTableLookUp() ... " anymore.

Thanks for your great job.

comment:5 Changed 6 years ago by matthijs

  • Resolution set to fixed
  • Status changed from infoneeded to closed

Cool, thanks for reporting back!

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.