Modify

Opened 8 years ago

Last modified 6 years ago

#1078 confirmed bug

music plugin does not play specific mp3 files/streams

Reported by: micaelopes@… Owned by:
Priority: normal Milestone: Firmware 2.3
Component: fon-plugin-music Version: 2.3.7.0 beta3
Severity: unknown
Cc: Hardware: 2.0n (FON2300)

Description (last modified by matthijs)

I installed music plugin in firmware 2.3.7 beta and it doesn't work.

When I want to listen music or insert a link to a stream server it says that is an invalid stream or 'Audiod is not running

Audiod, the music playing application, does not seem to be running right now. This usually indicates it has crashed or was never started. It will probably help to unplug and replug your USB audio card to restart audiod.'

If I connect to fonera by SSH and try to start audiod shows the text above:

root@Fonera:~# audiod
scanning for audio channel
found VOLUME
skipping
found PCM
using channel id 4
found SPEAKER
skipping
found PCM
skipping
found ALTPCM
skipping
found PHONEOUT
skipping
we have a client!
About to add fd 6
Client 6 disconnected
we have a client!
About to add fd 6
Client 6 disconnected
we have a client!
About to add fd 6
Client 6 disconnected
we have a client!
About to add fd 6
Client 6 disconnected
we have a client!
About to add fd 6
got token -> "STOP"
got token -> "LIST"
loading /tmp/myplaylist.m3u
found an entry "/tmp/mounts/kasaHD/music/VA-As.40.da.Cidade.FM-2010-UpPTMSNM (05-02-2011)/VA-As.40.da.Cidade.FM-2010-UpPTMSNM (05-02-2011)/Afrojack  Eva Simons - Take Over Control.mp3"
loaded /tmp/myplaylist.m3u
got token -> "MODE"
got token -> "START"
playing file : /tmp /tmp/mounts/kasaHD/music/VA-As.40.da.Cidade.FM-2010-UpPTMSNM (05-02-2011)/VA-As.40.da.Cidade.FM-2010-UpPTMSNM (05-02-2011)/Afrojack  Eva Simons - Take Over Control.mp3
scan_mp3(): fixed rate mp3, time 2147483647, num frames 2147483647
duration is = -2126008813
Segmentation fault

Simultaneosly I go to fonera and try to play a music until the message Segmentation fault is shown in the ssh connection...

I tried to insert the following links for stream server http://sradio.tv/asx/1090.asx http://sradio.tv/stream/1090.m3u

Can you help me?

Attachments (0)

Change History (10)

comment:1 Changed 8 years ago by matthijs

  • Status changed from new to infoneeded
  • Type changed from request to bug

It looks like you're trying to play an MP3 (Afrojack Eva Simons - Take Over Control.mp3) and that it contains an error or something else that the mp3 decoder breaks on. Perhaps you should try different mp3's to see if this occurs with all files or just some files?

comment:2 Changed 8 years ago by micaelopes@…

Hello,

The error occurs with all files. And why is not possible stream with the link I sent?

comment:3 Changed 7 years ago by matthijs

  • Description modified (diff)

comment:4 Changed 7 years ago by matthijs

I had a closer look at this ticket, and it seems there are really two separate problems.

  1. The music plugin does not support MMS audio streams, only HTTP (you can't really tell from the url, since the m3u contains a link to the asx stream, which contains a link to an MMS stream). I've created ticket #1142 for supporting this protocol, but that's not something that's easily done.
  2. The mp3 file you were trying to play somehow confuses the MP3 decoder or the sound card is somehow doing unexpected things, causing a segfault.

I'd like to further investigate the segfault issue in this ticket. Since you say the segfault happens for all mp3 files you have, it might be a problem with your soundcard, or the way your mp3 files were encoded. I'm having no problems here, so it's not totally broken. We'll have to find out what breaks it exactly.

I've found a (very short) mp3 testfile that properly works on my setup. Could you see if your Fonera can play it as well? You can download the file here: http://download.linnrecords.com/test/mp3/recit.aspx (don't let the url confuse you, it actually saves an mp3 file).

comment:5 Changed 7 years ago by matthijs

  • Milestone set to Firmware 2.3.7.0

comment:6 Changed 7 years ago by matthijs

  • Milestone Firmware 2.3.7.0 deleted
  • Resolution set to moreinfoneeded
  • Status changed from infoneeded to closed

I'm closing this issue, for lack of response. If you ever get around to testing this, feel free to leave a comment and we can reopen this issue.

comment:7 Changed 7 years ago by matthijs

  • Resolution moreinfoneeded deleted
  • Status changed from closed to reopened
  • Summary changed from music plugin does not work to music plugin does not play specific mp3 files/streams
  • Version changed from 2.3.7.0 beta1 to 2.3.7.0 beta3

I just found some mp3's in my own collection that fail to play with the music plugin (For my own reference: these are my Caro Emerald mp3 files). Hopefully this is the same problem you were running into.

I'm not sure if we can still fix this in time for 2.3.7.0, but at least we can have another look at this issue at some point.

comment:8 Changed 7 years ago by matthijs

On more thing I already found out: It seems that libmad craps out with a LOST_SYNC error. When audiod tells libmad to continue anyway, Then, libmad throws a BADLAYER error, which audiod also instructs libmad to ignore, causing a segfault. Just for future reference. I made some small changes to audiod to slightly improve error reporting, I'll commit those in the future.

comment:9 Changed 7 years ago by matthijs

(In [2135]) audiod: Slightly improve error reporting.

Any mad errors are now reported on stderr (which is still invisible for regular users, but may help debugging). Also, instead of ignoring all errors, default to stopping the playback of the current file on an error, which should at least prevent audiod from segfaulting.

References: #1078

comment:10 Changed 6 years ago by matthijs

  • Milestone set to Firmware 2.3
  • Status changed from reopened to confirmed

Add Comment

Modify Ticket

Action
as confirmed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.