Modify

Opened 7 years ago

Closed 6 years ago

#1130 closed bug (duplicate)

3G quits trying to redial

Reported by: mihaly.reg@… Owned by:
Priority: normal Milestone:
Component: fon-network-3g Version: 2.3.7.0 beta2
Severity: unknown
Cc: Hardware: 2.0g (FON2202)

Description

When 3g network is busy fonera connected to 3g dongle quits trying to redial after some attempts. This is blocking the possibility to finally find a free slot. And if the user does not checks logread he has ni clue why it's not reconnecting. The problem happens usually afternoon when more users are using the operator's network. Tried to connect to same 3G network directly with an android phone and it works fine, the problem is in fonera. My guess is that android is trying automatically to redial, but i can't prove this with logs right now. Attached the fonera log where i can see that the connect script is exited, then nothing happens for long time.

Attachments (1)

puttywf-fonera-quits-reconnect-script.log (105.4 KB) - added by mihaly.reg@… 7 years ago.

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by mihaly.reg@…

comment:1 Changed 7 years ago by matthijs

  • Status changed from new to investigate

Are you sure this is caused by a busy network? From the logread you posted, it seems the 3G dongle just doesn't reply _anything_ to the dial command (it should reply with "OK", or "NOCARRIER" when no signal was ready yet. Not sure what it should reply when the network is busy, but not replying _anything_ isn't really helpful...).

Not sure how we can fix this either... Commonly, a 3G dongle that stops replying doesn't magically start working if you just start over.

comment:2 Changed 7 years ago by mihaly.reg@…

I'm just guessing that the network is busy because the problem happens always only afternoon. After 23:00 it works again without moving the router/single. Signal is 9,99...11.99, i think it's enough. Btw..what means the digits 9.99? Also could be a bug in E160X but I can't test others, none i have is compatible w f2g except e160. It's possible to create a reset cycle if 3g modem is not responding? Of course only when it's necessary.

comment:3 Changed 6 years ago by matthijs

  • Resolution set to duplicate
  • Status changed from investigate to closed

I'm marking this as a duplicate of #1118, which is probably the same issue.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.