Modify

Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#1137 closed bug (fixed)

fon status, the graphs not getting updated

Reported by: chirag.sanghavi@… Owned by:
Priority: normal Milestone: Firmware 2.3.7.0
Component: fon-web Version: 2.3.7.0 beta3
Severity: minor
Cc: micaelopes@… Hardware: 2.0n (FON2300)

Description

in 2.3.7.0 beta, the status graphs are not getting updated. The stats for traffic is not visible.

Attachments (1)

main.htm (2.9 KB) - added by matthijs 7 years ago.
Fixed version of /usr/lib/lua/luci/view/fon_status/main.htm

Download all attachments as: .zip

Change History (11)

comment:1 Changed 7 years ago by ct1aic@…

I also have same problem. I'm using Firmware Version: 2.3.7.0 Beta 2 Developer's version in my LaFonera? 2.0n and I can't get any data from Dashboard >> Status.

I'm using a laptop PC with Windows 7 Ultimate 64 bits via WLan.

With Firefox 9.0.1 and Google Chrome 16.0.912.77 m, I get all graphics, but at the end of the page, a "Loading ..." message and no data or refresh of the page.

With IE9, I only get the first graphic (traffic on vpn) and same message "Loading ...".

With production version, it was working. Is it a bug of this beta?

comment:2 Changed 7 years ago by matthijs

  • Cc micaelopes@… added
  • Status changed from new to confirmed

#991 is a duplicate (and suggests this issue also occurs with 2.3.6.1)

Changed 7 years ago by matthijs

Fixed version of /usr/lib/lua/luci/view/fon_status/main.htm

comment:3 follow-up: Changed 7 years ago by matthijs

  • Component changed from unknown to fon-web
  • Milestone set to Firmware 2.3.7.0
  • Severity changed from unknown to minor
  • Status changed from confirmed to testing-fix
  • Version changed from 2.3.7.0 beta2 to 2.3.7.0 beta3

I found the problem: The status display was trying to display data for the VPN interface, which "crashed" the status display if OpenVPN was not enabled.

I suspect this has been broken for quite some time, but I'm not sure since when.

I've attached a fixed version of main.htm to this ticket. To install it, run the following command on your Fonera:

root@Fonera:~# wget -O /usr/lib/lua/luci/view/fon_status/main.htm http://trac.fonosfera.org/fon-ng/raw-attachment/ticket/1137/main.htm

Could you check if this fixes the problem for you and comment back here?

This fix also fixes #544, which caused the displayed values to be twice as much as they should.

comment:4 follow-up: Changed 7 years ago by jfgthomassen@…

I created a SSH connection succesfully and pasted the complete command and the response was Not found. And I ran into Paco the alpaca -)

comment:5 in reply to: ↑ 3 Changed 7 years ago by ct1aic@…

I accessed the Fonera via SSH with user root, gave the command and the status is now working, giving graphics. Not even a restart was needed. Many thanks for your kind help and support.

Now it would be nice to select other colors for the incoming or outgoing, as it's difficult to differentiated them...

Best regards. Rui @ Portugal CT1AIC

root@Fonera:~# wget -O /usr/lib/lua/luci/view/fon_status/main.htm http://trac.fo nosfera.org/fon-ng/raw-attachment/ticket/1137/main.htm Connecting to trac.fonosfera.org (67.192.249.56:80) main.htm 100% |*| 2958 --:--:-- ETA root@Fonera:~#

Replying to matthijs:

I found the problem: The status display was trying to display data for the VPN interface, which "crashed" the status display if OpenVPN was not enabled.

I suspect this has been broken for quite some time, but I'm not sure since when.

I've attached a fixed version of main.htm to this ticket. To install it, run the following command on your Fonera:

root@Fonera:~# wget -O /usr/lib/lua/luci/view/fon_status/main.htm http://trac.fonosfera.org/fon-ng/raw-attachment/ticket/1137/main.htm

Could you check if this fixes the problem for you and comment back here?

This fix also fixes #544, which caused the displayed values to be twice as much as they should.

comment:6 in reply to: ↑ 4 Changed 7 years ago by anonymous

Replying to jfgthomassen@…:

I created a SSH connection succesfully and pasted the complete command and the response was Not found. And I ran into Paco the alpaca -)

You need to copy/paste the command without CR/LF. Copy/paste from this page and not from the email.

Best regards. Rui @ Portugal CT1AIC

comment:7 Changed 7 years ago by jfgthomassen@…

Now it's working ! I copied too much ... Status is working well now ! Thank you ! ( I included root@fonera: in my copy/paste the first time)

comment:8 Changed 7 years ago by chirag.sanghavi@…

Yes it is working.

comment:9 Changed 7 years ago by matthijs

Good, thanks for testing.

About making the colors easier to differentiate, good idea. I think that shouldn't be too hard, so I'll have a quick look at that as well.

comment:10 Changed 7 years ago by matthijs

  • Resolution set to fixed
  • Status changed from testing-fix to closed

(In [2132]) luci: Only show existing interfaces in traffic status.

Before, alle networks in /etc/config/network were shown, even when the corresponding interface did not exist (and thus produces no data). Since the OpenVPN network is always listed in the configuration, but does not exist when OpenVPN is not enabled, this would cause the status display to break, since there was no data for the tun-ovpn interface (breaking all others graphs as well).

This change makes sure that only graphs for existing interfaces are shown, making the graphs work again when OpenVPN is enabled. I'm not entirely sure when this got broken exactly, but this seems like the proper fix for the problem.

Closes: #1137

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.