Modify

Opened 7 years ago

Closed 6 years ago

#1185 closed bug (moreinfoneeded)

DHCP on WLAN does not deliver DNS entries / DNS options in /etc/config/dhcp not working

Reported by: anonymous Owned by:
Priority: normal Milestone:
Component: fon-network Version: 2.3.6.1 (Gari jr.)
Severity: unknown
Cc: Hardware: 2.0n (FON2300)

Description

Hello,

I suppose since a few weeks my WLAN clients do not get any DNS address anymore from the FONERA 2.0N firmware V.2.3.6.1 ... I think it still worked in April '12, and now when I tried a new ANDROID device I noticed that it does not work anymore ... As I am using the DEV firmware I tried to add dhcp-option 6 with DNS-addresses into /etc/config/dhcp by using UCI but that did not work either ...

Any ideas ?

regards,

Jürgen

--snip--

File /etc/config/dhcp:


config 'dnsmasq' option 'domainneeded' '1' option 'boguspriv' '1' option 'filterwin2k' '0' option 'localise_queries' '1' option 'local' '/lan/' option 'domain' 'lan' option 'expandhosts' '1' option 'nonegcache' '0' option 'authoritative' '1' option 'readethers' '1' option 'leasefile' '/tmp/dhcp.leases' option 'resolvfile' '/tmp/resolv.conf.auto'

config 'dhcp' 'lan' option 'interface' 'lan' option 'start' '100' option 'limit' '150' option 'leasetime' '12h' list 'dhcp_option' '6,192.168.1.1,208.67.220.220,208.67.222.222'

config 'dhcp' 'wan' option 'interface' 'wan' list 'dhcp_option' '6,192.168.1.1,208.67.220.220,208.67.222.222' option 'ignore' '1'

Attachments (0)

Change History (5)

comment:1 follow-ups: Changed 7 years ago by matthijs

  • Component changed from unknown to fon-network
  • Status changed from new to infoneeded

If I understand your problem correctly, you're saying that clients that connect to your wireless network do not get any DNS server through DHCP? This would mean their internet connectivity is completely broken, is that indeed the case?

There should be no reason to manually add options to the dnsmasq config, the /etc/fonstated/RestartDnsmasq should take care of setting this up automatically.

Did you make any other customizations to the Fonera, other than changing settings through the webgui?

Does the issue apply to all clients, or just particular ones?

comment:2 in reply to: ↑ 1 Changed 7 years ago by anonymous

Replying to matthijs:

Yes, exactly. All IP-number based traffic etc is running well, I can browse with the webserver only on IP-number-based links. Indeed, the clients do not get ANY DNS server by DHCP anymore ... IP-assignment of dynamic and fixed IP-addresses plus gateway and netmask are still running fine. Effected are not only my new ANDROID tablets, but XP and WIN7 wireless clients as well.

In the moment, I can use just static configurations, what's not a big deal, but anyway the problem is nerving and quite weird, as it was working some time ago w/o problems ...

My FONERA 2.0N has its uplink via a 3G wireless modem on the USB port as I have no DSL or cable connection in the moment. And that 3G modem is there since quite a while ...

I have not done any other manual change in the config, I always have used the WEBGUI before.

If I understand your problem correctly, you're saying that clients that connect to your wireless network do not get any DNS server through DHCP? This would mean their internet connectivity is completely broken, is that indeed the case?

There should be no reason to manually add options to the dnsmasq config, the /etc/fonstated/RestartDnsmasq should take care of setting this up automatically.

Did you make any other customizations to the Fonera, other than changing settings through the webgui?

Does the issue apply to all clients, or just particular ones?

comment:3 in reply to: ↑ 1 Changed 7 years ago by j.k.zick@…

Replying to matthijs:

Forgot to say, that I also tried thru the webgui to use both 3G DNS server options, a static setup as well as the dynamic one in the 3G setup section. I can see in the dashboard that the DNS address of the 3G link is changing, but nothing happens on the clients' side ...

If I understand your problem correctly, you're saying that clients that connect to your wireless network do not get any DNS server through DHCP? This would mean their internet connectivity is completely broken, is that indeed the case?

There should be no reason to manually add options to the dnsmasq config, the /etc/fonstated/RestartDnsmasq should take care of setting this up automatically.

Did you make any other customizations to the Fonera, other than changing settings through the webgui?

Does the issue apply to all clients, or just particular ones?

comment:4 Changed 7 years ago by matthijs

Normally, the Fonera should advertise a DNS server of 192.168.10.1 (i.e., itself) through DHCP. The clients then send DNS request to the Fonera, which sends these onto whatever DNS server is configured on the Fonera (or obtained automatically through the WAN connection).

I have a few questions to help find out what's going on:

  • Does the problem occur all the time, or does the DNS work for a while after powering up the Fonera?
  • Can you paste the output of the "ipconfig /all" command, run from one of your Windows clients while the problem is occuring?
  • Can you paste the output of the following two commands, run on the Fonera through SSH while the problem is occuring?
    root@Fonera:~# ps aux
    root@Fonera:~# cat /proc/`pidof dnsmasq`/cmdline
    root@Fonera:~# cat /etc/config/dhcp
    root@Fonera:~# cat /etc/resolv.conf 
    root@Fonera:~# ls -l /etc/resolv.conf 
    
  • Does it help if you configure a static DNS server, like Google's 8.8.8.8 ?

See the reportbugs page for info on running commands through SSH and pasting the results.

comment:5 Changed 6 years ago by matthijs

  • Resolution set to moreinfoneeded
  • Status changed from infoneeded to closed

As part of the upcoming 2.3.7.0 firmware release, we're reviewing old open tickets to see if they are still relevant, which is why you get this response now.

If this issue still occurs with the 2.3.7.0 rc2 firmware, feel free to leave a comment here so we can further investigate.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.