Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1186 closed bug (fixed)

Performance issues with NTFS + Transmission not well documented

Reported by: guandalf@… Owned by:
Priority: normal Milestone: Firmware 2.3.7.0
Component: fon-plugin-transmission Version: 2.3.7.0 beta3
Severity: normal
Cc: Hardware: 2.0n (FON2300)

Description

Hi,

overral performance drops a lot when transmission is running. As an example, DNS queries drops from tenths of milliseconds to hundreds of milliseconds, samba transfers drops to less than 500 KB/s and so on.

Attachments (0)

Change History (9)

comment:1 Changed 7 years ago by matthijs

  • Component changed from unknown to fon-plugin-transmission
  • Status changed from new to infoneeded

Is this different from earlier firmware releases?

It's known that Transmission needs quite some (CPU) power to run, so performance dropping is somewhat expected. If the Fonera is not your main router (and thus does not have to do NAT), you can try running in bridge mode, which delegates more of the network traffic to the hardware.

Also, I've seen Transmission to pretty much block up the Fonera directly after adding a new torrent, while it writing a big empty file to store the downloaded data in. After a few minutes, performance should improve again. Perhaps this is what you're seeing?

Finally, perhaps you're using an NTFS disk with Transmission? This is known to be very slow, due to the complex structure of the NTFS filesystem.

comment:2 Changed 7 years ago by guandalf@…

I'm quite new to Fonera 2.0n. I used Fonera with last stable revision for one week then I moved to 2.3.7.0 beta 2, because of these performance issues, but also because the twitter configuration was not working, nor it was the transmission client. I could switch to a different network configuration but the point is that by default the Fonera uses a NAT configuration, 95% of external drives out there are formatted with NTFS (mine also) and most of the people gets a Fonera to use as their primary router. If it is not usable in this default configuration, it's likely to get a bad feedback. Sorry for the complaints but they are just because I love the project and the hardware very much and I felt a little disappointed when I found out there was so serious limitations. That said, you can close this ticket. Thank you.

comment:3 Changed 7 years ago by matthijs

  • Milestone set to Firmware 2.3.7.0
  • Status changed from infoneeded to confirmed
  • Summary changed from Performance issues when transmission is running to Performance issues with NTFS + Transmission not well documented

I guess the NTFS thing was less of an issue when the 2.0g (and thus this firmware) was originally created, I think FAT32 was still pretty standard back then. I agree with your point that this has (long) turned to NTFS, making the default setup crappy. I'm afraid there's not much we can do actually fix this situation: NTFS together with Transmission is just too much load for the 2.0n CPU.

However, I can see if I can add a notice to the Transmission page in the webinterface, to at least warn people that they have a non-optimal configuration.

comment:4 Changed 7 years ago by matthijs

  • Status changed from confirmed to testing-fix

I added a notice to my local tree, as well restructuring some internals to allow displaying the filesystem of each partition.

comment:5 Changed 7 years ago by matthijs

  • Severity changed from unknown to normal

comment:6 Changed 7 years ago by matthijs

(In [2161]) mountd: Include the mount name in uci state.

References: #1186

comment:7 Changed 7 years ago by matthijs

(In [2162]) mountd/plugin-torrent: Restructure disk listing

Instead of looking at /tmp/mounts, it looks through the uci state to find valid mounts with a fmg image installed or for installing the fmg mount.

Doing this allows us to get at extra info about the mount, such as the filesystem used.

To prevent the luci code from becoming more complicated by this, the separate "install" page in plugin-torrent is removed. Instead of doing the startup (and install if there is only one free partition) on one page and the install from another page (if there are multiple free partitions), there is now a single page that shows all partitions and allows starting up from installed partitions and installing to free partitions

References: #1186

comment:8 Changed 7 years ago by matthijs

  • Resolution set to fixed
  • Status changed from testing-fix to closed

(In [2163]) luci-torrent: Warn not to use NTFS and flash devices.

Closes: #1186

comment:9 Changed 7 years ago by matthijs

(In [2164]) luci-torrent: Show filesystem used for each partition.

References: #1186

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.