Modify

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1187 closed bug (moreinfoneeded)

Wifi breaks down when 2 or more devices are connected via Ethernet

Reported by: cmertes@… Owned by:
Priority: normal Milestone: Firmware 2.3.7.0
Component: fon-wifi Version: 2.3.7.0 beta3
Severity: unknown
Cc: Hardware: 2.0n (FON2300)

Description

I think this behaviour appeared first in 2.3.7.0 Beta 2 but I might have missed it earlier:

My HTPC is connected permanently to my Fonera 2n router over a switch but as soon as I plug in one laptop (either directly into the Fonera or into the switch), the other being connected wirelessly experiences a drop in ping time from 20ms or so to over 7 seconds (!) and a huge increase in package loss, too. This means no more name resolution which means “Internet’s dead” basically. As soon as I pull the Ethernet plug, the ping time creeps back to normal.

This is still happening in Beta 3. In the changelog since then I don't see anything related to this problem so it's probably not worth trying unless you disagree.

It's unlikely that it's the fault of the laptop since it doesn't matter which device is connected wirelessly and which over Ethernet.

Attachments (0)

Change History (12)

comment:1 Changed 7 years ago by matthijs

Hmm, on first sight, I really can't think of any reason why this is happening. It's not that the Fonera only supports one client: My whole network is connected through my Fonera, without any problems. So, to find out what's happening in your case, some questions:

  • When this problem occurs, only the wireless client is having problems and both wired clients are ok?
  • Does the problem occur with any device, or just these two laptops?
  • Does the problem occur when the HTPC is powered off?
  • Does the problem occur when you replace the HTPC by another ethernet device (if you have one)?
  • Does the problem occur when both laptops are connected wirelessly?
  • Could you doublecheck if this occurs with 2.3.6.1 and/or beta1 as well?
  • Can you check the CPU load of the Fonera when the problem occurs (run the top command through SSH, terminate it using control-C)?
  • Can you check the Fonera's log when the problem is occuring (run the logread command through SSH)?

See the reportbugs page for more info on SSH commands and pasting the output.

comment:2 Changed 7 years ago by matthijs

  • Status changed from new to infoneeded

comment:3 Changed 7 years ago by matthijs

  • Milestone set to Firmware 2.3.7.0
  • Type changed from request to bug

comment:4 Changed 7 years ago by cmertes@…

I will answer these questions in the same order:

  • Yes, only the wireless clients are having problems (running totally different systems: Linux, Windows and WebOS (although that is Linux technically)), the wired clients are fine.
  • We have three laptops, two running Linux and one running Windows and any one of them causes the problem IIRC. Although I focused my testing on the two Linux laptops. I will try the Windows one again but as I don't have access to it right now, this will have to wait until the end of this week I'm afraid. I can then also try to power off the HTPC and have only two wired laptops running to see if this causes the same problems. I very much think so but you never know until you tried it out.
  • No, the clients have to be running. This is true for the HTPC and for the laptops.
  • I haven't tried but I will (see above)
  • No, Wifi devices don't seem to cause the problem, no matter how many (and there I have more with my tablet and the mobile phones).
  • Yep, will do. I will post the result separately.
  • The only thing that's using some CPU (about 5%) is transmission which happens to be broken but that's a story for another bug I guess.
  • The log is a bit unusable because it shows several "starting transmission" -- "transmission has stopped" messages per second. I'd like to switch it off but that's not possible because the web interface is not displaying the according button anymore. It doesn't display much to be exact but again, that's for another bug. But unfortunately this means that the log is flooded with transmission messages and doesn't contain anything that might have happened before.

comment:5 Changed 7 years ago by matthijs

I quickly read your comment, I'll replay in more depth later. One quick comment: Apparently Transmission is not properly starting, causing it to keep trying over and over. To work around this, you can remove the torrent files from the "FoneraApps?" directory on the USB stick, this should completely remove the Transmission app (you can optionally reinstall it if you want).

comment:6 Changed 7 years ago by cmertes@…

Beta 1 seems to fix the problem and it was there in Beta 2. So that's the window. There are no daily builds before Beta 2 AFAICS so I can't narrow it down any further I guess.

comment:7 Changed 7 years ago by cmertes@…

The trick for the transmission problem worked, thanks! It doesn't seem to be related though because with Beta 1 transmission was broken but wifi works nonetheless.

comment:8 Changed 7 years ago by cmertes@…

Sorry, bad news. When I tried it with Beta 1 the problem did indeed not occur. But apparently it just took a while to manifest ... somehow. Now unexpectedly I involuntarily tested it and again, I could not connect via Wifi. Disconnecting the other laptop too fixed the problem :/ I will try an even older firmware but not today.

comment:9 Changed 7 years ago by matthijs

Ok, that means that we should be careful with interpreting test results: If the problem does not seem to occur, it's not guaranteed that it won't appear later...

I've read your answers in some more detail and I'm still quite clueless as to the cause. I'd very much like to see the logread output and hear if 2.3.6.1 does work (that version contains a different wifi driver version, so if that version works, it might a problem in the wifi driver).

On additional question: When the problem occurs, do all wireless client suffer from it, or just some?

I'll await your further test results :-)

comment:10 Changed 7 years ago by matthijs

  • Resolution set to moreinfoneeded
  • Status changed from infoneeded to closed

I'm closing this issue for lack of a response. If this issue is still relevant, feel free to leave a comment.

comment:11 Changed 7 years ago by cmertes@…

I'm very sorry: I missed the other mail. The problem hasn't been occurring for a very long time now. So from my point of view it can be considered fixed.

comment:12 Changed 7 years ago by matthijs

Ok, thanks for reporting back. Perhaps a software update on one of the connected devices fixed the problem or something...

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.