Modify

Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#1188 closed enhancement (fixed)

The possibility of changing the port number of openvpn server ??

Reported by: gabriel.schwartz@… Owned by:
Priority: normal Milestone: Firmware 2.3.7.0
Component: fon-plugin-openvpn Version: 2.3.7.0 beta3
Severity: minor
Cc: Jon, "The, Nice, Guy", Spriggs, <jon@…>, steven@… Hardware: both

Description

Hi, Exists the possibility to change port number udp/tcp 1194 for other by GUI ? My ISP and others to block 1194. Thanks a lot.

Attachments (1)

0001-Resolving-albeit-not-in-a-pretty-way-ticket-1188.patch (2.9 KB) - added by Jon "The Nice Guy" Spriggs <jon@…> 7 years ago.
git format-patch of this.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by matthijs

  • Cc Jon "The Nice Guy" Spriggs <jon@…> added
  • Milestone set to Firmware 2.3.7.0
  • Severity changed from unknown to minor
  • Status changed from new to confirmed
  • Type changed from request to enhancement

Good plan, I'll try to get that in for 2.3.7.0.

This setting probably needs some kind of notice that changing the port number also needs the same change in all client configurations.

Jon, since you've been doing some OpenVPN work recently, I'm adding you the CC. Perhaps you'd like to tackle this one as well?

comment:2 Changed 7 years ago by Jon "The Nice Guy" Spriggs <jon@…>

Sorry, completely missed this. I'll try and get a look in tonight. It's probably worth making it offer TCP or UDP as well as changing the port too.

comment:3 Changed 7 years ago by matthijs

Agreed

comment:4 Changed 7 years ago by matthijs

  • Cc steven@… added

#1020 is a duplicate of this ticket.

comment:5 Changed 7 years ago by gabriel.schwartz@…

Jon & Math thanks in advance-. great idea UDP/TCP port.

Changed 7 years ago by Jon "The Nice Guy" Spriggs <jon@…>

git format-patch of this.

comment:6 Changed 7 years ago by Jon "The Nice Guy" Spriggs <jon@…>

Patch submitted.

comment:7 Changed 7 years ago by matthijs

  • Hardware changed from 2.0n (FON2300) to both
  • Status changed from confirmed to testing-fix

I also applied this patch locally and will push it to SVN this week.

I made a few minor changes to the translation strings.

comment:8 Changed 7 years ago by matthijs

  • Resolution set to fixed
  • Status changed from testing-fix to closed

(In [2176]) luci-openvpn: Allow changing the protocol and port used.

Thanks to Jon Spriggs for this patch.

Closes: #1188

comment:9 Changed 6 years ago by matthijs

(In [2246]) openvpn: Fix copy-paste error in default protocol.

This value was only used when no protocol was specified in the openvpn configuration, which should not normally happen, so this error shouldn't have caused any problems.

References: #1188

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.