Modify

Opened 7 years ago

Closed 6 years ago

Last modified 5 years ago

#1190 closed enhancement (fixed)

wrong time zone offset setting

Reported by: post@… Owned by:
Priority: normal Milestone: Firmware 2.3.7.0
Component: fon-base-firmware Version: N/A
Severity: normal
Cc: Hardware: both

Description

If I take a look at the time on my fonera it it is shown in standard time zone format "UTC". It should be possible to set the time zone offset (UTC/GMT +/- x hours). This could be done manually or automatically by using the "Country-Setting" of the Dashboard WiFi?-Settings. The correct time (time zone) is needed for example for the scheduled time settings in Transmission BitTorrent? client.

Attachments (0)

Change History (8)

comment:1 Changed 7 years ago by matthijs

  • Hardware changed from 2.0n (FON2300) to both
  • Milestone set to Firmware 2.3.7.0
  • Severity changed from unknown to normal
  • Status changed from new to confirmed
  • Type changed from bug to enhancement
  • Version changed from 2.3.7.0 beta3 to N/A

Sounds like a plan. Connecting this to the wifi country or language setting is probably not the best plan, since those might not reflect the timezone correctly.

I had a look at the timezone support in uclibc, seems that it supports setting the timezone in /etc/TZ. The format of this file is a fairly verbose string, that should read something like CET-1CEST,M3.5.0,M10.5.0/3. Since that describes the timezone very precisely, but not very friendly, we'll need some kind of mapping from friendly names to precise names. I had a look around in the OpenWRT sources and we can probably create something using this file (have to check licensing, though).

comment:2 Changed 7 years ago by matthijs

Seems that using that timezone.conf.xml file is ok. I traced it back to commit 505e326 in the freeswitch project, which contains MPL licensed and public domain code. Arguably, such a database of timestamps is not even really protected by copyright law in the first place anyway.

I'll see if I can transform the file into something that works for luci (I don't think there's any XML parser on the Fonera right now).

comment:3 Changed 6 years ago by matthijs

  • Status changed from confirmed to testing-fix

I added a timezone selection setting to the "Language" settings page in my local tree. I'll do some more testing and then push this out to the SVN repository.

comment:4 Changed 6 years ago by matthijs

  • Resolution set to fixed
  • Status changed from testing-fix to closed

(In [2143]) luci: Allow changing the timezone.

Since Transmision offers scheduling downloads, having the timezone fixed to UTC is not longer sufficient. This commit adds a database with timezone information and adds a setting to the "Language" setting page to change the Timezone.

Since changing the timezone at runtime is tricky (running applications might not see the change, but new applications will) the timezone change is not applied at all until the next reboot.

Closes: #1190

comment:5 Changed 6 years ago by giuseppeg88@…

Currently the timezone change is not applied at all until the next reboot. This change can be made ​​immediately with also the writing of the file "/etc/TZ".

comment:6 Changed 6 years ago by matthijs

This is intentional, as stated in the commit message:

Since changing the timezone at runtime is tricky (running applications might not see the change, but new applications will) the timezone change is not applied at all until the next reboot.

We can write to /etc/TZ, but that might not produce the intended effect for all applications, so instead we just force a reboot. This is also documented on the timezone settings page.

comment:7 Changed 6 years ago by giuseppeg88@…

Ops! I had missed that sentence ;-)

comment:8 Changed 5 years ago by RichardPt

F-15e 299 was rolled out bristling with military condition threat games. https://my.swu.edu/ICS/icsfs/tabfen78.html?target=b18da53c-a2a3-46a9-bdea-bb0032463a9e Engineering efforts are supplied as operations of sample surgeons.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.