Modify

Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#1221 closed bug (fixed)

Set channel witdh to 20 MHz

Reported by: shareAir.net <post@…> Owned by:
Priority: normal Milestone: Firmware 2.3.7.0
Component: fon-wifi Version: 2.3.7.0 beta3
Severity: minor
Cc: Hardware: 2.0n (FON2300)

Description

After installing fon-ng-r2193 I noticed, that the Fonera sometimes doubles the bandwidth per channel to 40 MHz (20/40 MHz autoswitch?). In 2.4 GHz, enabling this option takes up to 82% of the unlicensed band! Please set the channel witdh by default to "20 MHz" and add an option for "20/40 MHz Auto"

Attachments (0)

Change History (10)

comment:1 Changed 7 years ago by matthijs

  • Hardware changed from unknown to 2.0n (FON2300)
  • Status changed from new to infoneeded

There is a switch for this, in Settings -> Wireless you can switch between HT20 and HT40. However, this switch is only available when you select 11n-only mode, since AFAIU, HT40 mode is onlyl available when running in 11n-only mode. Or are you seeing HT40 mode when running in one of the other modes as well?

comment:2 Changed 7 years ago by shareAir.net <post@…>

I am using the mixed g/n mode. The WiFi? scanner inSSIDer showes me, that the Fonera sometimes doubles the bandwidth per channel to 40 MHz in mixed g/n mode.

comment:3 Changed 7 years ago by matthijs

  • Milestone set to Firmware 2.3.7.0
  • Severity changed from unknown to minor
  • Status changed from infoneeded to confirmed

I did some more research, turns out HT40 mode is also supported in bgn and gn modes. Since it is on by default and can only be disabled in n-only mode, this causes HT40 mode to be always on in bgn and gn modes, which is obviously not correct.

We'll make sure this gets fixed before 2.3.7.0, thanks for reporting!

comment:4 Changed 7 years ago by matthijs

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [2194]) ra_wifi: Allow disabling HT40 in bgn and gn modes.

Previously, the code assumed that HT40 mode was available only when running in n-only mode, so it did not offer enable/disable controls in other modes. However, HT40 mode is also available for 11n clients in bgn and gn modes. Since the HT40 mode defaulted to enabled in non-n-only modes, this meant that HT40 was enabled and could not disabled in bgn and gn modes.

This commit allows toggling HT40 mode in bgn and gn modes as well. In addition, it sets HT40 mode to disabled for the other (b and bg) modes, just in case.

Closes: #1221

comment:5 Changed 7 years ago by matthijs

Could you confirm if the latest SVN autobuild solves this problem for you?

http://download.fonosfera.org/auto-builds/fon-ng/fon-ng-r2195/fonera2n/

comment:6 Changed 7 years ago by shareAir.net <post@…>

The HT20, HT20/HT40 switch is now available in g/n mode. But I have never seen a channel width of 40 MHz when using the HT20/HT40 mode (even after rebooting the Fonera). Are you sure it does switch?

BTW: Would it not make more sense to set HT20 as default instead of HT20/HT40. Enabling HT40 takes up to 82% of the 2.4 GHz band (think about your neighbors)!

comment:7 Changed 7 years ago by matthijs

Your saying that, with the new firmware, it no longer uses 40Mhz at all?

Could you check the /tmp/RT2860.dat file? It should contain:

HT_BW=1      

Meaning HT40 is enabled.

As for disabling HT40 by default, I'm a bit hesitant about that, since AFAIU it also means we limit the 2.0n to 150Mbps by default, which might come as surprise to people. Additionally, switching the default is only effective when we actually produce new 2.0n units with a newer firmware, or when people do a factory reset, since settings are normally preserved (and we can't tell if a user really wants HT40 mode or just left it at the default...)

Still, we'll consider switching the default setting, I'll get back on that.

comment:8 Changed 7 years ago by shareAir.net <post@…>

Could you check the /tmp/RT2860.dat file? It should contain:
HT_BW=1

HT_BW=1 is set correctly. But I can not see a channel width of 40 MHz in the Tool inSSIDer.

comment:9 Changed 6 years ago by matthijs

I did a bit of testing for this yesterday and also found that HT40 mode is usually not enabled for my connections. However, I did get a HT40 connection once, without any apparent configuration changes to trigger this. This leads me to believe that the wifi driver is very cautious with enabling HT40 mode and disables HT40 mode when it detects any (or a lot of, not sure) other (legacy) devices in the same channels.

Having said that, I wonder if the previous versions of the firmware did enable HT40 mode always. If so, perhaps there is some other new problem, but if not, perhaps you just checked for HT40 at some time when it was incidentally enabled...

comment:10 Changed 6 years ago by matthijs

A bit more digging in the code and some more testing shows that the wifi driver indeed checks the spectrum for other access points and disables HT40 mode if there are other access points on adjacent channels it would be interfering with.

There are some differences in the code between the 2.3.6.1 version and the 2.3.7.0 version in this area, which apparently cause the 2.3.6.1 to detect the other access points but not fall back to HT20 mode, whereas 2.3.7.0 correctly falls back. I suspect this is a bug in the older driver and that the new driver behaves correctly.

So, it seems there is no problem in the current firmware: It will enable HT40 mode when it does not detect any interfering access points only.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.