Modify

Opened 7 years ago

Closed 6 years ago

#1223 closed request (support)

Audiocli homepage after installing over new beta 3

Reported by: tom@… Owned by:
Priority: normal Milestone:
Component: fon-plugins Version: 2.3.7.0 beta3
Severity: unknown
Cc: Hardware: 2.0n (FON2300)

Description

It was reported but marked as solved. However this old program installed w/o problems and it sat there in the interface doing just nothing? AudioCli? v3 available from the ftp site.. But probably after rebooting it now shows the errors of AudioCli? in stead of the homepage to login to the Fonera2.0n

It is otherwise working as I last left it, so port 8080 must be working and I can give you the password of the external address..

Or how can I login and comment the line where the AudioCli? is loaded, or remove it again and all traces of it?

Regards, Tom

Attachments (0)

Change History (13)

comment:1 Changed 7 years ago by matthijs

  • Status changed from new to infoneeded

What error are you getting exactly?

Also, which audiocli app did you have installed exactly? Perhaps you can provide the link to the FTP site?

Did you recently install this program and did the problems occur after the first reboot, or did you install it longer ago?

comment:2 Changed 7 years ago by anonymous

http://lafonera.lan

I think I installed AudioCli? version 0.3 of last year

output:

error loading module 'audiocli' from file '/usr/lib/lua/audiocli.so':

File not found

stack traceback:

[C]: ? [C]: in function '?' ?: in function '?' ?: in function <?:96> (tail call): ? ?: in function 'dispatch' ?: in function <?:150>

Outside IP address :

http://****.dyndns.org (port 8080) (only port > 1023 are open to external, maybe SSH will be an exception)

comment:3 Changed 7 years ago by tom@…

I can't use repy on your e-mails, they get rejected.

The AudioCli? 0.3 version was on this very ftp site of Fonera itself ! Question is if you can login, or either I can get instructions on how to use SSH and ptty to get in and change the loading or uncomment the AudioCli?... Future versions may prevent the loading of older software that screws up the Fonera?

Regards, T

comment:4 Changed 7 years ago by anonymous

Hi Tom,

commenting here is preferred anyway, since that keeps public history :-)

As for my question about the FTP link, I am genuinely unsure what application you are referring to exactly. In recent firmwares, we have the music plugin and I think that it used to be called audiocli before. Since I'm not sure how what the exact problem is, I'm not sure how to fix it either.

Some ideas:

  • You could do a factory reset. This reverts to a clean firmware without any applications installed (version will remain beta3, or whatever it is now, though). However, this will also throw away all of your settings, so be sure to make a settings backup before this (Note: there is a chance that your DDNS settings panel will break if you do a settings restore, this should be fixed by upgrading to the soon-to-be-released 2.3.7.0 rc1 version).
  • You could login through SSH and see if there is a file called /usr/lib/lua/luci/controller/ audiocli.lua or something similar
  • You could login through SSH, open up the file /etc/config/plugfons and remove any section related to audiocli from that file.

See reportbugs for more info on running commands through SSH.

comment:5 Changed 7 years ago by tom@…

OK, fresh factory reset would be my last option. I can use Putty.

I have removed the lines from the option "audiocli" in the plugfons file with vi, using dd and ZZ. Now after rebooting the audiocli still tries to load. There is a file audiocli.sua in the controller directory, it contains binary data. What command should I use on this?

comment:6 follow-up: Changed 7 years ago by matthijs

Try "rm /usr/lib/lua/luci/controller/audiocli.lua" that should simply remove the file.

comment:7 in reply to: ↑ 6 Changed 7 years ago by anonymous

Replying to matthijs:

Try "rm /usr/lib/lua/luci/controller/audiocli.lua" that should simply remove the file.

I had renamed the file audiocli.sua (which is the same result as deleting for the boot order, but now it still tries to load AudioCli? and redirect the http folder but now there at http://192.168.10.1/luci/audiocli it says : {{"Not Found"}}. So where is that loader file? I tried finding still other audiocli references with WinSCP program for easier contents reading...No luck, I'm not familiar with the boot process I guess.

comment:8 Changed 7 years ago by tom@…

So the plugoptions file contained some redirect="1" that I hadn't removed as last line. Now I have the login back, but at the dashboard i get the following : {{ bad argument #1 to '?' (table expected, got nil) stack traceback:

[C]: in function '?' ?: in function <?:603> (tail call): ? ?: in function <?:71> (tail call): ? ?: in function 'dispatch' ?: in function <?:150>

}}

I guess I'm close now, probably the pluginfon file contents doesn't end correctly now as I removed the redirect line , last line.

comment:9 Changed 7 years ago by matthijs

Perhaps you could run the following command to find all files with "audiocli" in them?

root@Fonera:~# find / |grep audiocli

Alternatively, you could just do a settings backup and factory reset? I had intended to tell you how to do that through SSH, but seems I forgot. A settings backup is created by running "save-config.sh", which will create a file called "/tmp/sysypgrade.tgz", which you should download (you can upload it later through Settings -> System -> Settings Update). The factory reset is done with the command "factory.sh" (you might need to reboot the Fonera after that with the "reboot" command or a power cycle).

comment:10 Changed 7 years ago by tom@…

The grep instruction was great but too many entries, I considered myself out of luck and tried your factory reset, loaded the .tgz file but besides the DynDNS settings screwup I also lost all port forwarding settings... No big deal, just some search work again... When's the RC1 scheduled? I'll definitely take a bigger dive inside linux and the inside of "lua"...:-) Thanks..

comment:11 Changed 7 years ago by matthijs

Good to hear it's working again for you!

I'm hoping to release RC1 early next week.

To get your ddns config page working again right now, try this command: "cp /rom/etc/config/ddns /etc/config" (not sure if it works, but I think it should.

As for the port forwarding settings being gone, that's weird. Do you mind sending me your sysupgrade.tgz so I can try to find out what happened? I'd like to rule out a bug in the firmware that could affect other users. Note that your wifi password is stored inside the sysupgrade.tgz, so if you trust me to treat that confidentially, please send me the tgz file by mail to matthijs at stdin.nl

comment:12 Changed 7 years ago by matthijs

Or matthijs.kooijman at fon.com (perhaps that inspires a bit more trust :-)

comment:13 Changed 6 years ago by matthijs

  • Resolution set to support
  • Status changed from infoneeded to closed

Through mail discussion, all problems seem to have been solved, so I am closing this ticket.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.