Modify

Opened 6 years ago

Last modified 6 years ago

#1236 infoneeded bug

Picasa upload does not always work.

Reported by: matthijs Owned by:
Priority: normal Milestone:
Component: fon-plugin-picasa Version: 2.3.7.0 rc2
Severity: unknown
Cc: charudattu@… Hardware: unknown

Description

On the blog, Charudatt reports that Picasa uploads are not working for him:

Picassa uploader does not seem to be working, gives an error , but shows as done, and tweets too.

I tried entering my credentials but did not work. The Fonera Dashboard shows uploading, at the very end of the progress bar shows an error , creates a folder called DONE and creates some files done_picasa, I also get a tweet, saying that I have successfully uploaded it (becos , I have enabled it) , but nothing gets uploaded.

Charudatt, two more questions: You say "entering your credentials did not work". Do you mean that the credentials were not accepted (input fields turn red after clicking save), or do you mean re-entering the credentials did not help to fix the upload problem.

Could you try logging in with SSH, run the "logread" command shortly after a failed upload and attaching / pasting the output here? See reportbugs for more info on running commands on your Fonera.

Attachments (2)

glider.png (724 bytes) - added by matthijs 6 years ago.
Test image
upload.rar (875.1 KB) - added by Charudatt 6 years ago.
I tried with these files

Download all attachments as: .zip

Change History (7)

Changed 6 years ago by matthijs

Test image

comment:1 Changed 6 years ago by matthijs

  • Status changed from new to infoneeded

On more thing: I tested the picasa upload here and it worked as expected, so there must be something specific in Charudatt's environment that breaks the upload.

Charudatt, to rule out that the actual file uploaded is relevant, I've attached the test image that I've used to this ticket. Could you try if you can upload that glider.png file?

comment:2 Changed 6 years ago by Charudatt

@Fonera team : No the credentials were ok but it did not upload even then. But suprisingly the .png file uploaded and only that uploaded on the site. All others in the que gave error.

I guess, it has to do something with the file type, I am trying to upload .jpg (approx 250Kb size) and has a space in the file name. I had , earlier uploaded similar file but after the upgrade it behaved erratically. OK, I need to investigate if the file name has to do anything with it.

Thanks for the help, more on it later, tomorrow.

comment:3 Changed 6 years ago by matthijs

Your observations indeed suggest that there is something in the file or filename that breaks the upload.

I just tried uploading the glider.png renamed to "glider space.png", as well as a 300K big JPG with and without a space in the filename, all of which worked as expected.

Perhaps there is some other special thing about your filename, or otherwise perhaps the file content. Let me know if you find out, or perhaps you can send me the problematic file so I can try to reproduce the problem here (feel free to send it to matthijs.kooijman@… if you don't want to make it public in this bug report).

Changed 6 years ago by Charudatt

I tried with these files

comment:4 Changed 6 years ago by Charudatt

I have uploaded some files , which I tried. Now if the results come out positive, I guess, it leaves me with only one conclusion, that there's some problem with my account then.

Thank you.

comment:5 Changed 6 years ago by matthijs

I just tried the JPG files you uploaded and all of them uploaded succesfully...

I uploaded them by connecting to my Fonera through Windows Filesharing (samba) and copying the files into the "picasa" folder.

Perhaps you can get the output of the logread command, to see if there is anything useful in there?

Add Comment

Modify Ticket

Action
as infoneeded The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.