Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1240 closed bug (fixed)

Openwrt Packages support is broken

Reported by: steven@… Owned by:
Priority: normal Milestone: Firmware 2.3.8.0
Component: fon-buildsystem Version: 2.3.7.0 (Paco)
Severity: minor
Cc: Hardware: 2.0n (FON2300)

Description

steps to reproduce

  • go to your fon-ng svn checkout
  • cd openwrt ./scripts/feeds update

notice how many "makefile" errors you get.... eg : usbip, bitlbee, asterisk, ...

Attachments (0)

Change History (5)

comment:1 Changed 6 years ago by matthijs

  • Milestone set to Firmware 2.3
  • Severity changed from unknown to minor
  • Status changed from new to confirmed

I've done a review of some of the errors I noticed and fixed a few in my local tree.

There's still a bunch of errors left after these fixes (in particular "overriding commands for target clean" messages, caused by packages doing both host and target builds), but those require invasive changes to the build system (e.g., r14610, r14621, and more), which would cost too much time right now.

I'm testing building with these fixes / workarounds applied right now, when they work as expected, I'll commit them.

comment:2 Changed 6 years ago by matthijs

(In [2262]) build-system: Optimize metadatascanning.

This backports r14734 from OpenWRT trunk almost literally.

In addition to optimizing the metadata scanning, it also prevents some package Makefiles from being read twice. This duplication would cause make warnings, which would again cause the feed update script to output "please fix" messages.

References: #1240

comment:3 Changed 6 years ago by matthijs

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [2263]) build-system: Add dummy uclibc++ and nls makefiles.

This shoudl allow a few packages from the OpenWRT packages feed to build for the Fonera. The upstream versions of these files allow switching between libc++ implementations and enabling localization, but we just add empty files to make the Makefiles work again, while sticking to the defaults.

Closes: #1240

comment:4 Changed 6 years ago by matthijs

(In [2264]) Fix package configuration metadata scanning.

In r2262, the metadata scanning was optimized by backporting a patch from OpenWRT. However, a trailing space got left out of that commit (I probably removed it manually by way of cleanup...). It seems that without this space, the package info file cannot be parsed properly, making all configuration options for packages break. Since this causes busybox to be compiled with all options disabled, for example, this produces images that cannot boot.

References: #1240

comment:5 Changed 6 years ago by matthijs

  • Milestone changed from Firmware 2.3 to Firmware 2.3.8.0

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.