Modify

Opened 6 years ago

Last modified 4 years ago

#1242 infoneeded bug

Samba access denied on 2.3.7.0 Paco

Reported by: mihaly.reg@… Owned by:
Priority: normal Milestone: Firmware 2.3
Component: fon-base-firmware Version: 2.3.7.0 (Paco)
Severity: unknown
Cc: Hardware: 2.0n (FON2300)

Description

Upgraded Fonera 2n from beta3 to 2.3.7.0 Paco final. Problem: samba stopped working, access denied to Disc-A1 or Media. Error: C:\>net use R:
192.168.0.2\Disc-A1 /user:fonero my...pass System error 5 has occurred. Access is denied. Tested on Windows XP SP3.

Attachments (1)

samba (392 bytes) - added by tman <mihaly.reg@…> 6 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 6 years ago by mihaly.reg@…

Note: changed the root password and rebooted. Does not help, same error.

comment:2 Changed 6 years ago by tman <mihaly.reg@…>

Now it's working! Since yesterday I have rebooted the PC, today tried again a net use command and worked.

C:\>net use R:
192.168.0.2\Disc-A1 /user:fonero my ...passw The command completed successfully.

comment:3 Changed 6 years ago by info@…

I tried again to do so ... indeed i already tried but rebooted (not physical switch off)and did not wait .. I mean might be it has to expir the ip lease, but in thi case my computers and devices have fixed ip ... I tried also to reboot (again not physical swith off) the fonera but w/o any success.

comment:4 Changed 6 years ago by matthijs

  • Milestone set to Firmware 2.3
  • Status changed from new to infoneeded

Hmm, weird. It seems that "System error 5" is just a generic "Access Denied" message, so not much help there.

Mihaly, since the problem disappeared for you, I'm afraid debug info from your Fonera is no longer really useful...

casaleva, could you attach / paste the contents of the /etc/config/samba file on your Fonera?

Some ideas:

  • Perhaps the "Anonymous login" setting of Samba on the Fonera is set incorrectly?
  • Perhaps the system time is not being updated on the Fonera. You can check using the "date" command through SSH (note that the Fonera runs in UTC by default, which shouldn't be a problem).

casaleva, which Windows OS version are you using?

Changed 6 years ago by tman <mihaly.reg@…>

comment:5 Changed 6 years ago by matthijs

One more question: When this problem occurs, is smbd running (check with "ps aux|grep smbd"). I just booted a Fonera where smbd didn't properly start (even though nmbd did)...

comment:6 Changed 6 years ago by matthijs

I haven't been able to reproduce this "samba won't start" condition now, even after a few reboots, but I remember it seeing it once or twice before. Perhaps it only occurs directly after a firmware upgrade or something (though I don't think I just upgraded this particular Fonera...). In any case, this samba not starting is probably a real issue, not just some one-off weirdness.

In the meanwhile, I tried your net use command on my Windows XP machine after killing smbd on my Fonera, and I indeed got the same access denied system error 5 message. This suggests that in your case, smbd also didn't start properly. Could you confirm this?

When this system error 5 occurred, did it occur right away for you, or did the net use command take some 20-30 seconds to produce the error?

comment:7 Changed 6 years ago by tman

I can't recall if it was 5sec or 30sec. Sorry.

comment:8 Changed 6 years ago by tman

Now I can't reproduce this error. It happened only after the upgrade, now is working fine.

comment:9 Changed 6 years ago by tman <mihaly.reg@…>

This problem is back again. After it was up for months, today I had to reboot (by ssh) the F2n and after that the samba share access was denied to my LG media player, and also for PC. However SCP and FTP works. The password works for ssh, ftp and scp, it is denied only for samba. Changed the password. Samba still does not work. Reboot (by webpage system reboot). After reboot the new password worked fine for
192.168.0.2\Media, and listed in explorer the folder 'Files', but acces to this folder is denied. But access to
192.168.0.2\Files is fine ! It works from PC and LG also. It looks like reboot by console is not good for samba. Did not tested extensively, but I think this scenario worth to be be analyzed further.

comment:10 Changed 6 years ago by matthijs

Note that in 2.3.7.0 there is a bug that the Media share does not work, you'll have to use the individual share for each drive. See #1243

comment:11 Changed 6 years ago by matthijs

As for the difference between rebooting through the commandline and rebooting through the webui, it seems that the webui runs an ifdown wan and ifdown lan before rebooting. Perhaps that causes the TCP connections to be closed properly, preventing connected samba clients from somehow going into some state that causes samba to return access denied.

On the other hand, the theory was that somehow samba fails to start after the reboot, which I can't imagine being related to (not) shutting down the network connections properly. Perhaps there really is not difference, except that the first reboot breaks the connectivity and the second reboot (or perhaps even just waiting for a bit) fixes it again?

If this breaks again, could you check if smbd is running?

comment:12 Changed 5 years ago by tman <mihaly.reg@…>

Tried some actions to reproduce this issue, without luck.

comment:13 Changed 4 years ago by RichardPt

Compressing the home reduces its church. https://my.swu.edu/ICS/icsfs/tabfen81.html?target=f1a38988-0a51-4cfb-9a70-b1c667879b0d We widely demand hormonal breathing, giving the controversies the healing and evaporation air under the cone and second-generation.

Add Comment

Modify Ticket

Action
as infoneeded The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.