Modify

Opened 6 years ago

Last modified 6 years ago

#1259 infoneeded bug

Transmission keeps restarting while "rejecting IO to dead device" messages appear

Reported by: tman <mihaly.reg@…> Owned by:
Priority: normal Milestone:
Component: fon-base-firmware Version: 2.3.7.0 (Paco)
Severity: unknown
Cc: Hardware: 2.0n (FON2300)

Description (last modified by matthijs)

logread shows this on my fonera:

Apr  6 07:08:31 Fonera user.err kernel: scsi 0:0:0:0: rejecting I/O to dead device
Apr  6 07:08:31 Fonera user.err kernel: scsi 0:0:0:0: rejecting I/O to dead device
Apr  6 07:08:31 Fonera user.notice root: transmission has stopped
Apr  6 07:08:31 Fonera user.notice root: starting transmission
Apr  6 07:08:31 Fonera user.err kernel: scsi 0:0:0:0: rejecting I/O to dead device
Apr  6 07:08:31 Fonera user.err kernel: scsi 0:0:0:0: rejecting I/O to dead device
Apr  6 07:08:31 Fonera user.err kernel: scsi 0:0:0:0: rejecting I/O to dead device

The scenario is not clear at this time, I have not used/accessed the fonera for a while. Today logged in and looked at logread for another problem. Transmission was not running torrents, was just installed some time ago.

I had seen this error also a couple of months ago, but not sure which version was. Opened this ticket just to not forget about the problem. Will add more info later.

Attachments (1)

ssh_192.168.0.2_20130406_100507.zip (11.4 KB) - added by tman <mihaly.reg@…> 6 years ago.
logread

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by tman <mihaly.reg@…>

logread

comment:1 Changed 6 years ago by matthijs

  • Description modified (diff)

comment:2 Changed 6 years ago by matthijs

  • Component changed from unknown to fon-base-firmware
  • Status changed from new to infoneeded
  • Summary changed from rejecting IO to dead device to Transmission keeps restarting while "rejecting IO to dead device" messages appear

This is mostly a symptom of another underlying problem. Your logreads show no indication of _why_ the disk got disconnected, only the fallout of this.

However, the first logread in your zip shows that the Fonere keeps trying to start transmission, even though the disk is no longer working. I thought that mountd was supposed to stop this process when the disk got removed, but it could be that it needs the stop.sh script from the Transmission disk (which is no longer available) to do this. This would need some investigation.

It seems that between the first and second logread in your zip, the problem went away. Do you remember what you did inbetween?

comment:3 Changed 6 years ago by mihaly.reg@…

Apr 6 07:08:43 Fonera user.err kernel: scsi 0:0:0:0: rejecting I/O to dead device root@Fonera:~# reboot

After reboot the problem dissapeared.

Add Comment

Modify Ticket

Action
as infoneeded The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.