Modify

Opened 4 years ago

Closed 4 years ago

#1327 closed bug (duplicate)

permission problem in samba (wide links= no)

Reported by: conan747 Owned by:
Priority: normal Milestone:
Component: unknown Version: 2.3.7.0 (Paco)
Severity: unknown
Cc: Hardware: 2.0n (FON2300)

Description

When I updated my fonera 2.0n firmware to version 2.3.7 I started having problems with my disk share. I could mount it in my computer and I could navigate to the fonera:/Media/ExternalHD/, but then it showed that it was empty and if I tried to "ls" on it it would give me a permission error.

I traced the error to the /tmp/smb.conf file. It seems that on this version of the firmware a line is added for each share that says: wide linds = no

I deleted this line, killed smbd and restarted it again and my shares worked perfectly.

Now, the problem is that every time I restart the fonera (or I run root@Fonera:~#/etc/fonstated/RestartSamba), the smb.conf gets over-written and the problem appears again.

My solution was to fall back to the /etc/fonstated/RestartSamba and /etc/fonstated/ReloadSamba of version 2.3.6 which I got from this other thread: http://trac.fonosfera.org/fon-ng/ticket/966

I advice you to first do a backup of the files you are going to overwrite

  root@Fonera:~#cp /etc/fonstated/RestartSamba /etc/fonstated/RestartSamba~
  root@Fonera:~#cp /etc/fonstated/ReloadSamba /etc/fonstated/ReloadSamba~

  root@Fonera:~# wget http://trac.fonosfera.org/fon-ng/export/1793/tags/2.3.6.1/fon/samba3/files/etc/fonstated/RestartSamba -O /etc/fonstated/RestartSamba
  root@Fonera:~# wget http://trac.fonosfera.org/fon-ng/export/1793/tags/2.3.6.1/fon/samba3/files/etc/fonstated/ReloadSamba -O /etc/fonstated/ReloadSamba

Then you have to give them execute permissions:

  root@Fonera:~#chmod +x /etc/fonstated/RestartSamba
  root@Fonera:~#chmod +x /etc/fonstated/ReloadSamba

That should work (at least it works for me so far). I tried editing the files directly and removing the wide links = no line manually, but it turns out that those files are lua compiled files (correct me if I'm wrong), so I couldn't just edit them using a text editor.

If anyone has a more elegant way to solve this problem, or a newer version of Restart/ReloadSamba?, please tell me.

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by matthijs

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for you report, and some impressive debugging you did there. However, this bug was already known (see #1243) and fixed in SVN trunk. This bug was actually the original reason why we started working on the 2.3.7.1 bugfix release, so once that one is out it should fix your problem as well (in a bit better way than just enabling wide links again).

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.