Modify

Opened 10 years ago

Closed 6 years ago

#444 closed enhancement (duplicate)

Make NAT rules for the external interfaces apply to the trusted LAN

Reported by: jon@… Owned by: iurgi@…
Priority: low Milestone:
Component: unknown Version: Unknown
Severity: unknown
Cc: Hardware: unknown

Description

I have a webserver running on my home network behind my Fon 2.0n (firmware 2.2.6.0) which is my boundary firewall/switch. I have configured the NAT on the FON to route external traffic from my ISP allocated DHCP address (e.g. 100.100.100.1) to my webserver (192.168.1.1) on ports 80 and 443.

Under my previous router (a Linksys WRT54G) running DD-WRT, the NAT is also configured so that if my laptop (192.168.1.2) tries to connect to 100.100.100.1, it NATs the source address to 100.100.100.1 and the destination address to 192.168.1.2.

I know this is pretty inefficient, and probably breaks half-a-dozen RFCs, but if my wife (who is non-technical) accesses the HTTPS page from inside the network, she gets an error message about the hostname being invalid on the hostname (as it would do), and thus complains.

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by matthijs

  • Milestone Requests deleted

Milestone Requests deleted

comment:2 Changed 6 years ago by matthijs

  • Hardware set to unknown
  • Resolution set to duplicate
  • Severity set to unknown
  • Status changed from new to closed
  • Version set to Unknown

I'm marking this ticket as a duplicate of #1025, which describes the problem and caveats of a possible solution in a bit more detail.

Add Comment

Modify Ticket

Action
as closed The owner will remain iurgi@….
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.