Modify

Opened 8 years ago

Closed 8 years ago

Last modified 5 years ago

#479 closed bug (fixed)

tcp_ecn is on by default and causes hard to debug problems

Reported by: xm@… Owned by:
Priority: high Milestone:
Component: fon-base-firmware Version:
Severity:
Cc: Hardware:

Description

Hi.

It seems that recent fon firmwares still have "net.ipv4.tcp_ecn" set to "1". This parameter causes really hard to debug connection problems with certain network equipment or isps.

If some hop along the route path drops ecn enabled packets, any tcp connection initiated by the fonera will just hang and eventually time out after a while. While icmp still works fine, any tcp connection originating from the fonera itself will stall which causes the internet connection self test to fail resulting in defunct forwarding on the fonera.

Furthermore this parameter is not changeable via the ui, so ssh access is required to disable it.

OpenWrt? had the same problem for a while after tcp_ecn was enabled by default. Since this caused serious regression for lots of users the default was changed back to disable.

References:

  • dev.openwrt.org/ticket/4489
  • dev.openwrt.org/ticket/4202
  • dev.openwrt.org/changeset/16499

Suggested fix: in /etc/sysctl.conf

-net.ipv4.tcp_ecn=1
+net.ipv4.tcp_ecn=0

Attachments (0)

Change History (5)

comment:1 Changed 8 years ago by blogic

fixed

comment:2 Changed 8 years ago by blogic

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 8 years ago by matthijs

  • Milestone Requests deleted

Milestone Requests deleted

comment:4 Changed 7 years ago by anonymous

Are routers still effected by this issue? Otherwise, I'd suggest activating it again.

comment:5 Changed 5 years ago by XRumerTest

Hello. And Bye.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.