Modify

Opened 8 years ago

Closed 8 years ago

Last modified 3 years ago

#490 closed enhancement (fixed)

Upgrade ntfs-3g driver to improve performance

Reported by: pedrolamas@… Owned by: iurgi@…
Priority: high Milestone:
Component: fon-base-firmware Version: N/A
Severity: unknown
Cc: Hardware: both

Description

Like the title says, will you update the NTFS driver to the latest version available, at time of ticket, the 2009.11.14 version?

From the change log:

"Change: Performance optimizations. Frequently used data are cached to improve speed. Space allocation for fragmented and sparse files has been improved."

Maybe F2N would have torrent working better now with this driver, what do you think?

Thanks and keep the good work, best regards,

Pedro Lamas

Attachments (0)

Change History (7)

comment:1 Changed 8 years ago by iurgi

  • Milestone changed from Firmware 2.3.5 to Firmware 2.3.7.0

comment:2 Changed 8 years ago by matthijs

  • Component changed from unknown to fon-base-firmware
  • Hardware set to both
  • Milestone Firmware 2.3.7.0 deleted
  • Priority changed from normal to major
  • Status changed from new to confirmed
  • Summary changed from Will F2N new firmware have NTFS-3G version 2009.11.14? to Upgrade ntfs-3g driver to improve performance
  • Type changed from request to enhancement
  • Version set to N/A

This is probably worth investigating, considering the current version is from May 29, 2008.

comment:3 Changed 8 years ago by pedrolamas@…

Thank you for your attention! :)

comment:4 Changed 8 years ago by matthijs

  • Severity set to unknown

#904 reports problems with special characters, which are likely to be fixed by ntfs-3g 2009.1.1.

comment:5 Changed 8 years ago by matthijs

(In [1766]) fuse: Update to 2.8.4.

This imports the fuse package from OpenWRT trunk (r22919) unmodified.

Note that this also switches to the in-kernel fuse module, since fuse 2.8.x no longer includes a kernel module. Before, the in-kernel module was only used for kernels >= 2.6.25, though it is included for kernels

2.6.14). This might cause an older version of the kernel module to be

used by this upgrade.

References: #490

comment:6 Changed 8 years ago by matthijs

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [1767]) ntfs-3g: Update to version 2010.8.8.

Since ntfs-3g now uses other headers than just "fuse.h", fix up the include path for fuse.

We can't just import tne OpenWRT version of this package, since that contains conditional dependencies which our buildsystem version doesn't support.

Closes: #490 and #895

comment:7 Changed 3 years ago by Ramona

How is IPv6 behaving for you with 10.7? I <a href="http://lagircmq.com">reallgruy</a> access remote hosts that are V4/V6 dual stack and my 10.7 machine will sometimes access via V4 and sometimes v6. All other machines on this LAN (iOS 4, OSX 10.5 and 10.6, XP, Win7; all dual stack) always access via v6. Strange

Add Comment

Modify Ticket

Action
as closed The owner will remain iurgi@….
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.