Modify

Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#508 closed enhancement (fixed)

Set the public IP static in the OpenVpn when the DynDns isn't configured

Reported by: <giuseppeg88@…> Owned by: john.crispin@…
Priority: low Milestone: Firmware 2.3.7.0
Component: fon-plugin-openvpn Version: N/A
Severity: unknown
Cc: Hardware: both

Description

Can you add a form where to set the static public IP when the DynDNS isn't configured in the Fonera?

Attachments (0)

Change History (9)

comment:1 Changed 9 years ago by matthijs

  • Milestone Requests deleted

Milestone Requests deleted

comment:2 Changed 7 years ago by matthijs

  • Component changed from fon-network to fon-plugin-openvpn
  • Hardware set to both
  • Milestone set to Firmware 2.3.7.0
  • Severity set to unknown
  • Status changed from new to confirmed
  • Type changed from request to enhancement
  • Version set to N/A

We should probably fix this for 2.3.7.0, since it will contain a lot of other OpenVPN improvements as well.

comment:3 Changed 7 years ago by matthijs

  • Status changed from confirmed to testing-fix

comment:4 Changed 7 years ago by matthijs

  • Resolution set to fixed
  • Status changed from testing-fix to closed

(In [2054]) luci-openvpn: When DDNS is not configured, allow entering the public IP

When no public IP is entered, the WAN ip is used (but in most configurations where the modem is also a NAT router, this IP address is not a public IP and thus wrong). Now we allow the user to override this IP through the webinterface.

Commit prepared by blogic.

Closes: #508

comment:5 Changed 7 years ago by matthijs

(In [2055]) luci-openvpn: Make the public IP optional.

When not given, the DDNS hostname or WAN IP will be used, so no need to make the public IP required.

References: #508

comment:6 Changed 7 years ago by matthijs

(In [2056]) luci-openvpn: Show the "Public IP" field only after enabling OpenVPN.

References: #508

comment:7 Changed 7 years ago by matthijs

(In [2140]) openvpn: Use the new ddns config file format.

In r2092, the DDNS package used was switched to ddns_scripts, which uses a slightly different configuration file format. This commit fixes that, which should cause OpenVPN to use the DDNS filename again.

References: #681, #508

comment:8 Changed 7 years ago by matthijs

(In [2141]) openvpn: Mention when using the DDNS hostname.

References: #508

comment:9 Changed 7 years ago by matthijs

(In [2192]) luci-openvpn: Don't forget to backup the public ip setting.

References: #508

Add Comment

Modify Ticket

Action
as closed The owner will remain john.crispin@….
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.