Modify

Opened 8 years ago

Closed 7 years ago

Last modified 6 years ago

#540 closed bug (fixed)

Private signal not detected by HTC Magic Android nor Wii

Reported by: decodecoding@… Owned by:
Priority: normal Milestone: Firmware 2.3.6.1
Component: fon-wifi Version: 2.3.6.0 (Gari)
Severity: unknown
Cc: fchiodo@…, benve83@… Hardware: 2.0n (FON2300)

Description (last modified by matthijs)

While publica signal y detected by these two devices, public signal (WPA) is not detected.

This is on 2.3.5 RC2.

Attachments (1)

rt3052.sh (5.9 KB) - added by matthijs 7 years ago.
wifi script with WPS disabled to (temporarily) fix HTC Magic & Hero connections

Download all attachments as: .zip

Change History (26)

comment:1 Changed 7 years ago by iurgi

  • Milestone changed from Firmware 2.3.5 to Firmware 2.3.7.0

will, check. strange!

comment:2 Changed 7 years ago by matthijs

  • Component changed from fon-base-firmware to fon-wifi
  • Hardware set to unknown
  • Status changed from new to testnewer
  • Version set to Other

Could you see if this problem still occurs with 2.3.6? I know that wifi problems with apple products have been fixed, perhaps this also fixes these?

comment:3 Changed 7 years ago by matthijs

  • Cc fchiodo@… added
  • Description modified (diff)
  • Hardware changed from unknown to 2.0n (FON2300)
  • Status changed from testnewer to investigate
  • Summary changed from 2.3.5 RC2 - Private signal not detected by HTC Magic Android nor Wii to Private signal not detected by HTC Magic Android nor Wii
  • Version changed from Other to 2.3.6.0 (Gari)

Ah, #671 (by the same reporter) shows that it breaks for the HTC Magic on 2.3.6 as well. Decodecoding, is the Wii still broken with 2.3.6 as well?

Also according to #671, 2.3.0 was ok with the HTC magic, so some recent change broke this.

comment:5 Changed 7 years ago by fchiodo@…

On 2.3.6 I've seen that private signal (MyPlace??) is not detected by HTC Magic Android, but my Wii is connected regularly

comment:6 Changed 7 years ago by cyrus

it works with the nexus one though. (android eclair and froyo)

comment:7 Changed 7 years ago by matthijs

  • Milestone Firmware 2.3.7.0 deleted

comment:8 Changed 7 years ago by matthijs

  • Milestone set to Firmware 2.3.7.0

comment:9 Changed 7 years ago by anonymous

Neither HTC Hero can detected Fonera private signal with this firmware and public disconnects...

Changed 7 years ago by matthijs

wifi script with WPS disabled to (temporarily) fix HTC Magic & Hero connections

comment:10 Changed 7 years ago by matthijs

  • Severity set to unknown

I managed to get someone with a HTC Magic over here to test this.

What I've gathered so far, is that the WPS support on the 2.0n breaks the HTC Magic connection to the private wifi signal for some reason. When the 2.0n advertises it has WPS support, it is somehow hidden from the list of networks on the Magic.

#642 suggests that WPS was broken in 2.3.6.0, so perhaps that is related. I'll have a look at the exact cause of this issue.

In the meanwhile, you can apply the following workaround. Get your Fonera into dev mode, and run the following command (see this page for more instructions):

root@Fonera:~# wget -O /lib/wifi/rt3052.sh http://trac.fonosfera.org/fon-ng/raw-attachment/ticket/540/rt3052.sh

If you try this, please report your results here.

I haven't tested the public signal, I've only just noticed the last comment about disconnects with the public signal... Are others seeing this problem as well?

comment:11 Changed 7 years ago by benve83@…

Sorry but this don't work! I can connect with myplace but I can't go onb Internet. And now with my pc's I have the same problem. How I can go back to the original configuration?

comment:12 Changed 7 years ago by matthijs

  • Cc benve83@… added

Woah, that's weird. Are you using WPS to connect your PC's to the Fonera, or did you just type in the WPA key manually? Did you try rebooting the Fonera?

With the PC's, what problem are you having exactly? Does the MyPlace? signal no longer show up, or can you connect but not get onto the internet?

To restore the original configuration, use the following command:

root@Fonera:~# wget -O /lib/wifi/rt3052.sh http://trac.fonosfera.org/fon-ng/export/1679/tags/2.3.0.0/fon/ra_wifi/files/lib/wifi/rt3052.sh

Can other please still test this fix? I'm suspecting benve83 is perhaps seeing a second problem that's unrelated to the HTC Magic issue.

comment:13 Changed 7 years ago by benve83@…

Ok, I've reset the Fonera but the problem is the same. I use the WPA key. With the telephone and pc I can connect with MyPlace? signal but internet don't work. Now I've reset my fonera with original 2.3.6.0 firmware. This weekend I will come back to home to retest the connection with a new ROM.

comment:14 Changed 7 years ago by Raoul

Hi guys,

The reason why the HTC Hero/Magic? can't connect to the Fonera 2.0n is simple. The HTC Hero/Magic? is not a Wifi N compatible device, it supports only B and G Wifi. See the specifications for more infos: http://www.htc.com/uk/product/hero/specification.html

So if you want to use your Hero/Magic? with your Fonera 2.0n, you have to use B or G Wifi settings only.

Hope this helps.

comment:15 Changed 7 years ago by benve83@…

I disagree. Why there is an option to choose both B G and N? In the same time I've connected 4 pc: 2 in N and 2 in G

comment:16 Changed 7 years ago by fchiodo@…

Wrong: HTC Hero/Magic? (and maybe Nintendo Wii) did connect without problems using previous version of firmware (2.3.6). When i'll be back at home i'll try out the workaround, or i'll go back to 2.3.6 firmware until bug is fixed.

comment:17 Changed 7 years ago by fchiodo@…

OK, the fix script posted does work for me. This is the output i get from my fonera via ssh: root@Fonera:/root# sh /lib/wifi/rt3052.sh /lib/wifi/rt3052.sh: line 2: append: not found

Now i see private and public signal and i can connect and navigate the internet through MyPlace? by my HTC Magic.

Thank you

comment:18 Changed 7 years ago by matthijs

Good to hear that the fix is working for you. The error about "append" you get is expected, the script is not meant to be called directly.

benve83, did you get around to testing a clean firmware with this fix again?

comment:19 Changed 7 years ago by anonymous

Hi, with CyanogenMod? 6.0.0 RC1 (Android Froyo 2.2) now work! Thank you!

comment:20 Changed 7 years ago by matthijs

  • Milestone changed from Firmware 2.3.7.0 to Firmware 2.3.6.1

WPS is disabled in r1683 (backported for 2.3.6.1 in r1687). I'll leave this ticket open until WPS is completely functional again.

comment:21 Changed 7 years ago by matthijs

  • Resolution set to fixed
  • Status changed from investigate to closed

Hmm, on second thought, let's mark this one as fixed and keep #642 open.

comment:22 follow-up: Changed 7 years ago by chirag.sanghavi@…

Blackberry Bold 9700 can not see the private signal as well.

comment:23 in reply to: ↑ 22 Changed 7 years ago by anonymous

Replying to chirag.sanghavi@…:

Blackberry Bold 9700 can not see the private signal as well.

As a clarification, the issue of Blackberry Bold is being faced with 2.3.6.0

comment:24 Changed 7 years ago by chirag.sanghavi@…

After RC1 installation, Blackberry is able to see private signal.

comment:24 Changed 6 years ago by matthijs

(In [1932]) ra_wifi: Fix and re-enable WPS again.

In a driver config update in r1638 the WscConfStatus? variable, which is required for WPS to work, was accidentally removed. This commit re-adds it and enables WPS again.

Thanks to Giuseppe Giudice for this patch.

Closes: #642 References: #540

comment:25 Changed 6 years ago by matthijs

(In [1934]) luci: Allow disabling WPS.

This allows users to disable WPS, in case the problems with Android phones and WPS persist.

References: #540, #642

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.