Modify

Opened 9 years ago

Closed 6 years ago

#544 closed bug (fixed)

f2n: Status page shows throughput twice as high as it should

Reported by: carsten.schuette@… Owned by:
Priority: lowest Milestone: Firmware 2.3.7.0
Component: fon-web Version: 2.3.7.0 beta3
Severity: minor
Cc: Hardware: 2.0n (FON2300)

Description

I have a 16 mbit dsl line which synchonizes at abaout 14 mbit/s normally. Today I have downloaded a large file using firefox, and firefox said that download speed was about 950 kbit/s. But the fonera dashboard status page shows about 1900 kbit/s on LAN and WAN interface. Is is too high.

Attachments (0)

Change History (4)

comment:1 Changed 9 years ago by iurgi

  • Milestone changed from Firmware 2.3.5 to Firmware 2.3.7.0
  • Priority changed from major to trivial

comment:2 Changed 9 years ago by matthijs

  • Component changed from fon-base-firmware to fon-web
  • Hardware set to 2.0n (FON2300)
  • Milestone Firmware 2.3.7.0 deleted
  • Status changed from new to confirmed
  • Version set to 2.3.6.0 (Gari)

This happens on my 2.0n with 2.3.6.0 as well, bandwith is double the actual value.

comment:3 Changed 7 years ago by matthijs

  • Milestone set to Firmware 2.3.7.0
  • Severity set to minor
  • Status changed from confirmed to testing-fix
  • Version changed from 2.3.6.0 (Gari) to 2.3.7.0 beta3

I've found the cause of this issue, the update interval got doubled at some point, but the bandwidth calculation was not updated to take this into account.

I've attached a fixed version of main.htm to #1137 (which reports the graphs not working at all), which fixes both issues To install it, run the following command on your Fonera:

root@Fonera:~# wget -O /usr/lib/lua/luci/view/fon_status/main.htm http://trac.fonosfera.org/fon-ng/raw-attachment/ticket/1137/main.htm

Could you check if this fixes the problem for you and comment back here?

comment:4 Changed 6 years ago by matthijs

  • Resolution set to fixed
  • Status changed from testing-fix to closed

(In [2133]) luci: Correct traffic status bandwidth calculation.

The graphs showed twice the actual bandwidth, because the calculation was wrong. The calculation became incorrect when the update interval was changed in r19, but the calculation (which implicitly used the interval) was not updated to follow this.

This commit updates the calculation and makes the interval explicit in the calculation, to prevent this problem from ocurring again.

Closes: #544

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.