Modify

Opened 10 years ago

Closed 9 years ago

Last modified 7 years ago

#56 closed bug (fixed)

Symlinks on samba shares

Reported by: grajea1@… Owned by: iurgi@…
Priority: normal Milestone:
Component: unknown Version:
Severity:
Cc: Hardware:

Description

When mount samba shared folder via:

mount "fonera/Media" "/media/fonera" -t cifs -o "rw,user=fonero,pass=xxxxxxxxx"

... the volume mounts ok, but it show the symlinks as symlinks, with the real path of the resource in la fonera.

If I want la fonera show symlinks as folders, i have to edit smb.conf, add a line like unix extensions = no in [global] section, a restart samba with: smbd stop smbd start

The problem is that, when I make some change in samba configuration vía luci, smb.conf is writed to original status, without the fix.

In my opinion, it's necesary to add this line, because the content of "Media" shared folder always contains symlinks to the mounted USB-discs.

Attachments (0)

Change History (2)

comment:1 Changed 9 years ago by blogic

  • Resolution set to fixed
  • Status changed from new to closed

comment:2 Changed 8 years ago by matthijs

  • Milestone Requests deleted

Milestone Requests deleted

Add Comment

Modify Ticket

Action
as closed The owner will remain iurgi@….
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.