Modify

Opened 8 years ago

Last modified 8 years ago

#561 testnewer bug

WEP support broken on Fonera 2.0n: 2.2.6.0-2.3.5.0

Reported by: zencoslav@… Owned by: john.crispin@…
Priority: normal Milestone:
Component: fon-wifi Version: Other
Severity:
Cc: Hardware: 2.0n (FON2300)

Description

Hello!

I tried to enable 64&128 WEP encryption with Fonera 2.0n (two units). I loaded firmwares 2.2.6.0, 2.3.0.0 and 2.3.5.0.

WPA encryption works normally, but I need WEP because of compatibility with older devices and there are some performance issues with WPA. This is for a multi AP network with roaming support.

Description of the bug: When setting a WEP encryption with key, my Windows notebook comes up with this error: "Windows is unable to connect to the selected network. The network may no longer be in range. Please refresh the list of available networks and try to connect again."

Instead, it should ask me for the WEP key! Tried and rebooted several times.

With other APs, WEP works normally. With 2.0n, it also works with WPA. I tried to set up the wireless.public.key=1, and .key1=ACTUAL_KEY (also with config.sh script from uci fon), but still doesn't work. Other wireless devices would detect WEP network, ask me for the key, but none would get accepted.

I could not access the actual WEP settings from the Ralink chip, as iwlist doesn't work fully.

Proposed solution: check what WEP settings do actually get sent to the Ralink wireless chip. It should be easy to key in a 64-bit WEP (also with leading zeroes) and get it to work withing a minute.

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by matthijs

  • Hardware set to 2.0n (FON2300)
  • Milestone First Release deleted
  • Status changed from new to investigate
  • Type changed from request to bug
  • Version set to Other

comment:2 Changed 8 years ago by matthijs

  • Status changed from investigate to testnewer

When browsing the source, I just noticed r1650, which seems to fix this bug. Could you see if upgrading to 2.3.6.0 fixes your problem?

Add Comment

Modify Ticket

Action
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.