Modify

Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#619 closed bug (fixed)

DHCP request on WAN port (ticket 506)

Reported by: carsten.schuette@… Owned by: john.crispin@…
Priority: normal Milestone: Firmware 2.3.7.0
Component: fon-network Version: 2.3.6.0 (Gari)
Severity: minor
Cc: Hardware: both

Description

Ticket #506 was:

Why does fonera send this invalid DHCP request to the WAN port?! It's DHCP server only listens to the LAN ports, so no DHCP request should be sent to the WAN (Internet) port...?!

The ticket was closed some days ago with comment "invalid". But please note that this also happens when Fonera is set to "static" WAN mode.

Attachments (0)

Change History (5)

comment:1 Changed 9 years ago by matthijs

  • Hardware set to 2.0n (FON2300)
  • Milestone Firmware 2.3.6.0 deleted
  • Status changed from new to investigate
  • Version set to 2.3.6.0 (Gari)

AFAIK, the Fonera sends a dummy DHCP request to see if a DHCP server is already running, before starting its own. However, this should only happen on the LAN interface, where the DHCP server is actually started.

Why do you say the DHCP request is invalid? (You can comment on tickets now, btw).

comment:2 Changed 9 years ago by carsten.schuette@…

The DHCP request is invalid because it does not contain a valid host name.

comment:3 Changed 9 years ago by cyrus

  • Priority changed from normal to minor

comment:4 Changed 6 years ago by matthijs

  • Hardware changed from 2.0n (FON2300) to both
  • Milestone set to Firmware 2.3.7.0
  • Priority changed from low to normal
  • Severity set to minor
  • Status changed from investigate to testingfix

As part of the upcoming 2.3.7.0 firmware release, we're reviewing old open tickets to see if they are still relevant, which is why you get this response now.

I did a quick tcpdump of the WAN interface of my Fonera, and can indeed see the spurios DHCPDISCOVER packets. I'm not so sure if they're "invalid" for lack of a hostname, but they shouldn't be there anyway.

Turns out that this is caused by the RestartDnsmasq? script checking for existing DHCP servers on each configured network, even when then network is set to be ignored (like the wan network). This is easy to fix, I have a fix ready in my local tree already.

comment:5 Changed 6 years ago by matthijs

  • Resolution set to fixed
  • Status changed from testingfix to closed

(In [2245]) dnsmasq: Don't send DHCP packets to ignored interfaces.

When starting up, the RestartDnsmasq? script sends a DHCP packet to the interface it will be listening on, to make sure that there is not already a DHCP server running on the network.

However, it would also do this for interfaces which are configured to be ignored by dnsmasq. This caused a DHCPDISCOVER packet to be sent out on the wan interface during startup, for no good reason.

Closes: #619

Add Comment

Modify Ticket

Action
as closed The owner will remain john.crispin@….
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.