Modify

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#620 closed bug (fixed)

www.fon.com can not configure the Fonera 2.0n latest firmware

Reported by: steven@… Owned by: matthijs
Priority: high Milestone: Firmware 2.3.6.1
Component: fon-base-firmware Version: 2.3.6.0 (Gari)
Severity: unknown
Cc: jurgen@… Hardware: 2.0n (FON2300)

Description

Changed Public/private/router/wpa password of my "online" fonera 2.0n running latest firmware compiled yesterday but ... no change in eg SSID not even after a reboot...

It this possible?

Attachments (0)

Change History (9)

comment:1 Changed 7 years ago by matthijs

  • Hardware set to 2.0n (FON2300)
  • Milestone Firmware 2.3.7.0 deleted
  • Owner set to matthijs
  • Priority changed from normal to major
  • Status changed from new to accepted
  • Version set to 2.3.6.0 (Gari)

We've recently found out this bug as well. I'm currently testing on a fix for this.

The problem here is that the "thinclient" application, which receives the configuration updates, hasn't been updated regarding the MAC address change, so it sends the wrong address.

Initially, we thought that this problem was the cause of #669, but it seems they are unrelated.

comment:2 Changed 7 years ago by matthijs

  • Cc jurgen@… added
  • Severity set to unknown

#646 and #797 report that adding Family & Friends accounts does not work with 2.3.6.0 either. This is handled through thinclient as well, so fixing thinclient will probably solve that problem as well.

comment:3 Changed 7 years ago by matthijs

In the meantime, a fixed version of the thinclient command is available here: http://trac.fonosfera.org/fon-ng/attachment/ticket/669/thinclient

If you are suffering from these issues, please test that version, so we can find any remaining problems.

To install you'll need to have development firmware installed. Download the file and overwrite the /bin/thinclient file on your Fonera with it. The easiest way to do this is to connect using SSH / PuTTY and use the wget command:

root@Fonera:~# wget -O /bin/thinclient http://trac.fonosfera.org/fon-ng/raw-attachment/ticket/669/thinclient

comment:4 Changed 7 years ago by jurgen@…

How great is that!!! This is solving the problem with Family&Friends. Thank you so much.

comment:5 Changed 7 years ago by matthijs

  • Milestone set to Firmware 2.3.6.1

comment:6 Changed 7 years ago by matthijs

If you want to try this fix, see this wiki page for instructions on connecting with PuTTY (or another SSH client).

comment:7 Changed 7 years ago by JoepieNL

Isn't it possible to make an installable package (image firmware) and post a link to that instead of having to install developper firmware, accessing through ssh, overwriting files etc. ? That would be so much easier....

comment:8 Changed 7 years ago by matthijs

This is not really an on-topic question, but I'll answer it: Yes, that's possible. It's also a lot more work (since it also needs testing, and it needs to be signed with a key that only a few people have access to, etc.). And given that this is really a temporary workaround (the next firmware release will have the fix) and that most people who want to test bugfixes already have a developer firmware, we've kept to SSH commands for now.

comment:9 Changed 7 years ago by matthijs

  • Resolution set to fixed
  • Status changed from accepted to closed

This issue is fixed in r1688 (backported for 2.3.6.1 in r1690).

Add Comment

Modify Ticket

Action
as closed The owner will remain matthijs.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.