Modify

Opened 8 years ago

Closed 7 years ago

#645 closed bug (fixed)

When dchp server is enabled (or disabled), fonera becomes unresponsive

Reported by: ollikola Owned by:
Priority: high Milestone: Firmware 2.3.7.0
Component: fon-network Version: 2.3.6.0 (Gari)
Severity:
Cc: Hardware: 2.0n (FON2300)

Description

If dhcp server is enabled (or disabled) in the web gui, fonera becomes unresponsive and can't be used over the wlan. Only switching the box off and back on helps.

Firmware version: 2.3.6.0

Attachments (0)

Change History (4)

comment:1 Changed 8 years ago by matthijs

  • Component changed from fon-base-firmware to fon-network
  • Hardware set to 2.0n (FON2300)
  • Priority changed from normal to major
  • Status changed from new to confirmed
  • Version set to 2.3.6.0 (Gari)

I've just confirmed this on my Fonera 2.0n.

When you disable the DHCP server, the MyPlace? connection is killed (which could make sense because it is restarted). However, the MyPlace? signal never returns. The public signal stays around normall, though I haven't tried logging on to that.

I've also seen this behaviour when switching from and to bridge mode, but that's probably due to the same problem.

comment:2 Changed 8 years ago by matthijs

When this happens, the ethernet LAN connection stays available normally.

comment:3 Changed 8 years ago by calvinturbo@…

I had this same problem (=MyPlace? gone) too, but it gone now, because I moved the Fonera 2.0n to a other place in house and changed some settings (DHCP settings)

comment:4 Changed 7 years ago by matthijs

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [1834]) luci: Run ConfigWifi? after changing wan or lan settings.

When these settings are changed, the ConfigLan? script is run (for wan settings this is needed when bridge mode is enabled). The ConfigLan? script brings the lan network down and up. This also brings the private wifi signal down, since it is included in the lan bridge. However, the wifi network is not brought up anymore (since it is dynamically included in the lan bridge as part of bringing up the wifi network).

This commit makes sure that ConfigWifi? is also called after ConfigLan?, to bring the wifi signal back up again.

Closes: #645

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.