Modify

Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#648 closed enhancement (fixed)

Allowable wireless channels does not reflect change of country setting. Channel 13?

Reported by: mudhopper Owned by: john.crispin@…
Priority: normal Milestone: Firmware 2.3.7.0
Component: fon-wifi Version: 2.3.6.0 (Gari)
Severity: unknown
Cc: joeclifford@… Hardware: 2.0n (FON2300)

Description

Using the new 2.3.6.0 Gari Hummingbird firmware on fonera 2.0n - I live in UK and would expect, when changing the country setting in the wireless settings dialogue, that the available wifi channels would change from 1-11 to 1-13. I need to set to wireless channel 13 because of interference from my neighbours.

Attachments (0)

Change History (12)

comment:1 Changed 9 years ago by matthijs

  • Hardware set to 2.0n (FON2300)
  • Milestone Firmware 2.3.6.0 deleted
  • Status changed from new to confirmed
  • Type changed from bug to enhancement
  • Version set to 2.3.6.0 (Gari)

comment:2 Changed 9 years ago by joeclifford@…

Is this a trivial fix? If so, would you have time to include it along with the update to the kernel and wifi driver due for firmware version 2.3.7.0?

comment:3 Changed 7 years ago by matthijs

  • Milestone set to Firmware 2.3.7.0
  • Severity set to unknown

I think that the country setting affects the channels the driver will use in autoselect mode, but the list in the webinterface is always static.

To fix this, we should find out which countries can use which channels and then update the WebGUI accordingly. I'll have a look at this for 2.3.7.0.

comment:4 follow-up: Changed 7 years ago by shareAir.net <post@…>

The allowed channels and also the maximum transmit power level limits are defined by the country code settings. The following list may help you: http://www.cisco.com/en/US/docs/wireless/wcs/3.2/configuration/guide/wcscod.html

btw: Do the country settings of the Fonera firmware also affect (adjust) the maximum radio transmit power level?

comment:5 in reply to: ↑ 4 Changed 7 years ago by matthijs

The following list may help you:

Thanks, I'll have a look.

btw: Do the country settings of the Fonera firmware also affect (adjust) the maximum radio transmit power level?

I think they do. The country setting is passed onto the wifi driver directly, and I suspect the wifi driver knows about any country-specific limits like these.

comment:6 Changed 7 years ago by matthijs

  • Status changed from confirmed to investigate

I had a look at this reference, but also in the sources for the Wifi and it seems they do not quite correspond (the wifi driver lists channel 1-13 for all but 11 countries, while the link provided lists 1-13 for only a handful of countries).

I'd rather stick to the wifi driver for consistency. However, I did find that currently, the wifi driver is not taking its channel list from the country code configured, but from the explicitly configured region (which is now region 0, the 1-11 "failsafe" region that should be valid everywhere).

So, I'll have to find out how to fix this exactly. I'll report back when I have some progress.

comment:7 Changed 7 years ago by matthijs

  • Status changed from investigate to testing-fix

I ended up using a country -> regdomain list from the SIMPL firmware, for consistency.

I have the needed changes ready, I'll push them out to SVN this week.

comment:8 Changed 7 years ago by matthijs

  • Resolution set to fixed
  • Status changed from testing-fix to closed

(In [2169]) luci: Support channel 12 and 13 on 2.0n.

Before, only channels 1-11 were offered, regardless of the country configured.

Now, the country selected is used to select either regulatory domain 0, the safe default which offers only 1-11, or regdomain 1, which also offers channels 12 and 13. The country to regdomain mapping is taken from the SIMPL firmware (nyu.js). This has the side effect effect that the country list subtly changed, but that shouldn't really be a problem.

Additionally, the regdomain is also passed along to the wifi driver. The wifi driver does not automatically select the right regdomain based on the country code passed, so the wifi driver needs this explicit regdomain setting to allow using channel 12 and 13. This has the added effect that these channels can now be autoselected when the channel is set to "auto" and that these channels can be used in wifi client mode.

Furthermore, the structure of the country list was changed, so that it no longer needs to be sorted after loading it. This should improve the load time of the wireless settings page in the WebGUI.

Closes: #648

comment:9 Changed 7 years ago by matthijs

(In [2170]) ra_wifi: Don't set a default country.

Before, the default country was set to Spain. However, it makes more sense to just set no default. Additionally, this prevents wifi channels 12 and 13 from being enabled by default, which could cause problems in countries where their use is not allowed.

References: #648

comment:10 Changed 7 years ago by partisan0@…

So, when will channels 12 and 13 be available in Spain for Fonera 2.0n (verssion 2.3.7.0 Beta 3)????

I NEED channel 13 due to my new neighbours: 3 new APs using channel 11 (it was the best channel until them). I am experiencing many problems due to it (i.e.: connection problems, signal lost, etc).

comment:11 follow-up: Changed 7 years ago by matthijs

This change is included in the 2.3.7.0 RC1 release, so you can try using that version.

comment:12 in reply to: ↑ 11 Changed 7 years ago by anonymous

Replying to matthijs:

This change is included in the 2.3.7.0 RC1 release, so you can try using that version.

Thanks for your reply!!! Downloaded, tested and... working!! Great job! :)

Add Comment

Modify Ticket

Action
as closed The owner will remain john.crispin@….
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.