Modify

Opened 9 years ago

Closed 6 years ago

#652 closed bug (fixed)

Fails to show the right HDD space using samba in win 7

Reported by: henke81@… Owned by: iurgi@…
Priority: normal Milestone:
Component: fon-network Version: 2.3.6.0 (Gari)
Severity: unknown
Cc: fon-base-firmware Hardware: unknown

Description

I reported the bug before (Ticket #612) but it was closed with the reference to: "test with newer version". The fonera fails to show the right HDD space in the mapped network drive in Win 7 (using samba). My HDD's capacity is at 500GB but explorer only shows 1.76GB. I've upgraded to the latest "hummingbird" firmware but the problem is still there. Is there a fix coming up soon to correct this?

Regards, Henrik

Attachments (6)

Filebrowser(pic1).jpg (86.5 KB) - added by henke81@… 9 years ago.
Pic 1
(pic2)USBDisc.jpg (107.2 KB) - added by henke81@… 9 years ago.
Pic 2
(pic3)Samba.jpg (100.6 KB) - added by henke81@… 9 years ago.
Pic 3
(pic4)LMCompabilityLevel.jpg (187.4 KB) - added by henke81@… 9 years ago.
Pic 4
(pic5)DiskManagementConsole.jpg (125.1 KB) - added by henke81@… 9 years ago.
Pic 5
(Pic6)Hj_lp.jpg (89.9 KB) - added by henke81@… 9 years ago.
Pic 6

Download all attachments as: .zip

Change History (10)

comment:1 Changed 9 years ago by matthijs

  • Component changed from fon-plugins to fon-network
  • Hardware set to unknown
  • Milestone Firmware 2.3.6.0 deleted
  • Status changed from new to infoneeded
  • Version set to 2.3.6.0 (Gari)

Ticeket #612 mentions that this is broken for Windows Vista well. Also, you say there that the dashboard doesn't allow you to access the files either, meaning this is unlikely to be a samba-specific problem. Is access through the dashboard still broken with hummingbird?

In particular, what does "USB disc" and "Filebrowser" show you?

Could you also check the partition table of the disc for any hidden partitions or other weird stuff? How to find the right interface on Windows 7 is described under "Where to Find the Windows 7 Disk Management Console" here: http://pc-tutorials.suite101.com/article.cfm/resizing_partitions_in_windows_7. If you are running a development version of the Fonera firmware, you can also connect with SSH and run the fdisk command:

root@Fonera:~# fdisk -l /dev/sda

Changed 9 years ago by henke81@…

Pic 1

Changed 9 years ago by henke81@…

Pic 2

Changed 9 years ago by henke81@…

Pic 3

Changed 9 years ago by henke81@…

Pic 4

Changed 9 years ago by henke81@…

Pic 5

Changed 9 years ago by henke81@…

Pic 6

comment:2 Changed 9 years ago by henke81@…

Hi!

At first, the disc files aren't recognized by the fonera dashboard but after a few seconds (maybe after the HDD has booted up?) the filebrowser is able to find them (see pic 1). The HDD also seems to be recognized in the "USB disc"-window (see pic 2).

Samba also recognize the files on my HDD I've found out today! It's possible to read/write files to the disc but the drive capacity is still set to 1.76GB! (See pic 3)

When going through the "map drive set-up" on the Fon wiki, I'm prompted to change the "LMCompabilityLevel" at one point. But I can't find that value in my Windows 7 regedit..! (See pic 4) Maybe that has something to do with the 1.76GB error...?

The drive does not show up at all in the disk management tool, it's only mapping my C: drive, virtual drive and DVD burner drive. The USB disc has been allotted drive Z: by samba but only C:, E: and F: is showing in the disk management console (see pic 5, “diskhantering” is swedish for “disk management console”).

If you can write me a short tutorial on how to run SSH I'd gladly do that, I'm a bit of a noob on that.

I have a couple of other remarks aswell. In point 4.2.2 of the fonnera 2.0n Windows networshare Wiki, it says to "unable" the access to Windows network from WAN. Do you mean disable or is it meant to be enable (like in point 2.2.2)? It's a bit confusing.

Also I would like to see the Swedish letters å, ä and ö being implemented in the code so that samba will show the folder names as they should be (for example, one folder called: "Hjälp" is shown as "Hj_lp" in my samba, see pic 6).

Regards, Henrik

comment:3 Changed 9 years ago by matthijs

  • Severity set to unknown
  • Status changed from infoneeded to investigate

Hi Henrik,

thanks for your feedback and the screenshots. I'll respond to your comment in order.

First. you say there is a delay before the Fonera filebrowser shows your files? If you mean directly after plugging in your hard disk, then this is expected. When an USB device is plugged in, the Fonera gives the device a couple of seconds to get initialized before querying it.

From the USB disc screenshot, I can see that the Fonera does recognize the disk as 500GB properly (or 400-something, but that's expected due too 1000 vs 1024 issues). So the main problem is that samba fails to pass on the proper disk size. I'm not quite sure what causes this, but I think this should be the focus of this ticket.

As for the LMCompatiblity entry not existing, I think the default value is ok (if it was wrong, you wouldn't be able to connect at all).

As for the disk not showing up in the disk management, I meant that you should connect the disk to your PC directly using USB and then look in the disk management tool. But I don't think this needed anymore.

As for SSH, you can have a look at this page I've recently written. I don't think the fdisk command is needed anymore, but perhaps you could try the following command to see how much disk space the Fonera thinks there is:

root@Fonera:~# df -h

The issue you mention under point 4.2.2. of this page, is simply a (quite interesting) typo. It should be "enable", not "unable" :-) I've fixed the typo already.

As for the swedish letters, I think that has something to do with codepages and encodings and other stuffs I don't know enough about. This is probably the same issue as reported at #198. Feel free to reopen that ticket and add a comment there.

comment:4 Changed 6 years ago by matthijs

  • Resolution set to fixed
  • Status changed from investigate to closed

As part of the upcoming 2.3.7.0 firmware release, we're reviewing old open tickets to see if they are still relevant, which is why you get this response now.

I have just tested this again with firmware 2.3.7.0 rc and a Windows 7 client, with both a 16GB USB stick and a 3000GB USB disk. In both cases, the disk size is correctly displayed after a net use. It seems the problem is solved, possibly by some recent mountd or samba changes.

If this issue still occurs with the 2.3.7.0 rc2 firmware, feel free to leave a comment here so we can further investigate.

Add Comment

Modify Ticket

Action
as closed The owner will remain iurgi@….
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.