Modify

Opened 9 years ago

Closed 6 years ago

Last modified 5 years ago

#670 closed bug (worksforme)

Fonera using bridge mode appears offline on fon.com userzone

Reported by: mihaly.reg@… Owned by: iurgi@…
Priority: normal Milestone:
Component: fon-network Version: 2.3.6.0 (Gari)
Severity: unknown
Cc: Hardware: 2.0n (FON2300)

Description

https://www.fon.com/en/userzone/myRouters Your router is offline, please make sure your router is connected or try restarting it

I checked settings > fonspot, is enabled. Checked the switch on the back of router, is ON. Still not "sharing". I have 2.3.6.0, bridge. Private signal is working fine. Public I did not tried to log in, but scan shows that the ssid is visible.

Attachments (0)

Change History (19)

comment:1 Changed 9 years ago by matthijs

  • Component changed from unknown to fon-network
  • Hardware set to 2.0n (FON2300)
  • Milestone Firmware 2.3.7.0 deleted
  • Status changed from new to investigate
  • Version set to 2.3.6.0 (Gari)

Perhaps this is caused by enabling bridge mode? Could you see what happens when you disable bridge mode for a while?

comment:2 Changed 9 years ago by mihaly.reg@…

I could try non-bridge. It can take some time I have this F2 at a remote location. Please defune 'for a while'. 1 day? 1week? Other?

comment:3 Changed 9 years ago by mihaly.reg@…

I tried to disable bridge mode and my fon spot is online again. So the problem comes with the bridge.

comment:4 Changed 9 years ago by matthijs

  • Severity set to unknown
  • Summary changed from F2N 2.3.6.0 DEV public spot appears offline on fon.com userzone to Fonera using bridge mode appears offline on fon.com userzone

comment:5 Changed 9 years ago by matthijs

  • Milestone set to Firmware 2.3

comment:6 Changed 9 years ago by "Nanomad <condellog@…

I'm using bridge mode since 2.3.6.0 and I do not have this problem. Did you check your DNS settings on the fonera?

comment:7 Changed 9 years ago by mihaly.reg@…

i have my isp's dns set. And the internet is working fine through wifi. I don't think it's a dns issue.

comment:8 Changed 9 years ago by matthijs

I think I have a suspicion what is causing this.

Could you run the following commands and paste the output? See reportbug? on info about running commands and pasting output.

root@Fonera:~# uci export network
root@Fonera:~# cat /etc/resolv.conf
root@Fonera:~# route -n

BTW, in bridge mode, your internet working does not necessarily mean that the DNS is set correctly. In bridge mode, you computer will get a DHCP lease (and DNS server address) from your modem, not from the Fonera. The Fonera, on the other hand, will use the DNS address you configured.

comment:9 Changed 9 years ago by mihaly.reg@…

Fonera must be using a corrent DNS because Transmission is working fine, and it use tracker's hostnames!

comment:10 Changed 9 years ago by mihaly.reg@…

root@Fonera:~# uci export network package 'network'

config 'interface' 'loopback'

option 'ifname' 'lo' option 'proto' 'static' option 'ipaddr' '127.0.0.1' option 'netmask' '255.255.255.0'

config 'interface' 'lan'

option 'ifname' 'eth0.1' option 'type' 'bridge' option 'proto' 'static' option 'netmask' '255.255.255.0' option 'gateway' '192.168.0.1' option 'dns' '213.157.167.157' option 'ipaddr' '192.168.0.2'

config 'interface' 'wan'

option 'ifname' 'eth0.2' option 'netmask' '255.255.255.0' option 'hostname' 'Fonera-' option 'username' option 'password' option 'ipaddr' '192.168.0.2' option 'dns' '213.157.167.157' option 'gateway' '192.168.0.1' option 'auto' '0' option 'proto' 'bridge'

config 'interface' 'hotspotwifi'

option 'proto' 'none'

config 'interface' 'hotspot'

option 'ifname' 'tun0' option 'proto' 'none'

config 'interface' 'vpn'

option 'ifname' 'tun-ovpn' option 'proto' 'none' option 'up' '1'

root@Fonera:~# cat /etc/resolv.conf nameserver 213.157.167.157 root@Fonera:~# route -n Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 br-lan 169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 br-lan 0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 br-lan root@Fonera:~#

comment:11 Changed 9 years ago by mihaly.reg@…

tested today the upgrade to 2.3.6.1. on 2.3.6.0 reset config to default, upgrade to 2.3.6.1 and setup wan with dhcp. on fon.com my router appeared online. then I simply changed the mode to bridge and it goes offline. here are the same commands result on 2.3.6.1:

login as: root root@192.168.0.2's password:

BusyBox? v1.11.1 (2010-08-23 18:28:00 CEST) built-in shell (ash) Enter 'help' for a list of built-in commands.

,_ .' '._

; \ / -=o=.-"""""" ; \ / /

...----...;_ ;.:"=._/

'-. -.`;::' |

-. ;::' ;

`'-.....-/::. /

|::. .'

/\
.-` jgs /';\ /| /'; ;`;| -'-;_/

Gari the Hummingbird jr.



root@Fonera:~# uci export network package 'network'

config 'interface' 'loopback'

option 'ifname' 'lo' option 'proto' 'static' option 'ipaddr' '127.0.0.1' option 'netmask' '255.255.255.0'

config 'interface' 'lan'

option 'ifname' 'eth0.1' option 'type' 'bridge' option 'proto' 'static' option 'netmask' '255.255.255.0' option 'gateway' '192.168.0.1' option 'dns' '213.157.167.157' option 'ipaddr' '192.168.0.2'

config 'interface' 'wan'

option 'ifname' 'eth0.2' option 'netmask' '255.255.255.0' option 'username' option 'password' option 'auto' '0' option 'hostname' 'Fonera-001884882287 ' option 'proto' 'bridge' option 'ipaddr' '192.168.0.2' option 'dns' '213.157.167.157' option 'gateway' '192.168.0.1'

config 'interface' 'hotspotwifi'

option 'proto' 'none'

config 'interface' 'hotspot'

option 'ifname' 'tun0' option 'proto' 'none'

config 'interface' 'vpn'

option 'ifname' 'tun-ovpn' option 'proto' 'none' option 'up' '1'

root@Fonera:~# cat /etc/resolv.conf search FON nameserver 192.168.0.1 nameserver 213.157.167.157 root@Fonera:~# route -n Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 192.168.182.0 0.0.0.0 255.255.255.0 U 0 0 0 tun0 192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 br-lan 169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 br-lan 0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 br-lan root@Fonera:~#

comment:12 Changed 7 years ago by anonymous

I stumbled upon this somewhat old ticket. Is this still a problem on 2.3.7.0 beta2? I just had a go at reproducing this problem, but it doesn't seem to happen for me on beta2 (though it could be that the userzone has just not been updated yet). Could you confirm this?

comment:13 Changed 6 years ago by matthijs

  • Resolution set to worksforme
  • Status changed from investigate to closed

As part of the upcoming 2.3.7.0 firmware release, we're reviewing old open tickets to see if they are still relevant, which is why you get this response now.

I just powered on a 2.0n in bridge mode and it is shown as online now as expected. Possibly something was fixed on the server end to fix this.

If this issue still occurs with the 2.3.7.0 rc2 firmware, feel free to leave a comment here so we can further investigate.

comment:14 Changed 6 years ago by matthijs

  • Milestone Firmware 2.3 deleted

comment:15 Changed 5 years ago by philippe@…

Sorry to wake up this ...

I have a fonera 2.0n working well for ages in DHCP mode, with firmware 2.3.7.1 (dev).

I changed last week my router due to a new Internet provider (ADSL to cable), and I decided to put my Fonera in bridge mode because the plugs are not at the same place in my flat. The main router and the Fonera are now connected with a powerline.

For the bridge mod, I have :

  • IP 192.168.1.1
  • Submask : 255.255.252.0 (as my main router)
  • Gateway : 192.168.0.1 (P of the main router)
  • DNS : 192.168.0.1

The private SSID work fine; the connection to Internet is OK; the main router give the IP perfectly.

But I have problems with the public signal : the power led flash (no heartbeat ?); the public wifi is stopped (no FON_XXX when I check with my android); the dashboard say "Public Wi-Fi: Fonera is offline". Of course, the public signal is enabaeld in the dashboard (I check it twice !). And I'm unable to install plugin's because "You are currently offline and cannot install new applications."

If I go back to DHCP mode the public signal come back after 2/3 minutes; the power led stop blincking and everything is OK. The plugin's panel work.

But 2 or 3 minutes after I go back to bridge mode, same scenario : Publi WIFI stop working, power led blink, etc. Same after a reboot.

Have you an idea ? I paste after my signature the result of the SSH command asked 4 years ago to Mihaly.

Thanks, and "joyeuses Pâques".

Philippe

=============================================
login as: root
root@192.168.1.1's password:

BusyBox? v1.11.1 (2013-12-25 11:03:55 CET) built-in shell (ash)
Enter 'help' for a list of built-in commands.

[snap]

Paco the alpaca jr.



root@Fonera:~# uci export network
package 'network'

config 'interface' 'vpn'

option 'ifname' 'tun-ovpn'
option 'proto' 'none'
option 'up' '1'

config 'interface' 'loopback'

option 'proto' 'static'
option 'ifname' 'lo'
option 'ipaddr' '127.0.0.1'
option 'netmask' '255.255.255.0'

config 'interface' 'lan'

option 'type' 'bridge'
option 'proto' 'static'
option 'ifname' 'eth0.1'
option 'ipaddr' '192.168.1.1'
option 'netmask' '255.255.252.0'
option 'gateway' '192.168.0.1'
option 'dns' '192.168.0.1'

config 'interface' 'wan'

option 'ifname' 'eth0.2'
option 'macaddr' '00:18:84:88:25:e7'
option 'proto' 'none'
option 'auto' '0'

config 'interface' 'hotspot'

option 'ifname' 'tun0'
option 'proto' 'none'

config 'interface' 'hotspotwifi'

option 'proto' 'none'


root@Fonera:~# cat /etc/resolv.conf
nameserver 192.168.0.1

root@Fonera:~# route -n
Kernel IP routing table

Destination Gateway Genmask FlagsMetricRef Use Iface
192.168.0.0 0.0.0.0 255.255.252.0U 0 0 0 br-lan
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 br-lan

0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 br-lan

root@Fonera:~#
=================================

comment:16 Changed 5 years ago by matthijs

This is totally unrelated to the ticket you commented on, but I'll provide a quick response.

If the led blinks and the Fonera claims it is offline, this means that the Fonera cannot perform a DNS request, making it think it is offline. If the problem is introduced by switching to bridge mode, the most likely cause is that the IP configuration you supplied is incorrect. Perhaps your main router does not have a DNS server (and advertises your ISP's server instead of itself in DHCP)? You should revert back to DHCP and then doublecheck the IP and DNS settings that are configured then, those should also work for bridge mode.

comment:17 Changed 5 years ago by Philippe@…

Thanks for your answer. I'll check when I'm back home (easter ...)

But I assume that my ISP router has a working DNS server : the PC which are connected directly to it (through powerline or ISP router's WIFI) have a nice access to Internet. In bridge mode, the Fonera's private signal work well and have access to Internet, as my main PC connected to Fonera with ethernet.
The problem is only with the public signal.

For a diagram of my installation see https://app.box.com/s/lhypiczorqhuplmstj50

Regards

Philippe

comment:18 Changed 5 years ago by matthijs

The main router does not need a DNS server itself, it can also point DHCP clients to your ISP's DNS server directly. In this case, DHCP clients on the Fonera's private signal work fine, but the Fonera uses the wrong DNS server and thus fails.

comment:19 Changed 5 years ago by Philippe <philippe@…>

Thanks +++ Matthijs.

I'll check tonight ... or after Easter.

And sorry for writing in the wrong ticket. I thought, reading the title, that it was the right place !

Philippe

Add Comment

Modify Ticket

Action
as closed The owner will remain iurgi@….
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.