Modify

Opened 8 years ago

Closed 6 years ago

Last modified 6 years ago

#681 closed enhancement (fixed)

Upgrade DynDNS software to support opendns etc.

Reported by: steven@… Owned by:
Priority: high Milestone: Firmware 2.3.7.0
Component: fon-network Version: N/A
Severity: unknown
Cc: ramirez.javier@…, decodecoding@… Hardware: both

Description

Please upgrade ddns package on 2.3.6 with new version from openwrt...it also supports more than just "dyndns" ...but also Opendns and such

More info here : http://fthieme.net/blog/2010/04/08/dns-o-matic-openwrt

Attachments (0)

Change History (17)

comment:1 Changed 8 years ago by matthijs

  • Component changed from fon-base-firmware to fon-network
  • Hardware set to both
  • Milestone Firmware 2.3.7.0 deleted
  • Priority changed from blocker to normal
  • Status changed from new to investigate
  • Summary changed from DynDns service does not work in 2.3.6 to Upgrade DynDNS software to support opendns etc.
  • Type changed from bug to enhancement
  • Version set to N/A

comment:2 Changed 8 years ago by matthijs

Also, DynDNS seems to work ok for me on 2.3.6. If you DynDNS is not working for you at all (excluding the issue in #613), please open a separate ticket for that.

comment:3 Changed 8 years ago by matthijs

#668 also requests support for "no-ip".

comment:4 Changed 8 years ago by steven@…

DYNDNS issue: Dyndns works at "boot" of La Fonera since 2.3.6 but if your uptime is >24h... and you do a "ps -ef" it's very possible the dyndns service (ez-ipupdate) process is gone... this process is responsible for regular checking of "checkip.dyndns.org" to see it the last recorded public ip has changed...if it has... it would tell the new ip to your dyndns account.

in version 2.0.1 they didn't use ez-ipupdate and they only reported to dyndns when there actually was a change on the WAN interface of the fonera... but this feature was only usefull for people who put their fonera directly to the internet(public ip on WAN) or via a "pppoe" session... and not to those who had an "internet router" from their ISP

OPENDNS : on Fonera Classic the "freewlan" addons had a "Dynamic DNS" page which allowed you to configure "dyndns" and "opendns"... the latter has a Dns-o-matic plugin that would allow you to even use several others except Dyndns; and allows you to "filter" stuff... a link could be made to the dhcp / internet page where DNS is mentioned...to use OpenDNS 208.67.220.220 and it's filters

comment:5 Changed 8 years ago by matthijs

Ok, the issue you raise is reported in #613. Good to know there are no other issues.

comment:6 Changed 6 years ago by alanthehat <alanthehat+fonosfera@…>

comment:7 Changed 6 years ago by matthijs

  • Cc ramirez.javier@… decodecoding@… added
  • Milestone set to Firmware 2.3.7.0
  • Priority changed from normal to high
  • Severity set to unknown
  • Status changed from investigate to confirmed

#1121 is a duplicate.

However, it also points out that the DynDNS service is no longer free (which now makes the OpenVPN service unusable without DynDNS). For this reason, I'm raising the priority of this issue and assign it back to the 2.3.7.0 milestone.

And, if we're fixing this, we might as well fix #832 at the same time.

comment:8 Changed 6 years ago by matthijs

  • Status changed from confirmed to testing-fix

comment:9 Changed 6 years ago by matthijs

(In [2086]) ddns-scripts: Add new package.

This copies the package from OpenWRT r31212 without any changes. Note that this does not use the newest available version (r31939), since that uses configuration scripts that are not available on the Fonera.

References: #681

comment:10 Changed 6 years ago by matthijs

(In [2087]) ddns-scripts: Add support for ip_source = none.

This means to not try any ip autodetection in the ddns-scripts and just send updates to the ddns provider every check interval and let the provider detect our public address.

This helps when the Fonera is behind another router, meaning its wan IP is not the public ip. The ddns-scripts also include support for using an online "find my ip" service, but most of those services are either coupled to a ddns provider or do not allow doing automated requests (since those can cause a lot of load).

So, instead of relying on an external IP detection, ddns-scripts can now just send the request to the ddns provider and let them sort it out (most just autodetect the IP in this case).

References: #681

comment:11 Changed 6 years ago by matthijs

(In [2088]) ddns-scripts: Check "enabled" after killing the old daemon.

This allows disabling the daemon by just switching the enabled value and triggering a restart, instead of needing special code.

References: #681

comment:12 Changed 6 years ago by matthijs

(In [2089]) ddns-scripts: Use a different network name in bridge mode.

This is achange that is specific to the Fonera network configuration, that was also present in the old ez-ipupdate package.

References: #681

comment:13 Changed 6 years ago by matthijs

(In [2090]) targets: Include ddns-scripts instead of ez-ipupdate.

References: #681

comment:14 Changed 6 years ago by matthijs

  • Resolution set to fixed
  • Status changed from testing-fix to closed

(In [2092]) luci-ddns: Switch to using ddns-scripts.

Previously, luci generated config for ez-ipupdate, which is no longer used. This also adds an extra option to switch between sending the Fonera wan IP and letting the DDNS provider detect the IP itself and clarifies the interface a bit by using more verbose labels.

Closes: #681, #832

comment:15 Changed 6 years ago by matthijs

(In [2093]) luci: Gracefully upgrade ddns configuration.

Previously, /etc/config/ddns would contain config for ez-ipupdate, but now ddns-scripts is used. This change gracefully converts the configuration to the new format during upgrades (and also during a settings backup, but that is less relevant).

References: #681

comment:16 Changed 6 years ago by matthijs

(In [2100]) busybox/wget: Urldecode username/password before sending to server

This imports a patch from OpenWRT, which backports a change from upstream busybox. A few non-functional changes were made to the patch to make it apply to this version of busybox.

Making wget urldecode the username and password values, makes ddns-scripts work with providers that use HTTP authentication, since ddns-scripts assumes wget performs this decoding (just like curl and the real wget do).

References: #681

comment:17 Changed 6 years ago by matthijs

(In [2140]) openvpn: Use the new ddns config file format.

In r2092, the DDNS package used was switched to ddns_scripts, which uses a slightly different configuration file format. This commit fixes that, which should cause OpenVPN to use the DDNS filename again.

References: #681, #508

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.