Modify

Opened 8 years ago

Closed 7 years ago

Last modified 4 years ago

#686 closed enhancement (fixed)

Bring the Option to set Custom DNS in PPoE mode

Reported by: Josemi Owned by:
Priority: normal Milestone: Firmware 2.3.7.0
Component: fon-network Version: 2.3.6.0 (Gari)
Severity: minor
Cc: klimpong@…, schnunz@…, mihaly.reg@… Hardware: both

Description

I think that is a must-have to Bring the Option to set Custom DNS in PPoE mode

Attachments (0)

Change History (11)

comment:1 Changed 8 years ago by matthijs

  • Component changed from fon-base-firmware to fon-network
  • Hardware set to both
  • Milestone Firmware 2.3.7.0 deleted
  • Status changed from new to investigate
  • Version set to 2.3.6.0 (Gari)

It seems currently PPoE doesn't allow setting manual DNS server override, like DHCP does. This is probably a small interface-only change, though it might need changes in the ppp code as well.

comment:2 Changed 8 years ago by Josemi <josemi@…>

Any news?

comment:3 Changed 8 years ago by matthijs

  • Milestone set to Firmware 2.3
  • Severity set to minor

Another quick look shows that /lib/network/ppp.sh (called by /lib/network/pppd.sh I think) already passes the peerdns option to pppd. By setting that to 0, pppd should ignore any received DNS servers. Then only the static dns servers need to be configured, but perhaps there is some generic piece of network setup code that handles that already?

comment:4 Changed 8 years ago by matthijs

#927 is a duplicate of this ticket.

comment:7 Changed 8 years ago by matthijs

  • Cc klimpong@… added

comment:8 Changed 7 years ago by matthijs

  • Cc schnunz@… mihaly.reg@… added
  • Milestone changed from Firmware 2.3 to Firmware 2.3.7.0

This issue was raised on the blog by a few people as well, I'll see if I can fix this before the 2.3.7.0 final.

comment:7 Changed 7 years ago by matthijs

(In [1993]) ppp: Allow overriding the DNS server used.

This backports r19093 from OpenWRT trunk without any changes. Note that this just changes the networking scripts, there is no way to override the DNS from the WebGUI yet.

References: #686

comment:8 Changed 7 years ago by matthijs

  • Resolution set to fixed
  • Status changed from investigate to closed

(In [1994]) luci: Allow setting a custom DNS server in pppoe mode.

Closes: #686

comment:9 Changed 7 years ago by matthijs

(In [2017]) fonbase: Fix pppoe mode when DNS is set top automatic.

The new custom DNS setting for pppoe introduced in r1994 did not correctly check for the "automatic" setting (which is "0", not ""). This corrects that mistake and makes pppoe work with automatic DNS again.

References: #686

comment:10 Changed 6 years ago by matthijs

(In [2213]) fonbase: Really fix pppoe mode when DNS is set to automatic.

In r2017, this same thing was supposed to be fixed, but the fix was completely wrong. This fixes the broken condition and also explicitly sets the peerdns value to 1 (which is the default) when using automatic dns to make the code a bit more clear.

Due to a syntax error in the broken code, automatic DNS was still working after r2017, but static DNS was not. When in r2129 this syntax error was fixed, static DNS started working, but automatic DNS was broken again.

References: #686 Closes: #1229

comment:11 Changed 4 years ago by guides in St.Petersburg

Hi this is somewhat of off topic but I was wanting to know if blogs use WYSIWYG editors or if you have to manually code with HTML. I'm starting a blog soon but have no coding skills so I wanted to get advice from someone with experience. Any help would be enormously appreciated!

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.