Modify

Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#818 closed bug (moreinfoneeded)

USB printer does not work when connected through a hub

Reported by: carelvicer@… Owned by:
Priority: normal Milestone:
Component: fon-plugin-printer Version: 2.3.6.0 (Gari)
Severity: unknown
Cc: c.lukassen@… Hardware: 2.0n (FON2300)

Description

Is er een oplossing voor het feit dat de printer HP970Cxi prima werkt als ie op de USB -poort van de Fonera wordt aangesloten maar niet als ie via een powered 4-poort hub wordt aangesloten? In het dashboard zie je het kruisje verdwijnen zodra de usb hub met printer wordt aangesloten. Zodra ik hem weer rechtstreeks aansluit verschijnt het kruisje bijna onmiddelijk weer. De firmware op de fonera is versie 2.3.6

Attachments (0)

Change History (5)

comment:1 Changed 9 years ago by steven@…

To add to this defect: He is using a Fonera 2.0n With firmware 2.3.6 He is using a "powered usb hub" he has installed the official (latest available) FON plugin to have "printer support"

On a fonera 2.0n the "printer plugin" only seems to work when you are not using a usb hub.... It can be easily tested in the dashboard : you will see a "green +" on the printer plugin icon when connecting the printer directly to the 1 usb port on the device; and it will be gone when placing a usb hub inbetween

Printer type: HP970Cxi

comment:2 Changed 9 years ago by steven@…

No such issue on the Fonera 2.0g with 2.3.0.1 firmware (latest available) Here a usb 2.0 hub is REQUIRED to have the printer plugin work as advertised!

comment:3 Changed 9 years ago by matthijs

  • Component changed from unknown to fon-plugin-printer
  • Status changed from new to investigate
  • Type changed from request to bug

In the future, please report bugs in English (I can read Dutch, but none of the other developers can). Steven, thanks for the translation.

Steven, are you seeing the same issue, or did you just discuss this with the reporter?

A very rough test here shows no difference between a powered hub and direclty, but in neither case I get a green plus (so I suspect my printer is not supported at all, though it is listed in the dashboard under "Printer").

comment:4 Changed 9 years ago by matthijs

  • Summary changed from printeraansluiting op fonera via hsb-hub werkt niet to USB printer does not work when connected through a hub

Could you perhaps try using the development firmware, connect via SSH and execute the following command?

root@Fonera:~# cat /proc/bus/usb/devices 

If you don't understand how to do this, just say so and I will write some more elaborate instructions.

comment:5 Changed 6 years ago by matthijs

  • Resolution set to moreinfoneeded
  • Severity set to unknown
  • Status changed from investigate to closed

As part of the upcoming 2.3.7.0 firmware release, we're reviewing old open tickets to see if they are still relevant, which is why you get this response now.

If this issue still occurs with the 2.3.7.0 rc2 firmware, feel free to leave a comment here so we can further investigate.

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.