Modify

Opened 8 years ago

Last modified 5 years ago

#828 confirmed bug

fon.com is sooooooo slow

Reported by: decodecoding@… Owned by: john.crispin@…
Priority: normal Milestone:
Component: fon-web Version: Other
Severity: unknown
Cc: Hardware: unknown

Description

It takes almos 15-20 second to get logged into your fon.com account to check your profile. Couldn't it be a little faster?

Attachments (0)

Change History (23)

comment:1 Changed 8 years ago by matthijs

  • Status changed from new to infoneeded
  • Type changed from enhancement to bug
  • Version changed from Unknown to Other

I can't reproduce this, when I login it takes around 4-5 seconds which seems reasonable. Any chance there is a problem at your end? Perhaps you could try on another browser / PC / internet connection?

comment:2 Changed 8 years ago by decodecoding@…

Using different browsers in different broadband connections, still logging in takes several seconds, many more than it takes logging into other web based services.

comment:3 Changed 8 years ago by matthijs

But not 20-25 seconds anymore? Just to confirm that we're actually seeing the same (since it takes several seconds here as well, which I agree is a bit slow).

comment:4 Changed 8 years ago by decodecoding@…

I've been timing logging in and the average value I get is 20 seconds...

comment:5 follow-up: Changed 8 years ago by giuseppeg88@…

I have the same problem (really, I've always had this). Firefox employes 34 seconds to login; internet explorer: 40 seconds. The website is slow also to see the other pages (after login): about 5 seconds per page. May be dependent on the number of owned foneras?? I have 5 foneras.

comment:6 in reply to: ↑ 5 Changed 8 years ago by decodecoding@…

Replying to giuseppeg88@…:

I have the same problem (really, I've always had this). Firefox employes 34 seconds to login; internet explorer: 40 seconds. The website is slow also to see the other pages (after login): about 5 seconds per page. May be dependent on the number of owned foneras?? I have 5 foneras.

Hi, actually I have 7 foneras (all active) linked to my fon profile. Maybe this could be a cause of this sluggishness when logging into our Fon profile. It's just a guess...

Someone with just one fonera linked to his profile could test the opposite scenario...

comment:7 Changed 8 years ago by decodecoding@…

I'm starting to think that this delay when logging in may be related to the number of foneras you have associated to your Fon account.

I've recently tested an account with just one fonera linked and there is not such delay. Delay happens when I access to an accout with 6 associated foneras.

Would be good if someone else could test this two scenarios.

comment:8 Changed 8 years ago by matthijs

  • Severity set to unknown

I've contacted the system administrator about this issue. Apparently there are some load issues with the website, causing this slowness. They're already working on some changes to improve scalability, I'll keep this report updated.

comment:9 Changed 8 years ago by matthijs

  • Status changed from infoneeded to confirmed

comment:10 Changed 8 years ago by matthijs

  • Summary changed from Login into fon.com is sooooooo slow to fon.com is sooooooo slow

#848 was marked as a duplicate of this bug. It concerns the entire website, not just the login (which I had also confirmed), thus I'm updating the bug title.

comment:11 Changed 8 years ago by matthijs

Are you guys still seeing this slowness? The website seems faster to me now?

comment:12 Changed 8 years ago by giuseppeg88 <giuseppeg88@…>

I still have this problem: 30 seconds to login and 5-25 seconds to navigate through the pages of the panel.

comment:13 Changed 6 years ago by matthijs

  • Resolution set to worksforme
  • Status changed from confirmed to closed

As part of the upcoming 2.3.7.0 firmware release, we're reviewing old open tickets to see if they are still relevant, which is why you get this response now.

It seems this is no longer an issue for me, login and browsing works pretty fast now.

If this issue still occurs for you, feel free to leave a comment here so we can further investigate.

comment:14 Changed 6 years ago by giuseppeg88@…

Unfortunately I still have this problem: 30 seconds to login and 5-25 seconds to navigate through the pages of the panel.

comment:15 Changed 6 years ago by matthijs

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Hmm, weird.

Would you perhaps be willing to share your login details (after changing them) with me privately, so we can see if the problem is perhaps something in your account?

comment:16 Changed 6 years ago by giuseppeg88@…

@matthijs: I sent you an e-mail.

comment:17 Changed 6 years ago by matthijs

  • Status changed from reopened to confirmed

Ok, I just tested with Giuseppe's account, and it is also slow to login for me (45 seconds).

However, browsing is not slow for me on most pages.

I did notice that the "My Messages" page and the "My Fon" homepage are both slow, which leads me to believe this might be related to having messages in your inbox or sent folders, causing the rendering of the page to slowdown. This would also suggest that it is not the login itself that is slow, only the rendering of the subsequent "My Fon" page.

I'll see if I can make my own account slow as well by sending some messages...

comment:18 Changed 6 years ago by matthijs

Seems there might be two separate problem: The "My Contacts" tab on the "My Messages" page is always slow (even with my account which still logs in fast).

Adding a dozen messages to my inbox or sent folder or adding a dozen contacts to my contacts list does not help to make the "My Fon" page slow like in Giuseppe's account.

For now, I can't pinpoint the problem exactly, but the connection with messages / contacts is specific enough to report this problem to the Fon webteam. Hopefully they can figure out where the problem is.

comment:19 Changed 6 years ago by anonymous

For my own refernence, the internal ticket ID is QA-865

comment:20 Changed 5 years ago by matthijs

The Fon webteam made a change which should fix this. Could you guys check if the problem disappeared for you?

comment:21 Changed 5 years ago by matthijs

Sorry, seems I misinterpreted an internal comment, I think the bug has not been solved after all.

comment:22 Changed 5 years ago by Thomas Horner <trac.fonosfera.org@…>

i have tried but i cannot reproduce the problem.
the login works quickly as with any other web page.

comment:23 Changed 5 years ago by matthijs

IIRC the cause turned out to be having a lot of Fon passes in your account, so it doesn't occur for all accounts. Thanks for checking, though!

Add Comment

Modify Ticket

Action
as confirmed The owner will remain john.crispin@….
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.