Modify

Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#830 closed bug (fixed)

Register button is broken in 2.3.6

Reported by: steven@… Owned by: matthijs
Priority: high Milestone: Firmware 2.3.6.1
Component: fon-web Version: 2.3.6.0 (Gari)
Severity: minor
Cc: Hardware: 2.0n (FON2300)

Description

First : this is NOT a duplicate of bug#392 where one is "unregistered" due to a firmware upgrade.

People unbox the fonera... Notice they can upgrade to 2.3.6 and do so Then they want to push the register button WRONG

Firmware 2.3.6 only has a working heartbeat service...it has another #Bug where it can not talk to the FONwebsite to retrieve (pull?) www.fon.com router configurations... eg Family&friends, changing passwords or SSID is IMPOSSIBLE

Registration IS IMPOSSIBLE only solution/workaround -> downgrade to 2.3.0.0 ... register... Upgrade to 2.3.6.0

a lot of people reported the issue:

Attachments (1)

reg.lua (913 bytes) - added by matthijs 7 years ago.
Fixed version of /usr/lib/lua/luci/fon/reg.lua

Download all attachments as: .zip

Change History (24)

Changed 7 years ago by matthijs

Fixed version of /usr/lib/lua/luci/fon/reg.lua

comment:1 Changed 7 years ago by matthijs

  • Component changed from fon-base-firmware to fon-web
  • Owner set to matthijs
  • Priority changed from normal to high
  • Severity set to minor
  • Status changed from new to accepted

I can confirm this. The register link hasn't been updated to take the new MAC address assignment into account, so it sends the wrong address.

I've attached a fixed version of reg.lua, that should go into /usr/lib/lua/luci/fon. If you still have an unregistered Fonera, please test if this fixes the problem (all of mine are already registered).

See this page for info on how to access files on the Fonera and/or just run the following command on your Fonera:

root@Fonera:~# wget -O /usr/lib/lua/luci/fon/reg.lua http://trac.fonosfera.org/fon-ng/raw-attachment/ticket/830/reg.lua

comment:2 Changed 7 years ago by matthijs

  • Milestone set to 2.3.6.1

comment:3 Changed 7 years ago by xmarquez@…

I have the same problem, I cannot register. I have downgraded it to 2.3.0.0, but I continue having the same problem. When I click Register, the browser sends me to the dashboard or another page. Is there another workaround?

comment:4 Changed 7 years ago by matthijs

If you're seeing this in 2.3.0.0 as well, I think this is a different problem.

Also, I've just downgraded my 2.0n to 2.3.0.0 and I get a (seemingly) valid register link (actual data obfuscated with x's):

https://www.fon.com/main/standaloneLogin?h=99debe66b0bbd01ce5144900c8axxxxx&m=00-18-84-88-2e-xx

What url does the "register" button link to on your 2.3.0.0 version?

comment:5 Changed 7 years ago by steven@…

in the meanwhile v2.3.6.0 is installed and the url is thesame as you mentioned albeit different mac adres but also starting with 00-18-84...

Fon support (David) says: That mac has not been registered by our servers as online, so either that Fonera is not connected to internet, or their DSL or cable router is blocking it, or is not properly installed.

comment:6 follow-up: Changed 7 years ago by matthijs

The reason the mac is different is because the register link uses the wrong one (the Fonera has four, and they were recently reassigned). The fix I posted above should fix that issue. Could you see if it works for you? (Fix is at http://trac.fonosfera.org/fon-ng/ticket/830#comment:1)

comment:7 in reply to: ↑ 6 Changed 7 years ago by anonymous

Checking the HTML code, I can see the problem:

<li id="registerButton"><a class="icon" href="">Register</a></li>

Note that href = ""

Your proposed solution http://trac.fonosfera.org/fon-ng/ticket/830#comment:1 seems to technical for me. I just purchased the fonera 2 days ago and I was following the manual instructions. I have needed to downgrade it and now it seems that I need to install a dev firmware, ssh protocol, etc... It seems really very complicated for just installing the Fonera. Is there a simpler way? Am I the only one that have this problem?

Thanks

comment:8 Changed 7 years ago by matthijs

Thanks for the extra info, it seems that 2.3.0.0 has a different bug, then.

You could probably contact fon tech support (fon.com/support IIRC, find the "contact" link) and ask if they can manually register your Fonera (I think they can).

Alternatively, you can wait for the next update, which should be forthcoming as soon as we get some internet connection issues sorted out (see http://blog.fonosfera.org/problems-with-gari-the-hummingbird/)

comment:9 Changed 7 years ago by koter84@…

i also tried downgrading, but the link stays blank. just like with http://trac.fonosfera.org/fon-ng/ticket/830#comment:7

i send a support call to fon asking to enable my mac in my fon-account, but i'm still waiting for a reply to that ticket...

comment:10 Changed 7 years ago by matthijs

  • Resolution set to fixed
  • Status changed from accepted to closed

This issue is fixed in r1689 (backported for 2.3.6.1 in r1691).

comment:11 Changed 7 years ago by elm <elm+fonosfera@…>

Doesn't work for me. Applied patch by hand but register doesn't work.

root@Fonera:~# ifconfig -a|grep Ethernet
apcli0    Link encap:Ethernet  HWaddr 00:18:xx:xx:xx:FA  
br-lan    Link encap:Ethernet  HWaddr 00:18:xx:xx:xx:F8  
br-lan:1  Link encap:Ethernet  HWaddr 00:18:xx:xx:xx:F8  
eth0      Link encap:Ethernet  HWaddr 00:18:xx:xx:xx:FB  
eth0.1    Link encap:Ethernet  HWaddr 00:18:xx:xx:xx:FB  
eth0.2    Link encap:Ethernet  HWaddr 00:18:xx:xx:xx:FB  
ra0       Link encap:Ethernet  HWaddr 00:18:xx:xx:xx:F8  
ra1       Link encap:Ethernet  HWaddr 00:18:xx:xx:xx:F9  
wds0      Link encap:Ethernet  HWaddr 00:18:xx:xx:xx:F8  
wds1      Link encap:Ethernet  HWaddr 00:18:xx:xx:xx:F8  
wds2      Link encap:Ethernet  HWaddr 00:18:xx:xx:xx:F8  
wds3      Link encap:Ethernet  HWaddr 00:18:xx:xx:xx:F8

Link: https://www.fon.com/main/standaloneLogin?h=21cd821c4d269f9256ec4d8c543f59f8&m=00-18-xx-xx-xx-fb

xx are all the same in every mac address

comment:12 Changed 7 years ago by matthijs

I'll have a closer look at this next week.

comment:13 Changed 7 years ago by matthijs

A bit of further investigation shows that the fonera of elm is not present in Fon's database at all, meaning that the heartbeat client is somehow not being able to connect. This is most definately a different issue than the one described in this ticket, so let's not discuss it any further (I'll take this up by email / IRC with the reporter).

comment:14 follow-up: Changed 7 years ago by anonymous

Fixed with

root@Fonera:~# wget -O /usr/lib/lua/luci/fon/reg.lua http://trac.fonosfera.org/fon-ng/raw-attachment/ticket/830/reg.lua

comment:15 Changed 7 years ago by elm elm+fonosfera@…

The problem is that the Network i'm in is blocking the dns queres that are needed for the heartbeat. So there is no bug in the fonera firmware.

comment:16 Changed 7 years ago by megyesisandor@…

Please help me to finish the registration process! After login into www.fon.com it says my Fonera 2.0n sharing wifi, but I still see the exclamation sign(!) on the regoistering button on my dashboard. Important! I use Win7 Prof 32 bit system. Thanks a lot!

comment:17 Changed 7 years ago by matthijs

If fon.com shows the Fonera, it's registered ok. The Fonera itself keeps a different "registered" status, which is not always consistent with the official one (see #392). If you applied the fix here and registered with 2.3.6.0, then #620 will probably have prevented the Fonera from changing its registered status. Considering the registered status on the Fonera is only used to determine whether or not to show the registration button, there should be nothing to worry about.

comment:18 in reply to: ↑ 14 ; follow-up: Changed 7 years ago by Henke <honk@…>

Replying to anonymous:

Fixed with

root@Fonera:~# wget -O /usr/lib/lua/luci/fon/reg.lua http://trac.fonosfera.org/fon-ng/raw-attachment/ticket/830/reg.lua

Works! Thanks!

comment:19 in reply to: ↑ 18 Changed 7 years ago by anonymous

2.3.6.1 didn't fix this a reboot after didn't fix it

but getting this reg.lua afterwards FIXED IT!

logging: (radius timeouts?) http://pastebin.com/87gMw4Rk

internet settings : dhcp; normal WAN (no ppoe) no bridging

afterwards I finally found a localuser on /etc/fon and I did wait over 30 minutes did a "save" and edited several users on fon.com ?

comment:20 Changed 7 years ago by matthijs

Hmm, aren't you mixing up registration with Family & Friends? I'm not sure how getting reg.lua could help, it's the same as in 2.3.6.1. Perhaps this is timing-related? The radconfig errors also suggest you're seeing #874, which is not fixed in 2.3.6.1.

comment:21 Changed 7 years ago by steven@…

It's the only thing I was able to find with "logread"... I was connected by LAN to the device... and did continously "ls /etc/fon" during an hour while another browser session was on the "fon.com" userzone where the fonera was reported as being online...and changing/updating/saving the friends&family a 3rd browser session was on the GUI of the fonera 2.0n

the localuser was not present...untill I finally wget this reg file...

"registration" button only reverted back to the dashboard... the fonera was allready registered... I checked mac adres on my website I still have to plan a visit to family to try out registration/2.3.6.1 on their fonera 2.0n

comment:22 Changed 7 years ago by João Oliveirinha <joliveirinha@…>

As I said in the blog.. I already upgraded the firmware and the registration button is not working.. still. I was trying to see if I could see why and I tried to understand how the registration link is built.

The part of getting the mac is trivial but the part of the hash does not make sense because of the function gethash().

This..

cat /etc/chilli.conf | grep 'uamserver' | awk -F'/sec/' '{ print $2 }' | awk -F'/' '{ print $1 }'

does not return anything because that line only has this:

uamserver https://login.fon.com/cp/index.php

So, I was thinking that this maybe the real problem. No?

comment:23 Changed 7 years ago by matthijs

You're on the right track, the real problem is the connection to the radius server that gets proper values into chilli.conf. So the bug in this ticket is in fact fixed, but unfortunately there is another problem (but it is probably solvable on server-side). See #874 for details on this other bug.

Add Comment

Modify Ticket

Action
as closed The owner will remain matthijs.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.