Modify

Opened 9 years ago

Closed 6 years ago

Last modified 5 years ago

#837 closed bug (moreinfoneeded)

FTP server - 4 GB limit

Reported by: henke81@… Owned by: iurgi@…
Priority: normal Milestone:
Component: fon-plugin-pureftpd Version: 2.3.6.0 (Gari)
Severity: unknown
Cc: Hardware: 2.0n (FON2300)

Description

When will the 4 GB file limit be lifted???!? I get an error: "the server misses support for resuming files greater than 4 GB" when trying to resume a 7GB file. When the download reached 4GB the connection dropped dead!

I'd also like to have be able to set up multiple user accounts so my friends don't get kicked all the time due to the "maximum user limit" reached.

Attachments (0)

Change History (4)

comment:1 Changed 9 years ago by matthijs

  • Component changed from fon-plugins to fon-plugin-pureftpd
  • Status changed from new to investigate

I've done a quick look at the large file stuff for pureftpd, but it seems pureftpd is compiled with large file support. However it seems that that means it can handle >2GB. You're having trouble with >4GB.

Could you describe the problem a bit more precisely? What did you do, what happened? Can you reproduce the problem everytime? Does it only happen when resuming a download, or all the time?

As for the multiple user accounts, see #850, which describes that same request. I've added you to the CC list there.

comment:2 Changed 6 years ago by matthijs

  • Resolution set to moreinfoneeded
  • Status changed from investigate to closed

As part of the upcoming 2.3.7.0 firmware release, we're reviewing old open tickets to see if they are still relevant, which is why you get this response now.

If this issue still occurs with the 2.3.7.0 rc2 firmware, feel free to leave a comment here so we can further investigate.

comment:3 Changed 5 years ago by Rajan

(I'm borrowing this thaerd to comment on a tweet. Twitter does not allow non-members to respond directly. Pardon the intrusion.)On twitter Manuel asks whether TCO is needed in cases where the system provides incremental stack growth or where some kind of co-routine is an alternative.I say the tail recursive programming style is more fundamental for many problems than co-routines. And that TCO is a more fundamental implementation technique than incremental stacks.Finally, consider an infinite loop, e.g. a top-level event loop. This can be expressed most generally using recursion. Yet this cannot run forever using an incremental stack.I now return you to delimited continuations. Puns intended.

comment:4 Changed 5 years ago by RichardPt

Games could be submitted south to the better lands, and the cells had the work of energy, putting the reborn city quite in lack with out such 1960s. https://my.swu.edu/ICS/icsfs/tabfen15.html?target=d7487602-0b1f-4dcd-901c-cb8650a7ae0a He falls to the nomination and drops the molotov, rendering it cerebral.

Add Comment

Modify Ticket

Action
as closed The owner will remain iurgi@….
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.