Modify

Opened 8 years ago

Last modified 6 years ago

#840 investigate enhancement

K3765 from vodafone in Netherlands not recognised

Reported by: m.wittebrood@… Owned by:
Priority: normal Milestone:
Component: fon-network-3g Version: N/A
Severity: unknown
Cc: tibivasilescu@…, bisont87@…, davide@… Hardware: both

Description

Dear friends,

I just received my fonera 2.0n and installed latest firmware 2.3.6.0

My vodafone dongle K3765 is not recognised thus I cannot use the fonera. I tried several settings in the UMTS/3G section but none helped.

I found a discussion on http://www.mail-archive.com/wireless@ml.ninux.org/msg02277.html where somebody managed to get the K3765 running but this seems to be linux tools and I am no expert in Linux.

Hope you can help,

marcel

Attachments (4)

log1.TXT (10.0 KB) - added by m.wittebrood@… 8 years ago.
logread results
log2.txt (10.0 KB) - added by m.wittebrood@… 8 years ago.
logread results
cat command.txt (1.8 KB) - added by m.wittebrood@… 8 years ago.
cat /proc/bus/usb/devices output
dmesg.txt (15.3 KB) - added by m.wittebrood@… 8 years ago.
dmesg output

Download all attachments as: .zip

Change History (17)

comment:1 Changed 8 years ago by matthijs

  • Status changed from new to infoneeded

Most of the instructions in that thread don't seem to be needed anymore: 2.3.6.0 ships usb_modeswitch and ships a configuration file for the K3765. AFAICS, it should be supported by the Fonera already.

Could you get me the result of the "logread" command, shortly after you plug in the dongle, so I can see what is happening exactly?

See http://trac.fonosfera.org/fon-ng/wiki/reportbugs for information on how to run commands, and get the output here.

Changed 8 years ago by m.wittebrood@…

logread results

Changed 8 years ago by m.wittebrood@…

logread results

comment:2 Changed 8 years ago by m.wittebrood@…

Dear Matthijs,

I have the logread results attched for 2.3.6 developer version (GARI). I tried 2 times thus 2 logfiles.

Thanks for your fast reaction !

best regards,

marcel

comment:3 Changed 8 years ago by matthijs

From the logfiles, it seems usb_modeswitch is succesful (so the modem get switched into "modem mode"). However, it seems there are no ttyUSB devices created, which are used by umtsd to communicate with the modem.

Could you also get the results of the following two commands?

root@Fonera:~# dmesg
root@Fonera:~# cat /proc/bus/usb/devices

Changed 8 years ago by m.wittebrood@…

cat /proc/bus/usb/devices output

Changed 8 years ago by m.wittebrood@…

dmesg output

comment:4 Changed 8 years ago by m.wittebrood@…

dear matthijs,

I attached the output from both requested commands.

kind regards,

marcel

comment:5 Changed 8 years ago by matthijs

  • Cc tibivasilescu@… bisont87@… added
  • Hardware changed from 2.0n (FON2300) to both
  • Status changed from infoneeded to investigate

#812 and #879 are duplicates of this ticket (though #879 concerns 2.0g, but umtsd should be the same there).

comment:6 Changed 8 years ago by matthijs

  • Milestone set to Firmware 2.3
  • Status changed from investigate to confirmed

There is a guide on making this device work here: http://www.nervous.it/lang/en-us/2010/06/huawei-k3765-and-fonera-20n/

The summary of this guide is to put this in /etc/config/umtsd:

config 'umtsd' 'umtsd'
 option '_country' '_custom'
 option 'apn' 'replacewithyourapn'
config 'umtsdstate' 'umtsdstate'
config 'umtsdevice' 'option12D11465'
 option 'vendor' 'Huawei'
 option 'device' 'K3765'
 option 'data' '/dev/ttyUSB0'

 option 'cmd' '/dev/ttyUSB0'

and run:

echo "0x12d1 0x1465" >/sys/bus/usb-serial/drivers/option1/new_id

The latter causes the option serial driver to handle the device. We should update the option kernel driver to a later version that already knows that it needs to handle this id.

Note that this concerns the Huawei K3765. ZTE also makes a K3765-z model, which looks similar but has different USB ids (0x19d2:0x2000 and 0x2002 after modeswitch). To get that working, we'll need to add a proper usb_modeswitch config (included in recent versions of usb-modeswitch-data). This model also needs an updated kernel driver, or the new_id command above.

comment:7 Changed 8 years ago by matthijs

Hmm, seems the modeswitch for the -Z model is a bit more complicated than I though (I was looking at the start post of this topic, but things are more complicated than that. The usb-modeswitch-data package offers a modeswitch config file that is more complicated, perhaps that one works.

comment:8 Changed 8 years ago by matthijs

  • Cc davide@… added

Ok, for the -z model, an updated usb-modeswitch (1.1.4) with recent datafiles (20100826) manages to switch it out of the box. Or at least, the one owned by davide, there seem to be different models with the same usb id's around... usb-modeswitch does not know about the target usb id (19d2:2002), but this only seems to cause usb-modeswitch to log that the switch failed, while it actually worked. I'll ask upstream to add this id nonetheless.

To make the ZTE K3765-z model work with umtsd, the following should be set in /etc/config/umtsd:

config 'umtsdevice' 'option19D22002'
        option 'data' '/dev/ttyUSB3'
        option 'cmd' '/dev/ttyUSB3'

Note that there is no need for the new_id command, as I suggested above, the 2.0n firmware already contains an updated option driver which knows about 19d2:2002.

comment:9 Changed 8 years ago by m.wittebrood@…

Dear matthijs,

my vodafone huawei proved to be not the -z model

you stated above:

option '_country' '_custom' option 'apn' 'replacewithyourapn'

I had to use : option '_country' '_nl' option 'apn' 'live.vodafone.com'

The only strange thing is that I saw the UMTS running in the desktop. When I tried to connect to the internet I got the orange screen " your internet is misconfigured"

Could not get it right for about half an hour and I almost gave up, then I decided to ping google: ping 74.125.45.100 ping google.com

Both answered.... And after that I could enter the Internet.

No idea how stable this will be........

comment:10 Changed 8 years ago by m.wittebrood@…

rather unstable.

I disconnected the power of the fonera and tried again.

I had to issue the command: echo "0x12d1 0x1465" >/sys/bus/usb-serial/drivers/option1/new_id again to get the 3G connection running.

ping to google ip number does not work any more, get "time out"

comment:11 Changed 8 years ago by matthijs

usb_modeswitch upstream has added the 19d2:2002 target id:

Josua Dietze wrote:

The target product ID will be added to the next data pack release 20110227, due tomorrow.

comment:12 Changed 7 years ago by m.wittebrood

OK, I finally got it stable working with version 2.3.7.1

In the Netherlands see for apn settings http://www.vodafone.nl/zakelijk/klantenservice/Toestelinstellingen/Algemene_instellingen/ then I followed http://www.nervous.it/lang/en-us/2010/06/huawei-k3765-and-fonera-20n/ I corrected some errors from nervous.it so follow below (for 'pin' use your own pin.)

•WINSCP (from winscp.net) into your Fonera 2.0N router. •edit /etc/config/umtsd: config 'umtsd' 'umtsd'

option 'pin' '1234' option 'user' 'vodafone' option 'pass' 'vodafone' option '_country' 'nl' option '_provider' 'nl_7' option 'apn' 'office.vodafone.nl'

config 'umtsdstate' 'umtsdstate'

config 'umtsdevice' 'option12D11465'

option 'vendor' 'Huawei' option 'device' 'K3765' option 'data' '/dev/ttyUSB0' option 'cmd' '/dev/ttyUSB0'

Create the file /etc/usb-modeswitch.conf with the following content:

DefaultVendor?= 0x12d1 DefaultProduct?= 0x1520 TargetVendor?= 0x12d1 TargetProduct?=0x1465 MessageContent?="55534243123456780000000000000011060000000000000000000000000000"

Also create the file /etc/init.d/k3765:

#!/bin/sh /etc/rc.common START=90 usb_modeswitch sec=2 sleep $sec echo "0x12d1 0x1465" >/sys/bus/usb-serial/drivers/option1/new_id

Finally run:

chmod 777 /etc/init.d/k3765 /etc/init.d/k3765 enable

Now when I reboot the router, the Internet works...........

comment:13 Changed 6 years ago by matthijs

  • Milestone Firmware 2.3 deleted
  • Status changed from confirmed to investigate
  • Type changed from bug to enhancement
  • Version changed from 2.3.6.0 (Gari) to N/A

As part of the upcoming 2.3.7.0 firmware release, we're reviewing old open tickets to see if they are still relevant, which is why you get this response now.

We will revamp the 3G point at some point in the future. When this happens, we'll need to revisit supporting this 3G stick as well.

Add Comment

Modify Ticket

Action
as investigate The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.