Modify

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#842 closed bug (fixed)

Port forwarding deletion need reboot

Reported by: matthijs Owned by: john.crispin@…
Priority: high Milestone: Firmware 2.3.7.0
Component: fon-web Version: 2.3.6.0 (Gari)
Severity: minor
Cc: Hardware: 2.0n (FON2300)

Description

When you configure a port forward in the webgui, the firewall is not reloaded automatically. This needs a manual firewall restart (/etc/init.d/firewall restart) or complete router reboot to work.

This issue is making people think that port forwarding is not working at all (see #820 for example).

Attachments (0)

Change History (7)

comment:1 Changed 8 years ago by matthijs

  • Status changed from new to confirmed

comment:2 Changed 8 years ago by anonymous

Hello everybody;

since I installed 2.3.6.0 firmware forwarding through the web GUI gives me this error message:

/usr/lib/lua/luci/cbi.lua:316: Unable to read UCI data: firewall stack traceback:

[C]: in function 'error' /usr/lib/lua/luci/cbi.lua:316: in function 'init' /usr/lib/lua/luci/util.lua:68: in function 'Map' /usr/lib/lua/luci/model/cbi/fon_fw/portfwd.lua:4: in function 'func' /usr/lib/lua/luci/cbi.lua:88: in function 'load' /usr/lib/lua/luci/dispatcher.lua:677: in function 'target' /usr/lib/lua/luci/dispatcher.lua:368: in function 'dispatch' /usr/lib/lua/luci/dispatcher.lua:133: in function </usr/lib/lua/luci/dispatcher.lua:132>

Reset router has had no effect; I will try reset to factory default and report here.

grtz Jos

comment:3 Changed 8 years ago by JoepieNL

reset to factory worked !

comment:4 Changed 8 years ago by matthijs

  • Status changed from confirmed to investigate

Ok, good. However, the backtrace you posted is probably unrelated to the actual topic of this report.

Furthermore, considering other reports, the problems with port forwarding might be more complex that just what's stated here. This needs further investigation, though.

comment:5 Changed 8 years ago by matthijs

  • Status changed from investigate to confirmed
  • Summary changed from Port forwarding configuration changes need reboot to Port forwarding deletion need reboot

Even though I did report this ticket, I don't actually think what is says is correct. It seems that the firewall is actually reloaded after changing the port forwarding configuration, so adding new port forwardings do take effect immediately. I've tested this with both 2.3.6.1 as well as the latest svn version. I'm not sure why this didn't work before, though.

There is one problem, though: When deleting port forwards, the firewall is not reloaded properly, leaving the old port forwards in effect. Rebooting or adding another port forward fixes this.

I'll leave this ticket open for this particular issue.

comment:6 Changed 7 years ago by matthijs

On one occasion, it seems this bug (are at least the same symptom) occured for me when adding a firewall rule. I haven't been able to reproduce it on subsequent tries, though, so no clue if it's a real problem (when adding entries, the problem with deleting entries is identified).

comment:7 Changed 7 years ago by matthijs

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [1916]) luci: Fix event triggering when deleting values.

This removes a check for self.proceed, which seems to be a remnant of old code allowing the user to cancel pending changes (which was not working anyway). Removing this check makes sure that events are triggered when a value is removed from a list (e.g., when a port forward was removed).

Closes: #842

Add Comment

Modify Ticket

Action
as closed The owner will remain john.crispin@….
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.