Modify

Opened 9 years ago

Closed 6 years ago

Last modified 5 years ago

#849 closed bug (wontfix)

Error in DCHP whilst trying to register a Linksys router.

Reported by: Alex Milne <general@…> Owned by:
Priority: normal Milestone:
Component: other Version: Other
Severity: unknown
Cc: Hardware: unknown

Description (last modified by matthijs)

I have a linksys WRT54G Version 1.1 router MAC 00:06:25:FF:E5:04 which will not assign an IP address when I try to register the router. I have been in contact with customer care who reported: "I have forwarded your case to one of our firmware people Hopefully he will be in touch. Otherwise you can try to go on http://trac.fonosfera.org/fon-ng to get more support direct with the firmware developers."

I have tried reflashing the Linksys firmware, and the router works correctly. The linksys router correctly connects to my ADSL router (PPPoA.)

I can connect to the linksys router by RJ45, getting internet via the FON router and access to the FON Management console, but the linksys router will not allocate an IP address when I connect by wireless. I have tried with 2 wireless devices. I have tried talking to the router with Putty and attach a file with the router response to "nvram show".

I am not at home at present, but have connected the router permanently where I am so I can make changes if needed. Thanks in advance for looking at this matter.

Here is the setup, although I have changed where I thought it might make a difference:

The firmware I have downloaded from FON is called FONbasic-WRT54GL-0.6.6.bin. I have tried downloading another copy in case it was corrupted.

I still cannot link by wireless, although I can connect by ethernet to the management console and the internet.

Here are the settings on the FON router:

Ethernet/Wireless Physical Connections
IP address HW type Flags HW address Mask Devicechrome:
192.168.1.100 0x1 0x2 00:19:66:79:DB:4C * vlan1
192.168.1.1 0x1 0x2 00:30:54:42:15:5C * vlan1
192.168.10.115 0x1 0x2 00:13:77:04:36:2F * br0
Connections to the Router
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 1199 192.168.10.1:80 192.168.10.115:4784 ESTABLISHED
tcp 0 0 192.168.10.1:80 192.168.10.115:4782 TIME_WAIT
tcp 0 0 192.168.10.1:80 192.168.10.115:4783 TIME_WAIT
DHCP leases
MAC Address IP Address Name Expires in
00:13:77:04:36:2f 192.168.10.115 samsung 11h 52min 3sec
Wireless Status
eth2 IEEE 802.11-DS ESSID:"FON_AB12"
Mode:Master Frequency:2.462 GHz Access Point: 00:06:25:FF:E5:04
Tx-Power:19 dBm
RTS thr=2347 B Fragment thr=2346 B
Encryption key:off
WAN Configuration
Connection Type DHCP
System Settings
Host Name ABlinksys
boot_wait Enabled
Language English
IP Settings
IP Address 192.168.1.104
Netmask 255.255.255.0
LAN Configuration
IP Address 192.168.10.1
Netmask 255.255.255.0
Default Gateway
DNS Servers
208.67.222.222 Remove
208.67.220.220 Remove
Wireless Configuration
Wireless Interface Enabled
ESSID FON_AB12
Channel 11
Access Restriction
LAN Access Deny
WDS Connections
Automatic WDS Enabled
Host Names
IP Address Host Name
127.0.0.1 localhost Remove
OpenWrt Remove
Static IP addresses (for DHCP)
MAC Address IP Address 

Attachments (2)

putty01.log (10.1 KB) - added by Alex Milne <general@…> 9 years ago.
Fon router startup behaviour.txt (672 bytes) - added by Alex Milne <general@…> 9 years ago.
Startup with and without internet connectivity

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by Alex Milne <general@…>

Changed 9 years ago by Alex Milne <general@…>

Startup with and without internet connectivity

comment:1 Changed 9 years ago by matthijs

  • Component changed from fon-base-firmware to other
  • Description modified (diff)
  • Status changed from new to investigate

If I understand correctly, you have flashed a FON firmware version on your linksys router? Where exactly did you find and download this firmware?

comment:2 Changed 9 years ago by Alex Milne <general@…>

I downloaded from http://www.fon.com/en/download/popupSelectVersion choosing the Linksys G/GL for my V 1.1 linksys router. The version is FONbasic-WRT54GL-0.6.6.bin To try to get the router working, I have tried flashing with the latest (non - FON) Linksys firmware, the FONadvanced-0.6.0.bin, (from http://download.fon.com/beta/FONadvanced.bin) and am now back to the FONbasic-WRT54GL-0.6.6.bin, and have done this several times. The operation of the router is now somewhat different. I can connect by LAN to 192.168.10.1 only when the Linksys is not connected to the internet. A computer on the linksys LAN sees the internet, if present. I can connect by wireless now when the internet is present (usually 192.168.182.89 to MAC 00-06-25-FF-E5-04) whereas I could not before, but only to the "No network access" page. I still don't get a registration page. The 2 other MACs on the linksys seen from my ADSL router are the same but ending (instead of 04) in 02 and 03 (which never has a lease time more than 1 minute). I don't know if this is the expected operation or not. I hope I have clarified things as well as updating the router behaviour. Thanks and hope you can point me in the correct direction. Alex

comment:3 Changed 8 years ago by anonymous

This issue is still current - it seems the problem is that in the chillispot configuration file, there are wildcards (example *.verizon.net). The version running in the FONbasic build tries to resolve literally "*.verizon.net" and fails, meaning chilli does not start, hence the DHCP issue.

comment:4 Changed 8 years ago by LAngelesJen

Hey just becoming a member, glad to be here! I appear forward to partcipating and have go through a great deal so far, so hello! I've been involved in some other forums and have found this area to have substantially more desirable written content, so it tends to make sense to last but not least post! BTW where is the option to change the time zone for my account? It's kind of weird having the time like 5 hours off lol

comment:5 Changed 8 years ago by LAngelessun

Hey just becoming a member, glad to be here! I'm glad to be here as a final point, heading to post considering I've been studying a lengthy time. Sooo anyways, plenty about me, see you all around and hello yet again haha. BTW, what can I do to change the time zone for my account? It's kind of weird having the time like 5 hours off lol

comment:6 Changed 8 years ago by Rene <rene@…>

I have made an enhancement to the official firmware to accept errors in chilli.conf file sent by FON servers. You may try it if you want. Sorry, my website is in french but you will find FONBasic-0.6.7 firmware for linksys routers.

Link: http://rene.margar.fr/2011/02/firmware-fonbasic-0-6-7-pour-linksys-wrt54g/

comment:7 Changed 6 years ago by matthijs

  • Resolution set to wontfix
  • Status changed from investigate to closed

As part of the upcoming 2.3.7.0 firmware release, we're reviewing old open tickets to see if they are still relevant, which is why you get this response now.

I'm closing this ticket, since we don't really support the FONBasic firmware anymore. If anyone asks, I will point them to your site, though.

comment:8 Changed 5 years ago by Boli

Thanks ! You made it easy !I was trying to cncneot on one of my old laptop. When I search for the SSID, I did not find my network. I got the same message windows can not configure this wireless network First I called my Internet service provider, they transferred me to router manufacturer.They did not help me as my router was out of warranty.Finally I tried your Easy Guide and got cncneoted in few minutes.Few steps and booooom ! cncneoted !

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.