Modify

Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#852 closed bug (cannotreproduce)

WiFi is not disabled by hardware switch OFF

Reported by: mihaly.reg@… Owned by: john.crispin@…
Priority: normal Milestone:
Component: fon-wifi Version: 2.3.6.0 (Gari)
Severity: unknown
Cc: Hardware: 2.0n (FON2300)

Description

F2N is up and running, bridge mode, fw 2.3.6.0, wifi MyPlace? working. I set the hardware switch WiFi? to OFF, but wireless connection to Myplace is still possible. I don't want to reboot the router (just in case that this would be the solution).

Attachments (0)

Change History (7)

comment:1 Changed 9 years ago by matthijs

  • Status changed from new to investigate

The wifi switch works for me, without bridge mode. I'll have to test if it still works in bridge mode.

comment:2 Changed 9 years ago by matthijs

Giuseppeg just tested the switch with bridge mode enabled, it worked for him. So the problem does not seem to be bridge-specific.

Mihaly, does this problem still occur for you? Or did it perhaps get solved by a reboot?

comment:3 Changed 9 years ago by mihaly.reg@…

Tested again the following scenarios (fw 2.3.6.0, bridge):

  1. MyPlace? is configured and working. WiFi? client can connect and browse the internet. Set the WiFi? hardware switch on the back of F2N to Off. Connect again with wifi client and browse the internet, is working.
  2. HW wifi switch is Off, reboot the F2N. After the router is back, no MyPlace? signal. No Wifi connection possible.
  3. Move the switch to On. Scan wifi networks with the wifi device. No MyPlace? !

Conclusion: while the router is up and running, the hardware wifi switch has absolutely no effect. Only reboot puts the switch setting into action.

? I'm doinmg something wrong ? There is a "Reset/WPS" button near the On/Off? switch. Should I do something else then moving from On to Off ? Press the Reset/WPS ? Btw... I don't want to reset/reboot the router ! Other applications are running. I don't want to interrupt anything else, just disable WiFi? "on the fly" by the On/Off? switch.

comment:4 Changed 9 years ago by matthijs

Just flipping the switch should be sufficient, it worked for me and giuseppeg.

Could you pastebin a logread from shortly after flipping the switch?

comment:5 Changed 9 years ago by mihaly.reg

root@Fonera:~# logread -f Jul 30 12:19:33 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:19:36 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:19:38 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:19:40 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:19:40 Fonera user.crit fonstated: enqueue --> ConfigWifi? Jul 30 12:19:40 Fonera user.crit fonstated: enqueue --> ConfigFON Jul 30 12:19:40 Fonera user.crit fonstated: enqueue --> RestartChilli? Jul 30 12:19:40 Fonera user.crit fonstated: running event /etc/fonstated/ConfigWifi Jul 30 12:19:40 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:19:41 Fonera user.info kernel: br-lan: port 2(ra0) entering disabled state Jul 30 12:19:41 Fonera user.warn kernel: Terminate the task(RtmpCmdQTask) with pid(1039)! Jul 30 12:19:41 Fonera user.warn kernel: Terminate the task(RtmpWscTask?) with pid(1040)! Jul 30 12:19:41 Fonera local6.err chillispot[22933]: dhcp.c: 2260: 127 (Network is down) recv(fd=12, len=1534) failed Jul 30 12:19:41 Fonera local6.err chillispot[22933]: chilli.c: 3339: dhcp_decaps() failed! Jul 30 12:19:41 Fonera local6.err chillispot[22933]: dhcp.c: 2471: 127 (Network is down) recv(fd=13, len=42) failed Jul 30 12:19:41 Fonera local6.err chillispot[22933]: chilli.c: 3344: dhcp_arpind() failed! Jul 30 12:19:41 Fonera user.warn kernel: RX DESC a0541000 size = 2048 Jul 30 12:19:41 Fonera user.warn kernel: <-- RTMPAllocTxRxRingMemory, Status=0 Jul 30 12:19:41 Fonera user.warn kernel: Key1Str is Invalid key length(0) or Type(0) Jul 30 12:19:41 Fonera user.warn kernel: Key1Str is Invalid key length(0) or Type(0) Jul 30 12:19:41 Fonera user.warn kernel: Key2Str is Invalid key length(0) or Type(0) Jul 30 12:19:41 Fonera user.warn kernel: Key2Str is Invalid key length(0) or Type(0) Jul 30 12:19:41 Fonera user.warn kernel: Key3Str is Invalid key length(0) or Type(0) Jul 30 12:19:41 Fonera user.warn kernel: Key3Str is Invalid key length(0) or Type(0) Jul 30 12:19:41 Fonera user.warn kernel: Key4Str is Invalid key length(0) or Type(0) Jul 30 12:19:41 Fonera user.warn kernel: Key4Str is Invalid key length(0) or Type(0) Jul 30 12:19:41 Fonera user.warn kernel: 1. Phy Mode = 4 Jul 30 12:19:41 Fonera user.warn kernel: 2. Phy Mode = 4 Jul 30 12:19:41 Fonera user.warn kernel: 3. Phy Mode = 4 Jul 30 12:19:41 Fonera user.warn kernel: RTMPSetPhyMode: channel is out of range, use first channel=0 Jul 30 12:19:41 Fonera user.warn kernel: MCS Set = 00 00 00 00 00 Jul 30 12:19:41 Fonera user.warn kernel: SYNC - BBP R4 to 20MHz.l Jul 30 12:19:41 Fonera user.warn kernel: Main bssid = 00:18:84:88:22:84 Jul 30 12:19:41 Fonera user.warn kernel: <==== rt28xx_init, Status=0 Jul 30 12:19:41 Fonera user.warn kernel: 0x1300 = 00064300 Jul 30 12:19:41 Fonera user.info kernel: br-lan: port 2(ra0) entering learning state Jul 30 12:19:41 Fonera user.info kernel: br-lan: topology change detected, propagating Jul 30 12:19:41 Fonera user.info kernel: br-lan: port 2(ra0) entering forwarding state Jul 30 12:19:43 Fonera user.info kernel: device ra0 left promiscuous mode Jul 30 12:19:43 Fonera user.info kernel: br-lan: port 2(ra0) entering disabled state Jul 30 12:19:43 Fonera user.info kernel: device ra0 entered promiscuous mode Jul 30 12:19:43 Fonera user.info kernel: br-lan: port 2(ra0) entering learning state Jul 30 12:19:43 Fonera user.info kernel: br-lan: topology change detected, propagating Jul 30 12:19:43 Fonera user.info kernel: br-lan: port 2(ra0) entering forwarding state Jul 30 12:19:43 Fonera user.notice root: runnow --> /etc/fonstated/RestartChilli Jul 30 12:19:44 Fonera user.crit fonstated: finished running /etc/fonstated/ConfigWifi Jul 30 12:19:44 Fonera user.crit fonstated: running event /etc/fonstated/ConfigFON Jul 30 12:19:45 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:19:46 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:19:47 Fonera user.crit fonstated: finished running /etc/fonstated/ConfigFON Jul 30 12:19:47 Fonera user.crit fonstated: running event /etc/fonstated/RestartChilli Jul 30 12:19:47 Fonera user.crit fonstated: finished running /etc/fonstated/RestartChilli Jul 30 12:19:47 Fonera user.crit fonstated: enqueue --> hotspot_wdt_stop Jul 30 12:19:47 Fonera user.crit fonstated: running fast event hotspot_wdt_stop Jul 30 12:19:47 Fonera user.crit fonstated: stopping chilli wdt Jul 30 12:19:47 Fonera user.crit fonstated: enqueue --> hotspot_wdt_start Jul 30 12:19:47 Fonera user.crit fonstated: running fast event hotspot_wdt_start Jul 30 12:19:47 Fonera user.crit fonstated: starting chilli wdt Jul 30 12:19:47 Fonera user.crit fonstated: enqueue --> StartFonsmcd? Jul 30 12:19:47 Fonera user.crit fonstated: enqueue --> hotspot_wdt_stop Jul 30 12:19:47 Fonera user.crit fonstated: running fast event hotspot_wdt_stop Jul 30 12:19:47 Fonera user.crit fonstated: stopping chilli wdt Jul 30 12:19:47 Fonera user.crit fonstated: enqueue --> hotspot_wdt_start Jul 30 12:19:47 Fonera user.crit fonstated: running fast event hotspot_wdt_start Jul 30 12:19:47 Fonera user.crit fonstated: starting chilli wdt Jul 30 12:19:47 Fonera user.crit fonstated: running event /etc/fonstated/StartFonsmcd Jul 30 12:19:48 Fonera user.crit fonstated: finished running /etc/fonstated/StartFonsmcd Jul 30 12:19:50 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:19:51 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:19:52 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:19:55 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:01 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:02 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:05 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:17 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:18 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:26 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:29 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:30 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:30 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:30 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:33 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:34 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:37 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:38 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:39 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:47 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:48 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:48 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:48 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:49 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:49 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:50 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:20:50 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:01 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:04 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:08 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:08 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:10 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:11 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:12 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:13 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:15 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:15 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:15 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:23 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:25 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:26 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:27 Fonera user.warn kernel: AP SETKEYS DONE - WPA1, AuthMode?(4)=WPAPSK, WepStatus?(4)=TKIP, GroupWepStatus?(4)= TKIP Jul 30 12:21:27 Fonera user.warn kernel: Jul 30 12:21:33 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:40 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:40 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:43 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 Jul 30 12:21:44 Fonera user.warn kernel: DWC_OTG_HC_XFER_FRAME_OVERRUN: 8 root@Fonera:~#

comment:6 Changed 6 years ago by matthijs

  • Resolution set to test_in_newer_version
  • Status changed from investigate to closed

As part of the upcoming 2.3.7.0 firmware release, we're reviewing old open tickets to see if they are still relevant, which is why you get this response now.

Looking at the log, I see the ConfigWifi?, ConfigFON, RestartChilli? events, which are (likely) triggered by /etc/fonstated/GpioSwitch, meaning the switch change did get processed correctly.

Perhaps something in the newest firmware fixed this (I still cannot reproduce the problem here).

If this issue still occurs with the 2.3.7.0 rc2 firmware, feel free to leave a comment here so we can further investigate.

comment:7 Changed 6 years ago by matthijs

  • Resolution changed from test_in_newer_version to cannotreproduce

Add Comment

Modify Ticket

Action
as closed The owner will remain john.crispin@….
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.