Modify

Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#874 closed bug (fixed)

Public wifi signal flips on and off, related to radconfig errors

Reported by: matthijs Owned by: john.crispin@…
Priority: normal Milestone: Firmware 2.3.7.0
Component: fon-wifi Version: 2.3.6.0 (Gari)
Severity: unknown
Cc: ddomee@…, josemi@…, batiatto@… Hardware: 2.0n (FON2300)

Description

There seems to be an issue that has been surfacing recently where the public wifi signal keeps switching off and on all the time.

Note that this is a different issue from #669, where onlined marks the Fonera as offline, which causes the orange page to appear and also brings down the public wifi signal.

This issue does not make the orange page appear. You can recognize it because of the following message in the logread output:

Jul 21 16:47:29 Fonera user.alert fonstated: redirector returned invalid data
Jul 21 16:47:29 Fonera user.crit fonstated: enqueue --> RestartChilli
Jul 21 16:47:29 Fonera user.crit fonstated: running event /etc/fonstated/RestartChilli
Jul 21 16:47:45 Fonera user.err syslog: main-radconfig.c: 34: Radius request timed out
Jul 21 16:48:29 Fonera local6.info chillispot[8884]: tun.c: 664: 2 (No such file or directory) TX queue length set to 100
Jul 21 16:48:29 Fonera user.crit fonstated: finished running /etc/fonstated/RestartChilli           

Some further investigation shows that the chillispot redirector somehow redirects users to fon.com/cp/something instead of fon.com/login/gateway, as it should. It seems likely that there is some kind of communication problem with the radius server, which prevents radconfig from getting the proper chillispot configuration. The default /etc/chilli.conf contains the fon.com/cp... url.

Attachments (1)

fonera_batiatto_logread.txt (22.7 KB) - added by batiatto@… 7 years ago.
Log file

Download all attachments as: .zip

Change History (10)

comment:1 Changed 7 years ago by ddomee@…

So do I have this problem!!! In fact I think that my new fonera 2.0N is defective

comment:2 Changed 7 years ago by Josemi <josemi@…>

I also have this problem.

comment:3 Changed 7 years ago by matthijs

  • Status changed from new to confirmed

Further investigation shows that this issue is caused by a specific internet connection, not a specific Fonera (though once a Fonera has been used on a "good" connection, the errors become less obvious on a "bad" connection as well).

tcpdumping shows that the Radconfig replies really don't end up at the Fonera, so they get lost somewhere on the internet connection or at the NAT gateway.

Using a "good" Fonera on a "bad" connection, one can actually connect and login to the public signal. This would mean that there is indeed a radius exchange over the "bad" connection, so it's not that the NAT gateway is breaking all UDP / radius traffic (but this still needs to be verified by tcpdumping).

Considering that the radconfig reply packet is fairly big (IP packet is 1496 bytes), this might be an issue with packet size / MTU. If so, we might need to find a way to reduce the packet size of the reply by a few bytes...

Changed 7 years ago by batiatto@…

Log file

comment:4 Changed 7 years ago by batiatto@…

I do have the same issue. I have attached my logread output.

cheers.

comment:5 Changed 7 years ago by matthijs

  • Cc ddomee@… josemi@… batiatto@… added

We've disabled path MTU discovery on our Radius servers, which seems to make things work again (at least for the ADSL line in the Fon office in Madrid).

Please check if this issue is resolved for you and please report back here with the results (whether it worked or not). There should be no changes required to the Fonera or the firmware.

Also, registration should be working again now (at least with 2.3.6.1). If your Fonera is still unregistered, please also check if you can register now.

comment:6 Changed 7 years ago by matthijs

One more note: You might need to reboot the Fonera to force a radconfig reload before it works.

comment:7 Changed 7 years ago by batiatto@…

Hi guys,

this problem seems to be fixed for me now, the public SSID keeps up and is stable now. however i have another issue now, which is the follwoing.

  1. I connect to the public SSID
  2. I logon entering my fon username and password
  3. I can navigate through google
  4. I can't browse any other web page

I tried this from a Linux client (Ubuntu 10.4) and an iPhone 4.

any idea?

ps. may be this is related to another ticket, haven't check that out. So #874 seems to be fixed despite of this new issue I am experiencing,

comment:8 Changed 7 years ago by matthijs

Could you create a new ticket for this other issue? Thanks.

comment:9 Changed 7 years ago by matthijs

  • Resolution set to fixed
  • Status changed from confirmed to closed

On November 22nd 2010, the chillispot configuration (as retrieved by radconfig) has been reviewed to remove a lot of whitelisted addresses and domains. This should make the radconfig packets involved in this bug a lot smaller, preventing any fragmenting and MTU problems altogether.

I'm closing this report. If you're still having issues or see your public wifi signal flipping on and off like described in this report, feel free to leave a comment and I can reopen the ticket.

Add Comment

Modify Ticket

Action
as closed The owner will remain john.crispin@….
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.