Modify

Opened 7 years ago

Closed 7 years ago

Last modified 4 years ago

#894 closed bug (fixed)

2.3.6.1 shows lua error in the wizard

Reported by: matthijs Owned by:
Priority: high Milestone: Firmware 2.3.7.0
Component: fon-base-firmware Version: 2.3.6.1 (Gari jr.)
Severity: trivial
Cc: giuseppeg88@… Hardware: 2.0n (FON2300)

Description

When using 2.3.6.1 on a clean Fonera (e.g., after a factory reset), the welcome wizard errors out with the following message (or something similar):

Error in template wizard_fonera2/register: ?:0: attempt to index field 'spot' (a nil value)
stack traceback:
	[C]: in function '?'
	?: in function <?:223>
	(tail call): ?
	?: in function <?:660>
	?: in function 'dispatch'
	?: in function <?:132>

This happens when it tries to build a registration url, at:

  • Step 3 (after setting the password) when the Fonera has no internet connection.
  • Step 8 (after setting the megaupload password) when the Fonera is connected to the internet.

If this happens to you, don't panic! This only happens in the last step of the wizard, so you've only missed out on the registration of your Fonera, and there is a button available for that on the dashboard afterwards.

However, due to this error, the Fonera won't register that you've finished the wizard already. So if you get this error, navigate back to the main page (http://fonera). You'll get the wizard again, but just click "abort wizard" and you're done!

And now, for the technical stuff. The cause of this issue is that in the wizard, the luci.fon.spot lua module isn't included before calling luci.fon.reg.geturl(), while geturl assumes the module is included. This was not a problem with the registration url in the dashboard, since the systray.htm requires the luci.fon.spot before calling get_url.

This bug was caused by r1689 / r1691, so it only occurs in 2.3.6.1, 2.3.6.0 is not affected.

Attachments (0)

Change History (3)

comment:1 Changed 7 years ago by matthijs

  • Cc giuseppeg88@… added
  • Status changed from new to confirmed

Btw, this bug was reported by Giueseppe on IRC last night.

comment:2 Changed 7 years ago by matthijs

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [1735]) Require luci.fon.spot in luci.fon.reg.getmac().

When geturl() (and thus getmac()) are used from the wizard, luci.fon.spot is not included yet. When it is used from the dashboar, luci.fon.spot is not included yet. When it is used from the dashboar, luci.fon.spot is not included yet. When it is used from the dashboar, luci.fon.spot is not included yet. This change ensures it is always included and thus also works from the wizard.

Closes #894

comment:3 Changed 6 years ago by matthijs

(In [1946]) Backport r1735: Require luci.fon.spot in luci.fon.reg.getmac().

When geturl() (and thus getmac()) are used from the wizard, luci.fon.spot is not included yet. When it is used from the dashboard, luci.fon.spot is not included yet. This change ensures it is always included and thus also works from the wizard.

References: #894

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.