Modify

Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#898 closed bug (fixed)

Orange page behavior is still incorrect

Reported by: Salim Fadhley <sal@…> Owned by:
Priority: normal Milestone: Firmware 2.3.7.0
Component: fon-network Version: 2.3.6.1 (Gari jr.)
Severity: unknown
Cc: Hardware: 2.0n (FON2300)

Description

Continuation of #669

I still get occasional yellow-screens with 2.3.6.1 - this problem is far from fixed.

  • On one occasion it was because the ADSL modem required a reset. Unfortunately the yellow-screen prevents me connecting to the modem to reset the device.
  • On another occasion it was because two computers were doing a big apt-get upgrade. That was enough data-flow to cause three consecutive packet losses. The yellow screen caused a disruption to everybody else using the network.

I'd strongly suggest that:

  • The yellow-screen on the Private AP should be optional (i.e. easy to disable)... or
  • Ditch the yellow-screen entirely. It's far more trouble than good because it even if there is an Internet fault it does not offer particularly helpful advice. Often the fault will not be in the fonera but some kind of upstream device.
  • Finally, if we keep the yellow screen make it more diagnostically useful. For example, include a simple wiring diagram. You could even show a warning if the WAN port is disconnected.

Attachments (0)

Change History (10)

comment:1 Changed 9 years ago by Salim Fadhley <sal@…>

Ticket raised by me!

comment:2 Changed 9 years ago by matthijs

  • Component changed from fon-base-firmware to fon-network
  • Milestone set to Firmware 2.3.7.0
  • Reporter changed from anonymous to Salim Fadhley <sal@…>
  • Status changed from new to confirmed
  • Summary changed from Yellow-screen behavior is still incorrect to Orange page behavior is still incorrect

Hey Salim,

I did sort of expect this to happen, the 2.3.6.1 fix was mostly getting the major problems out of the way. We are considering removing the orange page altogether, as you also suggest. There will still be a heartbeat thing that checks the connection and brings down the public wifi signal when the connection is broken, to not raise expectations when there really isn't any connection.

I'll see if we can get this removal sped up a little.

comment:3 Changed 9 years ago by koter84@…

when i see the frequency of this error, while there is no problem with the internet connection.. i think that the internet should be down for at least 5 minutes before the orange page shows up, and the public wifi is disconnected.

maybe the check could be extended to more than just 1 dns-name, so that when google fails, another big site (like wikipedia or fon) is checked.. and to rule out dns problems do a direct IP test as well.

I also second that it is difficult (even impossible) to connect to the device in on the WAN side of the fonera, so that when there is a problem you can't fix it unless you rewire all the devices and connect your computer or laptop directly to the WAN-device.. I still vote for complete removal of the page (at least in the DEV-version!!!)

comment:4 Changed 8 years ago by anonymous

Does onlined do anything apart from checking if the connection is still there? If not, it shouldn't hurt if I just kill the process, right?

comment:5 Changed 8 years ago by matthijs

Onlined doesn't do anything else, so killing it shouldn't hurt (though I'm not sure if something will restart it automatically, you would have to try).

comment:6 Changed 8 years ago by admiral0

onlined isn't restarted, so you can kill it when you want

comment:7 Changed 8 years ago by anonymous

is there any way to manually (per ssh) clear the list of 'misconfigured internet'-sites? the list seems to survive a router reboot, so i assume it's in a file somewhere.

comment:8 Changed 8 years ago by matthijs

This "list", is the DNS cache on your client (possibly in the browser). Restarting the browser might work, restarting your PC should definately work. Note that clients are known to cache these results for some time, even when the Fonera tells them to only remember them for 1 second (by setting the DNS TTL to 1). So there's really nothing we can do from the Fonera to fix that.

In other news, it's likely that we'll remove the orange screen from 2.3.7.0 after all. I've done some preliminary testing and it seems doable to just remove it. onlined will stay, though, so the hotspot and some parts of the webgui (application installs from the internet) will still be disabled when onlined detects an offline state. However, the Orange screen redirect will be removed. In a later release, we will probably move the detection of online/offline status into fonsmcd, the daemon that talks to Fon's heartbeat servers. This should make it more reliable.

comment:9 Changed 8 years ago by anonymous

you're right. i cleared my windows dns cache and disabled the firefox internal cache. now at least my internet is usable again!! thanks =D

comment:10 Changed 8 years ago by matthijs

  • Resolution set to fixed
  • Status changed from confirmed to closed

(In [1905]) fonbase: No longer redirect all traffic when the Fonera is offline.

This effectively removes the "orange screen", which has caused more problems than solved them recently. The problem is that onlined seems to trigger into the "offline" state every now and then without reason. This prevents people from using their internet connection (they get redirected to the orange screen) even when their connection is normally working. Non-compliant DNS caches in browsers worsen this effect, even if the state switches back to online directly after.

This commit removes the redirect to the orange screen. However, onlined still runs as before and shuts down the public wifi signal and the ntp client when the internet connection is down. Also, the leds still indicate the online status, which is useful for user feedback.

Closes: #898

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.