Modify

Opened 9 years ago

Closed 7 years ago

Last modified 5 years ago

#909 closed enhancement (wontfix)

OpenVPN should be able to run as TCP, or UDP or Both

Reported by: JonTheNiceGuy <jon@…> Owned by:
Priority: normal Milestone:
Component: fon-plugin-openvpn Version: 2.3.6.1 (Gari jr.)
Severity: normal
Cc: ramirez.javier@… Hardware: both

Description

By amending the following files, OpenVPN could run in TCP-Server mode, UDP mode or run both.

/etc/config/openvpn

#     option 'proto' 'udp'
#     option 'dev' 'tun-ovpn'
#     option 'server' '10.8.0.0 255.255.255.0'

/etc/init.d/openvpn - note there's no logic to this currently - This just arbitrarily starts both up. Some logic might be a good idea :)

// Search for the line: eval "$SSD -q -b -p '$PID' ... etc
// Replace it with the following:
                ARGS_U="$ARGS --dev tun-ovpn-u --server 10.8.0.0 255.255.255.128 --proto udp"
                ARGS_T="$ARGS --dev tun-ovpn-t --server 10.8.0.128 255.255.255.128 --proto tcp"
                eval "$SSD -q -b -p '$PID' -x $BIN -S -- --syslog 'openvpn-u($s)' --writepid '$PID' $ARGS_U"
                eval "$SSD -q -b -p '$PID' -x $BIN -S -- --syslog 'openvpn-t($s)' --writepid '$PID' $ARGS_T"

Attachments (0)

Change History (6)

comment:1 Changed 9 years ago by matthijs

  • Hardware changed from 2.0n (FON2300) to both
  • Milestone set to Firmware 2.3
  • Severity changed from unknown to normal
  • Status changed from new to confirmed

comment:2 Changed 9 years ago by matthijs

  • Cc ramirez.javier@… added

#960 is a duplicate of this ticket.

comment:3 Changed 7 years ago by Jon "The Nice Guy" Spriggs <jon@…>

Patch to cover selecting between TCP and UDP attached to #1188. I can't see any way to do both TCP and UDP, not without hacking at the /etc/init.d/openvpn file more than I'm comfortable with.

comment:4 Changed 7 years ago by matthijs

  • Resolution set to wontfix
  • Status changed from confirmed to closed

Since #1188 covers switching between TCP and UDP, this leaves only running both for this ticket. Since implementing that probably becomes messy, we'll just leave it with selecting either TCP or UDP.

comment:5 Changed 7 years ago by matthijs

  • Milestone Firmware 2.3 deleted

comment:6 Changed 5 years ago by Michael

I've installed and the wpm mdolue of openvpn to work with webmin. This was the easy part. Creating the ca, crt and pem keys was easy. However, I've ran into one problem after another after trying to configure the vpn for either tun or tap. I couldn't get tap to configure at all. However, inspite of the problems I'm having, I like the webmin interface, as it certainly saves a lot of typing. Also, through it, I can visually see what's required of setting up a vpn. http://eemhiecna.com [url=http://xgtvbjtnyuh.com]xgtvbjtnyuh[/url] [link=http://blfaievy.com]blfaievy[/link]

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.