Modify

Opened 9 years ago

Closed 6 years ago

#943 closed enhancement (fixed)

auto-build of new development versions

Reported by: koter84@… Owned by:
Priority: normal Milestone:
Component: other Version: N/A
Severity: unknown
Cc: josemi@…, calvinturbo@… Hardware: both

Description

could you auto-build nightly-images?

or maybe use the opkg system to get out software updates to development versions of the fon software...

this way fixes can get tested quicker, and the problem won't "return" when a new release goes online...

Attachments (0)

Change History (7)

comment:1 Changed 9 years ago by Josemi <josemi@…>

Very interesting. Can anyone add me as cc so I can keep updated?, please.

comment:2 Changed 9 years ago by matthijs

  • Cc josemi@… added
  • Status changed from new to confirmed

Good idea! In fact, we've even been trying to get this set up already. There is an image builder, which should do regular builds already. The next step is getting those images published somewhere. There's a few strings the need to be pulled to get this done, but it's definately in the pipeline :-)

comment:3 Changed 9 years ago by koter84@…

good to hear that you're already working on this :D (sorta)

i would definitely slap a nightly build on there every time i would upgrade my firmware (unless the nightly's are really bad) since it seems that the software doesnt really break in between versions..

still i'd prefer to use the opkg system for minor updates... the 2.3.6.1 release wouldn't have been necessary to release, it could have just been 3 packages being updates in the repository...

comment:4 Changed 9 years ago by matthijs

Yeah, the committed versions should usually be pretty ok. Right now, I usually commit a change to a local git mirror and let it linger around a bit for testing before pushing it out to the svn repository.

Regarding the use of opkg for updates, right now opkg isn't well integrated with the Fonera firmware. There is the option of installing "hotfixes", which are special .tar.gz tarballs similar to applications that can be installed without completely reflashing the device. I haven't investigated those for the 2.3.6.1 release, though.

We might have another look at all this in the future, though I think the first step would be to just generate nightly complete firmware images.

comment:5 Changed 9 years ago by calvinturbo@…

Can you add me as cc too?

comment:6 Changed 9 years ago by matthijs

  • Cc calvinturbo@… added

comment:7 Changed 6 years ago by matthijs

  • Resolution set to fixed
  • Status changed from confirmed to closed

w00ps, forgot to update this ticket. Autobuilds of SVN versions have been available for a while now, see http://blog.fonosfera.org/automated-firmware-builds-from-subversion-available/

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.