Modify

Opened 9 years ago

Closed 6 years ago

Last modified 5 years ago

#946 closed request (duplicate)

H3G ITALY MODEM HUAWEI E122 RECOGNISED BUT HANGS

Reported by: jon@… Owned by:
Priority: normal Milestone:
Component: fon-network-3g Version: 2.3.6.1 (Gari jr.)
Severity: unknown
Cc: Hardware: 2.0n (FON2300)

Description

H3G ITALY MODEM HUAWEI E122 RECOGNISED BUT HANGS WITHOUT DIALLING IN

I have a problem attempting to dial in to H3G in Italy with post-paid data subscription.

The modem is recognised and receives a UMTS signal (LED switches from green to blue), but hangs when it attempts to connect (Fonera message remains "UMTS is dialing in").

I have installed the latest dev version (http://download.fonosfera.org/LATEST/fonera2.0n-FON2300/20100824_FON2303_2.3.6.1_r1730_DEV.tgz) and modified the umstd file as follows:

etc/config/umstd

config 'umtsd' 'umtsd'

option 'pin' '2340'
option '_country' 'it'
option '_provider' 'it_5'
option 'apn' 'datacard.tre.it'
option 'dns' '62.13.171.2'

config 'umtsdstate' 'umtsdstate'

config 'umtsdevice' 'option12D11001'

option 'vendor' 'Huawei'
option 'device' 'E122'
option 'data' '/dev/ttyUSB0'
option 'cmd' '/dev/ttyUSB0'

cat /var/state/umtsd

umtsd.umtsdstate.vendor=

umtsd.umtsdstate.model=

umtsd.umtsdstate.provider=

umtsd.umtsdstate.signal=

umtsd.umtsdstate.state=INIT

umtsd.umtsdstate.tx=0

umtsd.umtsdstate.rx=0

umtsd.umtsdstate.online=1282582642

umtsd.umtsd.attached=1

cat /proc/bus/usb/devices

T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=480 MxCh?= 1

B: Alloc= 0/800 us ( 0%), #Int= 1, #Iso= 0

D: Ver= 2.00 Cls=09(hub ) Sub=00 Prot=01 MxPS=64 #Cfgs= 1

P: Vendor=0000 ProdID=0000 Rev= 2.06

S: Manufacturer=Linux 2.6.21 dwc_otg_hcd

S: Product=DWC OTG Controller

S: SerialNumber?=lm0

C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr?= 0mA

I:* If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub

E: Ad=81(I) Atr=03(Int.) MxPS= 4 Ivl=256ms

T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 3 Spd=480 MxCh?= 0

D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1

P: Vendor=12d1 ProdID=1001 Rev= 0.00

S: Manufacturer=HUA WEI

S: Product=Huawei Mobile

C:* #Ifs= 5 Cfg#= 1 Atr=80 MxPwr?=500mA

I:* If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option

E: Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms

E: Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=31875us

E: Ad=8a(I) Atr=03(Int.) MxPS= 16 Ivl=64ms

I:* If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option

E: Ad=85(I) Atr=02(Bulk) MxPS= 256 Ivl=0ms

E: Ad=05(O) Atr=02(Bulk) MxPS= 256 Ivl=31875us

I:* If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option

E: Ad=86(I) Atr=02(Bulk) MxPS= 256 Ivl=0ms

E: Ad=06(O) Atr=02(Bulk) MxPS= 256 Ivl=31875us

I:* If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

E: Ad=83(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms

E: Ad=03(O) Atr=02(Bulk) MxPS= 512 Ivl=31875us

I:* If#= 4 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

E: Ad=82(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms

E: Ad=02(O) Atr=02(Bulk) MxPS= 512 Ivl=31875us

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by matthijs

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #906.

comment:2 Changed 5 years ago by Chaas

Umm, are you really just giving this info out for nontghi?

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.