Modify

Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#956 closed bug (test_in_newer_version)

Transmission dies if 2 partitions used for torrents

Reported by: mihaly.reg@… Owned by:
Priority: normal Milestone:
Component: fon-base-firmware Version: 2.3.6.1 (Gari jr.)
Severity: unknown
Cc: Hardware: 2.0n (FON2300)

Description

Transmission 2.11 installed on F2N 2.3.6.1 (valleri version, see forum.fon.com/forum). Default torrent dir is /tmp/mounts/Disc-A1/torrent, with many torrents in the default directory. Some of them I move to /../Disc-A2/torrent1 (with help of external GUI program, like Tr Remote Dotnet) After files are moved apparently it's working, but after some time Transmission dies. In F2N webUI the list is empty, at the bottom the settings dissapeared, no access with external WebUI program. Reboot F2N does not help, Tr. is dead forever, I had to reinstall it from scratch. P.S.: Disc-A1 and Disc-A2 is the same HD, multipartitioned. A1 is 700GB, A2 is 500GB, A3 is 300GB, total 1.5TB. Filesystem is EXT. (not sure which ext...formatted a log time ago on another PC)

Attachments (0)

Change History (9)

comment:1 Changed 9 years ago by mihaly.reg@…

The root cause of this error seems to be: -tr started and using data from Disc-A1 and Disc-A2, but files from Disc-A2 are not used for a while (e.g. no peers for the torrents), -disc-A2 is ummounted by linux because it's idle -peers shows up for torrents located on discA2

error! Transmission tries to seed the torrents but cannot find the files and cannot mount the drive A2 ! >> crash !

This unmount issue explains also other errors of transmisson, like 'location' errors, etc..

comment:2 Changed 9 years ago by matthijs

  • Milestone set to Firmware 2.3
  • Status changed from new to investigate

Ah, thanks for the analysis. We'll have a closer look at fixing this later. This would probably involve patching transmission to keep a file or a directory open on all discs it is using or something.

comment:3 Changed 9 years ago by mihaly.reg@…

Matthijs, do you think is a good ideea to path transmission? I think not, because on F2N we can install private releases also...fon was never up to date with the latest fixes. Wouldn't be much easier to place a checkbox in webui near each 'disc' with parameter 'Never unmount' ? This could be implemented in the next 2.3.7.0 and will not depend on any further transmission release! Thanks!

comment:4 Changed 9 years ago by matthijs

Patching transmission shouldn't be a problem. In fact, the current version of the transmission plugin already has a few patches applied. The patches will be public, so anyone doing a private build can just include the patches as well (I think Paolo, who has been making updated builds before also just uses our build system and patches).

As for having a "never unmount" checkbox, that's really just a workaround. I want this to work out of the box for people, tranmission really shouldn't crash because the user forgot to tick a checkbox. I also want to wrap up the changes for 2.3.7.0, so I'll probably leave this issue for now.

comment:5 Changed 9 years ago by mihaly.reg@…

Sorry i disagree with your arguments:

  • what about Motion installed on A1 and saving pics on A2 after sda2 unmounted (didn't tested...but..what if?)
  • what about webdav or whatever plugin that will follow, installed on A1 and using the unmounted A2?
  • what if Paolo forgets the patch
  • what if I keep my files on A2 and want them instantly not after a refresh (because right after ftp login they don't work)
  • whatever strange scenario you can imagine...

Yes, I agree, the 'never unmount' checkboxes are a workaround, but... a very good one !

  • and finally: anybody wants to patch trasmission for this bug? Then let him do it, but leave also the 'checkbox' option as a 'backup' for whatever imaginable or unimaginable reason.

Sorry for the long post, I'm just annoyed that I'm fighting with F2n bugs for 1 year now...and finally I found the cause...it would be nice a solutiona also...not other delays... Thanks for understanting! Keep up the good work!

comment:6 Changed 9 years ago by charles@…

There's an upstream ticket that I'll leave open for now, but I'm not sure whether or not it's an upstream issue -- I can't trigger the same bug on a Linux laptop when removing an external hard drive. Apples and oranges, maybe.

Anyway... if you are able to reproduce this issue and get a backtrace for it, and if it seems to be belong upstream, just give me a yell.

comment:7 Changed 6 years ago by matthijs

  • Milestone Firmware 2.3 deleted
  • Resolution set to test_in_newer_version
  • Status changed from investigate to closed

Could you see if this is still a problem on 2.3.7.0 rc2? There have been some fixes in mountd, which might have helped here.

comment:8 Changed 6 years ago by mihaly.reg@…

Unfortunatelly I cannot test this on rc2 because now I'm using only one partition, exactly for the reason described in this ticket. I have a 1TB disc that is full so I can't even repartition it on the fly, it would be needed to delete all files for a fresh partitioning. No idea how to test it, sorry. Maybe when I will buy my next TB disc :-)

comment:9 Changed 6 years ago by matthijs

Ok, no problem, I'll see if I can test this myself at some point (might be post-2.3.7.0, though).

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.