Modify

Opened 9 years ago

Closed 7 years ago

#967 closed bug (moreinfoneeded)

OpenVPN in Bridge mode not working

Reported by: cstephane@… Owned by:
Priority: normal Milestone:
Component: fon-plugin-openvpn Version: 2.3.6.1 (Gari jr.)
Severity: unknown
Cc: kontakt@… Hardware: 2.0n (FON2300)

Description

The generation of the 'ovpn_config.zip' shouldn't be different weather or not La Fonera is in Router mode / Bridge mode...?

Attachments (0)

Change History (10)

comment:1 Changed 9 years ago by matthijs

I'm not sure what you're saying: Is the config different in bridge mode, or do you think it should be? What problems are you seeing in bridge mode?

comment:2 Changed 9 years ago by matthijs

  • Status changed from new to infoneeded

comment:3 Changed 9 years ago by cstephane@…

OpenVPN is Working fine in Router mode... But in Bridge mode, no result at all !

Its seems that the 'ovpn_config.zip' have to be rewritten with a new setup (new route).

comment:4 Changed 9 years ago by matthijs

You mean that the OpenVPN connection from the client fails alltogether? Or does it work, but not allow you to connect to the Fonera (on 192.168.10.1). I think I found a bug that should cause the latter...

comment:5 Changed 9 years ago by anonymous

I can't establish any OpenVPN connection from the client to the Fonera 2N 2.3.6.1 in Bridge mode. (It is working fine in Router mode)

comment:6 Changed 9 years ago by cstephane@…

I can't establish any OpenVPN connection from the client to the Fonera 2N 2.3.6.1 in Bridge mode. (It is working fine in Router mode)

comment:7 Changed 9 years ago by matthijs

Hmm, it did work for me in bridge mode (at least the connection was established, the routes were wrong). Are you sure that it's not another problem related to the static address you configure in bridge mode? Perhaps you set up the wrong netmask or gateway, or perhaps you changed the address and forgot to update a port forwarding on your modem?

comment:8 Changed 8 years ago by kontakt@…

Hello,

I think I have the same problem here.

Fonera2n with 2.3.6.1 and Internet configured as Bridge.

My Problem with the openvpn is that the connection is established, but no packets come trough - I guess wrong routes.

I would be glad to get further advice :)

Benjamin

comment:9 Changed 8 years ago by matthijs

  • Cc kontakt@… added

kontakt, your problem seems to be a different one: You can connect the OpenVPN network, but not packets are sent through it, while cstephane cannot connect entirely. The bug kontakt is describing has been fixed in SVN (r1847), see #1036 for the ticket and a workaround.

The bug described by cstephane is still waiting for his answers, since I have not been able to reproduce the problem yet.

comment:10 Changed 7 years ago by matthijs

  • Resolution set to moreinfoneeded
  • Status changed from infoneeded to closed

Add Comment

Modify Ticket

Action
as closed The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.