Modify

Opened 8 years ago

Last modified 6 years ago

#989 investigate enhancement

Support 3G dongle: Nokia CS-17

Reported by: fzs_@… Owned by:
Priority: normal Milestone:
Component: fon-network-3g Version: N/A
Severity: unknown
Cc: fzs_@… Hardware: both

Description

Hi, this is a long one. I've had a couple of Fonera 2.0n:s for about a year or so and finally thought of contacting you guys. Been struggling for the whole time to get an UMTS device working.

The support for the Nokia CS-17 Internet Stick, Huawei E1820 and Huawei E169 would be -very, very- much apprecciated, in this order of importance. As long as you haven't had a CS-17 in a linux machine before, it even comes with it's own variety of Linux drivers. Maybe they would be of help?

I made the mistake of installing the "nokiainternetmodem.deb" package so can't find any way to get my hands back to the ZeroCD drivers, which apparently are nowhere else to be found. At the moment (10/12/20), Linux Mint 10 does not recognize the stick at all, and Ubuntu 10 does the same after I removed the driver package to get my hands back to the ZeroCD files. Apparently Nokia's modeswitch shows different disk content for Windows and Linux enviroments.

Anyway, in my opinion the trouble with Fonera 2.0n is the lack of real support for umts-modems. Whereas other routers got a pull-down menu where to choose the right make+model from, the Fonera2 seems to try going around ZeroCDs with only the usb-modeswitch, some luck and with a very general set of commands.

So far I modified at least the developer firmwares 2.3.6.1 and 2.3.6 (since SSH access is required to modify the files) and got unstable but usable connectivity with a Huawei E169. It takes less than 24h for the system to choke. Removing the dongle for a while might help, but normally a full power off is required. Got a powered USB-hub for it, too. With the dongle connected the overall system performance drops like the tail of a cow.

My quick and dirty fixes for the E169 were based mainly on http://wiki.fon.com/wiki/FON2-Tweak-3G-Irish3 , modifying numbers of the used usb-devices, '/dev/ttyUSB0' etc.

With the recent Nokia CS-17 I tried another approach with the usb-modeswitch, introducing it in "/etc/config/network" as "config 'interface' 'ppp0'" and updating the "/etc/config/firewall" with lines

option 'mtu_fix' '1' option 'network' 'wan ppp0'

, but in the end couldn't get usb-modeswitch to "eject" the drive. "cat /proc/bus/usb/devices" gave me these values for the stick:

T: Bus=01 Lev=02 Prnt=02 Port=01 Cnt=01 Dev#= 5 Spd=480 MxCh?= 0 D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1 P: Vendor=0421 ProdID=0622 Rev= 0.01 S: Manufacturer=Nokia S: Product=Nokia Datacard S: SerialNumber?= Icanhaz hidden C:* #Ifs= 1 Cfg#= 1 Atr=a0 MxPwr?=100mA I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage E: Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms E: Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms root@Fonera:/etc/usb_modeswitch#

I used vi to create the file /etc/usb-modeswitch.conf with values: ###################################### # Nokia CS-17 Internet Stick DefaultVendor?= 0x0421 DefaultProduct?=0x0622 TargetVendor?= 0x0421 TargetProductList?="1001,1406,140c,14ac" CheckSuccess?=20 MessageContent?="55534243123456780000000000000011060000000000000000000000000000"

The last 3 lines were completely random from some website configuring a Huawei to a linux desktop enviroment (slackware?), so that could be the problem. Windows device management gave me Hardware ids VID_0421&PID_0624 for the installed CS-17 modem driver. I really hope this would help and Finally make the 3G project take some steps ahead.

I could really use the USB 3G support since it's the only means of connecting and the main reason why I got the boxes in the 1st place. If it would be more stable, the Fonspot sharing would also serve the purpose better. I understand a bit more out of these than an average pig out of a moon rocket, but seems like many people are even more confused with the Fonera 2.0n 3G issues than I am. Let's get this thing on the move, eh?

Cheers and merry christmas, Juha the Flying Finn

Attachments (1)

Fonera2n-E169_CS-17.zip (2.7 KB) - added by anonymous 8 years ago.

Download all attachments as: .zip

Change History (3)

Changed 8 years ago by anonymous

comment:1 Changed 7 years ago by 3guser@…

I have gotten the Huawei E1820 (aka E182e or E1823) to work on a Fon 2.0g. The described method should even work on a 2.0n.

See the wiki page: http://wiki.fon.com/wiki/Huawei_E182e

comment:2 Changed 6 years ago by matthijs

  • Hardware changed from 2.0n (FON2300) to both
  • Status changed from new to investigate
  • Summary changed from Nokia CS-17, Huawei E1820, Huawei E169. Still no 3G support, oh dear why? to Support 3G dongle: Nokia CS-17
  • Type changed from bug to enhancement
  • Version changed from 2.3.6.1 (Gari jr.) to N/A

As part of the upcoming 2.3.7.0 firmware release, we're reviewing old open tickets to see if they are still relevant, which is why you get this response now.

We will revamp the 3G point at some point in the future. When this happens, we'll need to revisit supporting this 3G stick as well.

Let's make this ticket about the Nokia CS-17 only. Ticket #876 is about the E1820 and #450 is about the E169.

Add Comment

Modify Ticket

Action
as investigate The ticket will remain with no owner.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.